Roon Arc - initial setup issues with router

Roon Core Machine


Networking Gear & Setup Details

Orbi, WiFi, no VPN

Connected Audio Devices

Control4 rack system, although this issue doesn’t pertain to my home’s audio distribution.

Number of Tracks in Library


Description of Issue

Trying to set up ARC for the first time on my new Nucleus+. Roon ARC “not ready.” Router firmware is updated. Router dashboard indicates UPnP is on. Not sure how to fix.

Diagnostics: {
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

@RICK_JOHNSON, welcome to the community. A fellow user here, but the diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Thank you for jumping in to help so quickly! Please keep in mind that I’m a relative noob when it comes to all things networking, so I may not understand the how or why of certain recommendations you might make.

  1. UPnP appears to be on. See attached screenshot.

  2. I tried manually opening the port. That said, I’m a noob. Did I do this right? See attached screenshot.

  3. Settings appear to be the same on the Roon ARC screen. See attached screenshot.

  4. I’m not running a VPN. Where would I check to see if a firewall might be interfering?

  5. My modem is in bridge mode. Wi-Fi is solely through the Orbi.

I’ll get your thoughts on these items, then if needed, will address the other four items.

Thanks again!

Let’s see if you can try a couple of options. As a general rule, you want EITHER port forwarding or UPnP active, but not BOTH. So, let’s try the UPnP option first.

Keeping UPnP active, can you delete the port forwarding rule and see if ARC can work for you? The UPnP table looks correct, but I am not an Orbi user so cannot be sure.

If that does not work, then let’s look more deeply at the port forwarding options on your Orbi.

UPnP on and no port forwarding rules was where I started this adventure before my original post.

Sounds like we need to dive into port forwarding further.


Could you please post the error message which is show in the Roon App under Settings → Roon Arc?

In the screenshot a can’t read it completely.



The error message is as follows:

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“server_ip”:“”,“found_natpmp”:true},
“upnp_autoconfig”: {“status”:“NotFound”}


Thx for the post of your error message.

I don’t know your ISP and i think we should check if your ISP has implemented CG-NAT.

Would you be so kind and go to On this page your public IP will be shown (don’t post it here!!)

Then login to your router and look for a status page. On this page your WAN-IP address is shown (don’t post it here!!)

If your public IP address and WAN-IP address are not the same, then your IPS has implemented CG-NAT.

You could contact your ISP and ask the following questions (don’t made this up myself, just copied from @benjamin - Roon Staff: Technical Support).

Have you implemented carrier-grade NAT for my account level?
Have you fully implemented IPv6, or do you have IPv4 addresses available?
Can I request a static IPv4 address to support port forwarding?
Are there any ports you have reserved at the ISP level I should be aware of?

Kind regards,


While I found my public IP, I’m not readily finding my WAN-IP address. This leads me to a bigger picture point that I probably should have made earlier…

I have an Arris gateway/modem for AT&T internet. I have turned off wireless functionality on the modem. I have a Netgear Orbi mesh system to handle my wireless routing. Sooooo, should I be looking for the WAN-IP on the Arris modem or the Orbi router? Are there any other modem/router interplay issues I should be considering?

I’m going to head out of town tomorrow and am trying desperately to resolve this issue today. I’m not exactly sure of your role (community vs Roon support), but is there a way to flag this message to see if we can expedite? I really appreciate the help!


To clarify my role, i’m just a fellow community member.

To help you it’s for me and other community members important that you describe as good as possibly what your setup is.

So we have a AT&T router/modem and we also have the Orbi. Is your Roon Core attached to the Orbi? And your Orbi is attached to this AT&T router?

Kind regards,

Could you please write down

Thanks, Maartin. I had totally forgotten about my gateway/modem and wireless router being separate. Here’s the setup:

AT&T internet service. Arris modem/gateway model BGW210-70. That’s the main connection into the house. Wireless is turned off on the modem.

Main Netgear Orbi is plugged into the Arris modem. Orbi main/satellites provide the wireless connections in our house.

Roon core is a Nucleus +. It is connected wirelessly through the Orbi. No hardwire connection.

Thoughts re: next steps?

Your manual port forwarding rule here is set to 5000, not 50000

It’s also FTP instead of TCP.

1 Like

To clarify the previous comment by Jim:
FTP and TCP are in different categories of things.

FTP is a service protocol on a higher level, it is a file transfer protocol. It is associated with specific reserved ports, numbers 20 and 21. (All numbers up to 1023 are reserved for specific protocols). Normally these ports (and not 5000) would be automatically chosen when selecting FTP as the service that shall be port forwarded.
Because FTP is a service that the user would want to specifically use, its name is listed in the “Service Name” column in the screenshot. (It’s just a name for convenience)
FTP runs on top of TCP.

TCP is the underlying Transmission Control Protocol that is the basis for higher-level protocols like FTP, HTTP, or Roon. (The other option (but not for FTP, Roon, etc.) would be UDP. (Similar to TCP but simpler and without tight controlling of the data transfer. DHCP, DNS, and others use UDP).

In the screenshot, I don’t think we can see the column where TCP or UDP would be chosen.

What’s important for @RICK_JOHNSON:

The rule should use the port 50000 and TCP as the transport protocol. The Service Name (which in the screenshot is FTP for some reason) can probably be chosen freely and should be Roon for clarity.
Some routers only allow “Other” as the service name for services that are not listed in the menu (see screenshot below), then use this and nevertheless set it to use port number 50000.

This is where you choose the service name before adding the rule, it probably has an entry Other or some way to type “Roon”:

In the other fields, enter the correct IP (in your existing rule you chose, ensure that it is the correct one) and 50000, then click ADD. If you choose Other (or similar) as the service name, there will probably also be a way to choose TCP, UDP, or “Both”. Choose TCP.

For the sake of clarity, the port forwarding that I set up (and screenshotted above) was on my Orbi wireless router, not the Arris modem/gateway. Is that where I should be making these port forwarding changes, or should I be doing this on the Arris modem?

As for the manual port forwarding rule… I deleted the existing one and will start over. On the Orbi, when adding a new service, my options are FTP / HTTP / HTTP / ICUII / IP_Phone / NetMeeting / News / PPTP / QuakeII-III / Real-Audio / Telnet. TCP isn’t an option, and if I’m understanding your comment to @Jim_F correctly, FTP is the correct choice here.

I’m now going back into the Orbi port forwarding settings to start this one from scratch. Let me know if this is the proper way to set up the service.

On that screen, if I include the “.16” at the end of the IP address and then click the Add button, this is what I see:

Note that using this method, the ports are automatically set to 20-21. I assume that I should be setting this up using the “add custom service” button back on the main screen (screenshot above), and then I should manually set the port to 55000? If that’s the case, let me know if the following screenshot looks like where we should end up.

Thanks again for your help!

The port numbers must be correct everywhere. However, the added info that you have the AT&T router/modem and the Orbi wireless router makes me think that you probably need 2 daisy-chained port forwarding rules, one on the AT&T and one on the Orbi. Do both devices allow the setting of port forwarding rules? If yes, do this:

  • The AT&T modem is the external interface that gets the ARC connection from the outside, and it must be able to forward the traffic from its external IP & port 50000 to the internal network, this being represented by the Orbi in your setup.
  • Set up a similar rule for port 50000 on the Orbi, so that it takes the traffic that is coming to its incoming port from the AT&T, and forwards it onward to the Core

So on both devices, one rule each:

  • Name “Roon” (or Other, whatever is possible), port 50000, TCP
  • On the AT&T use the IP of the Orbi in the rule (it must forward the traffic to the Orbi) and on the Orbi use the IP of the Core (it must forward the traffic to the core)

Okay, I’ve made some adjustments, as I realized that I had set the port to 55000 rather than 50000.

First, here is my Orbi main service screen:

Next, here is the detail for the Orbi service I set up:

Finally, I changed the ARC Settings to port 50000 as well. I still get this error message:

Detail of the ARC settings error message (in case the pic isn’t clear): {
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“server_ip”:“”,“found_natpmp”:true},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}

Thoughts re: next steps?

The Orbi rule looks more or less fine now. Choose TCP here:
though it most likely does not matter if it says TCP/UDP (this just sets implicitly 2 rules, for TCP and for UPD, but ARC will only use TCP). Still, just TCP is the cleaner way.

However, see my previous post above yours: You probably need another, similar rule as described on the AT&T, if it allows setting up forwarding rules. Just use the IP of the Orbi in this rule

Sorry, your message came through as I was typing my message. I now see I need to set the AT&T modem port forwarding rule as well. I assume I would need to set a static IP for my Orbi in order to set up the modem rule, correct? If I set a static IP for this purpose, could that mess up anything else in my wireless world?

Ok, I can’t seem to find in the AT&T modem dashboard exactly where port forwarding would be set up. I’ll do some research and get back later. Thanks again!