Roon ARC - iOS cellular connection to Core fails ("poor connection - retry") + Core crashes

Roon Core Machine

iMac (Retina 5K, 27-inch, 2017)
4.2 GHz Quad-Core Intel Core i7
32 GB 2400 MHz DDR4
MacOS Monterrey 12.6 (21G115)

Networking Gear & Setup Details

Internet > Three Mobile Home Broadband 5g hub (IP Passthrough) > Ethernet > Google Wifi [MESH] > Ethernet > Core (iMac)

No double NAT (this was resolved by switching on IP Passthrough on the Three 5g hub, and the Roon Core reports that Roon ARC has been successfully configured.

No port forwarding rules in place.

Connected Audio Devices

iPhone Mini 12 (iOS 15.7) - via Wifi and/or cellular connection (5g or 4G - also via Three Mobile)

Number of Tracks in Library

166,719

Description of Issue

Roon Core usually works seamlessly on my home network, with the iPhone 12 Mini in question as a remote and endpoint, via the Roon Remote iOS App.

The same appears to be true of the iOS Roon ARC app, when connecting to my home networking, via WiFI.

The issue arises every time I use Roon ARC on a cellular connection (5g or 4g) inside and outside of my home, both walking or driving.

The Roon ARC iOS app plays music briefly (plays a few tracks, if a connection is made at all), but then it loses its connection with the Core, when it will display the UI error message “Poor Connection - Retry”. This problem typically loops from hereon, and connection cannot usually be re-established (with/without toggling cellular access and/or shutting the iOS app down and restarting)

Meanwhile, where this happens, my Core also crashes at the same time. The Roon Core will then require a restart (If this is not done, the UI Home page doesn’t load content, and flashes the roon logo without resolving).

I really want Roon ARC to work - it has so much promise! I’ve battled to resolve an initial double NAT issue in support of it, but I just can’t get it going consistently while on a mobile connection in transit.

Any thoughts / ideas / help appreciated - I suspect that there may be a connection with the mobile device moving from WiFi to Cellular (and vice versa) and seemingly some issues with any changes to - and stability of - my cellular signal?

1 Like

Welcome to the community, @Greg_Ince.

Is your core connected over Wi-Fi? If so, can you try an Ethernet connection directly to your router?

Hi Martin! Thanks.

No, not connected by Wi-Fi.

As detailed, the core is connected to my network by Ethernet (detailed above - wired to a Google Wi-Fi router, which in turn feeds other mesh access points). Furthermore, the iMac my Core runs on has Wi-Fi turned off completely.

Greg

Okay, thanks, so there’s no backhaul over Wi-Fi? Since you’ve not setup port forwarding UPnP must be working for you. And Three definitely provide you with an IPV4 address?

Hi @Martin_Webster,

Backhaul - I don’t know for certain, but I don’t think there would be backhaul over wifi on the network, as it’s configured?

core > ethernet > main ‘google wifi’ router of wifi mesh network > ethernet > Three Home Broadband 5g hub (2.4 & 5 WIFI TURNED OFF) > internet via cellular WAN

UPnP - yes, seems to be working - driven by the Google Wifi router which has the setting on (the setting is not set to on, on the Three Hub)

IPV4 - as for Three providing me with an IPV4 address, I believe so. Whatsmyip identifies an ipv4 address, but cannot detect an ipv6 address.

Is that conclusive / what you mean?

Furthermore, in case it’s helpful, I already have ipv6 turned off on the google wifi mesh router. I think that the google router should be the only device ‘routing’, as it is receiving IP from the Three Home Broadband 5g hub via IP Passthrough (bridging wasn’t an option, and it was this option that solved an initial double NAT problem, and allowed Roon ARC to be confirmed ‘ready’ by the Core ). So I’m guessing IPV6 may not be relevant, but don’t really know?

Thanks,

Greg

I’m trying to understand if the Google router has an Ethernet switch connecting the core directly to the Three router.

Hi @Martin_Webster ,

OK.

The iMac running the Roon core has wifi turned off. It is connected by ethernet to the the main ‘google wifi’ router. The ‘google wifi’ router connects to the the three hub, also by ethernet.

Wifi is delivered in the house, via a google wifi mesh network, that is driven by the ‘google wifi’ router above, in conjunction with other wireless mesh access points, but the access to the internet for the Roon core on the iMac would be wired, and is connected, as outlined above.

Sorry, it’s possibly confusing that I’m referring to one of the routers as ‘google wifi’ in this context. My home mesh network is wifi, but the roon core, and its connection to the internet from the machine it’s running on is wired.

Does that help?

Below is the base of the google wifi router - one ethernet connects to my iMac, the other connects to the three 5g home broadband hub. The middle is the power cable.

1 Like

Hi Support,

Thanks to @Martin_Webster for his enquiries yesterday, but I just want to say that this frustrating behaviour continues today.

Same pattern this morning - a short period of ARC access, via the iOS App, whilst on a cellular connection. I played three tracks, from a short, three-track album, whilst walking around my neighbourhood, well beyond my home network’s range.

At the end of playback, I then tried to play something else in ARC, and once again, I hit the “poor connection - retry” message.

When I got home a few minutes later, I found my Core had crashed, once again. As before, the Core had frozen up. Whilst the UI was responsive, it was unable to load anything beyond the pulsing Roon logo one sees on the application’s start up.

To add to this, I was successfully using ARC over wifi, connected to my home network last night. I found that this activity also lead to the “poor connection - retry” message, and then resulted in my core locking up.

I mention this as it suggests that this may not be an issue that is exclusive to remote cellular connection, after all?

Greg

The thing that stands out here is the fact this is a 5G connection to WAN. I’ve run Roon off a 4G router in the past and it worked well until the show I was at filled up and competition for bandwidth caused issues.

1 Like

Hi @Henry_McLeod ,

Yes, it strikes me as a potential flag for issues, too, and not just matters of bandwidth, I suppose? I think my hub may also switch between 4g and 5g in certain circumstances.

I’m not really sure what questions/diagnostics to run, as the set up of ARC has been on the edge of my technical understanding when it comes to routers, etc - hopefully, Roon support will be able to chime in to this thread, as they may be able to give me a further diagnostic steer.

Thanks,

Greg

Oh dear. My Roon Core has crashed, once again, after I opened ARC on my phone, while I was connected via wifi to my home network. This time, however, I was simply reviewing the app’s settings, and hadn’t even tried to play anything.

I’m increasingly puzzled by what’s occurring, as and when I try and make use of the iOS Roon ARC app, both inside and outside my home network…

I would look at upload/download speeds and test using ARC with WiFi disconnected thus forcing your setup to behave as if you were away from. Reset ARC and synchronise first then disconnect WiFi and see how it goes.

1 Like

Thanks, @Henry_McLeod - I’ll investigate, and what I can find out!

Well, I’ve investigated matters, as suggested above by @Henry_McLeod, following initial assistance from @Martin_Webster.

I’ve not really noticed any notable or significant issues with upload/download speeds that ought to be the culprit. Especially not from home - this has been the case with my 5g Home Broadband Hub, and Mobile Phone via its 5g (and 4g) connections. There have been fluctuations, but little more than that.

Like most people, my cellular signal does fluctuate in the nearby area, whilst I’m walking, so it’s likely that any handshake with the core could potentially be impacted by this, as I move from mast to mast, and from 5g to 4g. That said, my phone has often been able to connect directly to Qobuz in those moments of notice of ‘poor connection’ notification from ARC, when I’ve gone on to try this. This has made me think that this may not be just an issue relating to speed/strength of signal.

Happily, what I can report today, is a potential improvement, in the last day or so, after making the following changes to my set up:-

Roon ARC:

  • I reset ARC

  • I left Roon Radio on (I turned it off immediately at install to preserve cellular data when on the move).

  • I’ve specified ‘Original Format’ on WiFI and ‘Balanced’ on Cellular (as opposed to simply leaving ARC to ‘Automatically Pick Best Quality’)

  • I’ve actually downloaded a couple of albums to test that feature (but when i’ve been using ARC, generally, I’ve been trying to play things I’ve not played before, so as to avoid being wrong footed by caching)

Roon Core:

  • I turned off LastFM scrobbling on my Core (Normally, I have it on, on my Core, but not on my streaming service, to avoid double scrobbling issues I’ve encountered, but I wanted to remove anything additional)

Roon Remote App iOS

  • I also turned off the beta “Enable Lock Screen Controls” setting in the iOS Roon Remote app, just incase having both installed, and using both on the same device was causing some kind of interaction/issue.

Having done the above, I’m wondering if the Roon Radio setting is the key - if it somehow enables/encourages my iPhone to call back to my Core in a more continuous manner that simply playing an album didn’t require, and that this somehow interacts poorly with signal fluctuation while I am on the move.

Will keep monitoring for the next few days, and if I can find the energy reverse some of the setting changes I’ve made since resetting ARC.

Happy to share useful logs with Roon Support, if that may be helpful, too!

Greg

Hey @Greg_Ince,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

I wanted to check in on this thread to see if you were still experiencing connection issues between your core and arc? If so, please take note of the date and time this happens next and share it here.

From there, we’ll enable diagnostics on your account to take a closer look :+1:

Hi @Benjamin,

Thanks for coming back to me. Roon ARC does appear to have been stable since the update before last was rolled out.

Now, when I do get poor connection messages, from time to time, this doesn’t result in failure to reconnected and my core hanging.

I’ve not yet upgraded the iMac that I have my core on to Ventura, or, my iPhone to iOS 16 - this is actually because I don’t want to damage ARC stability, now it has apparently stabilised.

Are you able to advise on the likelihood of ongoing stability if I were to update MacOS and iOS? I’m loving having ARC working, and don’t won’t to break it now it is, without taking advice from you guys first! :slight_smile:

In the meantime, I’ll make a note of the date/time of any further connections issues, and come back to you on that front where these may arise.

Thanks,

Greg

Hi @benjamin after the more general outage across Sunday and Monday for ARC, I hit the issue in this thread again old this lunchtime.

It was between 13:00 and 14:00 UK local time. The issue cropped up after a period of Arc running fine for about 15/20 mins.

Could you investigate the log and see what led to the reappearance of the poor connection failure detailed upthread, please?

The issue was resolved by a restart of my core, having continued on cellular and on Wi-Fi before the restart around 5pm.

I have a sneaking suspicion this could be linked with scrobbling?

Any help gratefully received - my wife can’t always be at home to restart my core! :wink:

Hey @Greg_Ince,

Thanks for following up, and I’m sorry to hear you’re running into connectivity issues! We weren’t able to find anything specifically linked to scrobbling with Lastfm, but that’s an interesting theory.

When you disable this feature, can you confirm the crashing of your core stops? Test it a few times and report back :+1:

Beyond that, I’d be curious to see if you’re core continues to crash with a fresh database. Please follow the steps below:

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

I’ll be on standby for your reply