Roon Arc not working!

Hi Guys ,

I’m quite excited about Roon 2.0 with Arc . I reinstalled everything to the new app but ARC is not connecting . This is the error I’m getting

{

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},

“external_ip”: {“actual_external_ip”:”xx.xxx.xxx.xx”,”router_external_ip”:null},

“natpmp_autoconfig”: {“status”:“NotFound”},

“upnp_autoconfig”: {“status”:“NotFound”}

}

I replaced my IP address with ‘Xs’

I’m running UDM pro as my router . I did follow the recommendation of Roon on manual port forwarding.

IP address: The IP address of your roon core

LAN/Private/Internal Port: Port 55000

WAN/Public/External Port: This port must be the same as the LAN/Private/Internal port

But still the error remains . Any help would be appreciated .

Cheers,
Emmanuel

Internet provider? Provider modem in bridge mode?

Optus

The modem is not on bridge mode .

Thanks
Emmany

If it isn’t bridged you have a double NAT.

This is the Topology

The modem to , UDM Pro to Unifi PoE 24 port switch .

All the devices including the roon core is connected to the switch .

Does it make any difference ?

Cheers

My understanding is that NBN modems in Australia are “locked” so they can’t be configured to be in bridge mode (I’d be happy to be wrong as I have a very similar problem)

A post was split to a new topic: Issues setting up ARC with my system

Does any of unifi Firewall Rules I created have something to do with it ?

There’s nothing you can do with just port forwarding on your UDM (AFAIK, I’ve dealt with the same issue) if the ISP modem/router is doing NAT. UDM is designed to be your actual Internet facing router, not be stuck behind a separate NAT router. Some ISPs allow you to set their router in bridge mode, so that your UDM gets an actual Internet IP address, others do not. Some ISPs (like the one where I have the UDM) won’t remove their own NAT, but they will create a port forwarding rule to your specification that forwards to your UDM’s local IP address, and then your rule on the UDM should work, or at least this worked for my setup.

I may be wrong but I think most Aussie ISP NBN modem/routers are locked but some can be bridged. Google would be your friend here.

I’m with Aussie broadband and I didn’t take a modem from them. Instead I took the supplied network termination device (NTD - I think) which isn’t a modem or router I don’t think and needs a router to be attached to it. I have connected that to my Netgear Orbi router and ARC set itself up with no issues.

To the OP, do you have a NTD or did your ISP send you a modem/router? If it is the former you shouldn’t have double NAT going on. If the latter you almost certainly do I would say.

Roon Arc is still not working !!! , Can anyone from Roon official support address this issue ?. I know many have complained about it .Anyone else who had this problem and found a solution ?. I hope Roon will fix the issue soon .

That’s interesting @largestgasman as I have had multiple NAT issues at two premises with Aussie BB because they usage CG-NAT, one was a FTTN connection and the other was FFTP. First of all I got around it by paying extra for a static IP address then I found out that you can opt out of CG-NAT by calling ABB’s support.

I think @Emmanuel_Charles is running into the same issue because of CG-NAT, without knowing what model modem he is using we won’t be able to find out if it can be set up in bridge mode.

Emmanuel you need to speak with Optus support and explain to them that you have a music service that requires port forwarding set up on your router. I’ve just checked and Optus do use CG-NAT.

Hopefully @support will be able to help you but as it is the weekend you may have wait for a couple of days.

Hi Guys ,
Thanks for bringing in more info to fix this isse of Roon arc not working for many . I just want to update info based on the above comment . I do know what Modem I have . It is a HFC Coaxial modem box from nbn , most probably the Arris Touchstone CM8200 . Im not able to get into the modem to configure it on to bridge mode . All I can do is to try various options on the UDM pro but of no avail . Has any Optus customers facing similar issues ?. Im not sure if optus is on CG-NAT , some people say yes but some people say otherwise . Its a bit of a conundrum here , I was so excited with the Arc app but , not been able to use it . Hope there will be some kind of solution for this . Cheers . Emmany

The easiest way to know is to call them. Then, if so, you already have them on the line to request a change.

1 Like

I called them they are asking me to go for static IP . Can someone at Roon just say that we need a static IP , so that Roon Arc can work ?. So that I can go ahead and get on with it .

Hi @Emmanuel_Charles, I don’t think a Roon representative will say this as everyone’s case is different. I was able to opt out of CG-NAT with Aussie Broadband but I have done some research on Optus and it appears that there is no option to do that.

Your best bet is to go ahead with a Static IP because as far as I am aware there is no way to set up port forwarding with Optus CG-NAT implementation (or any other Australian ISP’s CG-NAT).

Hi Mate , Thanks a lot . I think I will go ahead with the Static IP . Hope it works…fingers crossed… :slight_smile:

2 Likes

Gosh I hope so too.

I changed it to static IP and still Im getting the same error . :unamused: . Does it have something to do with the unifi firewall ?. I dont know what to do …

Hey @Emmanuel_Charles

I am really surprised. I think it is time to flag @support you really need their help.

I am confident they will be able to help you.