Roon ARC Sync Failures [Investigating]

Roon Core Machine

Windows 11 256db Ram

Networking Gear & Setup Details

Linksys 1c1900; plus TP Link Switch, Core and one Roon remote connected ethernet; everything else wifi

Connected Audio Devices

Stack Audio Link II

Windows HP360 Lapto Win 11
Android phone Samsung S22 Ultra; Android 12

Number of Tracks in Library


Description of Issue

Reinstalled my Core hoping that would get ARC to work properly (previously it connected, but failed to index my library)

Deleted and reinstalled ARC on phone. This is what I get if I open ARC:

It just stays that way.

I have “ready” in my Setup for ARC.

1 Like

Hey @danny2,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

Following up on this thread, I wanted to check in to see if you’re still running into issues getting Arc squared away? I would make sure you have the latest Roon and Roon Arc build installed on your core and mobile devices :pray:

I’ll be monitoring this thread for your reply

Issue still exists. I have latest versions installed.

Hey @danny2,

Please remove arc from your phone, power down your phone, restard and reinstall. We’ll need to start on a fresh slate to grab a set of logs from your Android to investigate further.

Please run through booting up arc a few times to recreate this error. From there,

Connect your PC to Android phone and install ADB (instructions are here (all platforms)). Then:

  1. Type adb shell in terminal
  2. Type logcat v (ref: Logcat command-line tool  |  Android Developers)
  3. Reproduce the problem and let terminal print logs for 3-5 more seconds
  4. Select output from the moment you started the reproduction of the bug till the very end
  5. Upload the log here and let us know once you have done so:

I’ll be on standby for your reply :+1:

Couldn’t get it to work.
You need to give me much better instructions that totally walk me through it, step by step.
No everyone is used to doing this kind of stuff.

Hey @danny2,

Let’s take a few steps back and try this first:

Please remove arc from your phone, power down your phone, restard and reinstall. Make sure no other apps are running during this.

I would also suggest giving your roon core a hard reboot, as well as your router and network.

Let me know if this issue persists after doing this.

Did all that. Still same issue as 21d ago.

Still doesn’t work for me after updates.
ARC doesn’t even open fully. Hangs before it gets to the syncing screen.
I opened another thread about it.

Same for me.

No, it hasn’t been resolved. Just no error message now. But still doesn’t work.

Hi everyone,

@danny2, @Alexander_Bashlaev, @Mycoft_Holmes, thank you for your assistance and patience so far. We’ve moved this thread into a separate topic as this issue appears distinct from the other thread. The team has investigated an additional sync issue that has intertwined with the original reports, and we’re escalating to development.

Diagnostics suggest there may be issues syncing after ARC has been resetting, setting off a feedback loop that prevents the database from loading profiles.

As a first step, would you please try the following?

  1. On your home WiFi network with a strong connection, fully delete the Roon ARC app.
  2. Power cycle the mobile device.
  3. Attempt to install and open ARC again.

It’s possible this may resolve or temporarily relieve the issue. In any case, it will equip our technical support and QA teams with a precise timeline of the issue in diagnostics so we can quickly pin it down and implement a fix.

Thank you!


I’ve done the uninstall, power cycle, re-install multiple times over the past month. Doesn’t make a difference. Just did it again. No change. ARC still doesn’t open fully.

For me it helped after a full reinstall to clean the cache and storage of roon arc. (pixel 5)

1 Like

Works for me now - thank you for your efforts!


Just updated to the latest Core and ARC . Shut down server and phone and restarted both - no improvement. Still ARC doesn’t open fully after hitting the opening page with the symbol (as seen above).

I have the same problem. On the Samsung GALAXY S10PLUS (android-11), 2 month I see just a white screen. Reinstalling and shutting down the device and updating versions of Nucleus and Arch do not help.
On the my player iBasso dx300 from the first day ARC works fine without any dances. Dear RooN, do something please, it’s been a problem for 2 months already.

Hey @danny2 and @Alexey_Lavrov,

This may be database related. Let’s test running things on a fresh database to see if your issues persist. Steps to follow below:

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

Let me know how things run after the above :+1:

Did all of the above. No change. Still get Roon Arc opening page and hang. No actual connection.

Hi @connor,
I don’t know what exactly helped, but after reinstalling the Roon Arc app and restoring the Roon server from a backup on a different machine, now everything works.

Okay, just installed Roon Arc on my new iPad, and…it works.
So why doesn’t it work on my Android phone (Samsung S22 Ultra)? It has Android 13.
It’s clearly something to do with the phone-Roon connection and not my server, modem,router, or ISP.