Roon blank screen after minimising window

I Have to restart roon client on windows 10. I am running roon server on a mac 1.2 154b. I am running roon client to control playback on a windows 10 home 64bit with all updates. Roon client on win 10 is 2.1 154b.
I open roon client and all is well. I leave in background and switch apps all is fine. If i minimize roon client and bring back up the roon window is blank. I must close roon client and reopen then all is fine unless I minimize client again. Mac server works fine and plays as expected and not affected and does not require any intervention. No error messages on windows client.

I’m afraid this is a known problem on some Windows systems. It is an issue with the (Intel) graphics driver. On some machines (e.g. mine), there is a workaround - just change the window size from fullscreen to windowed and back (or vice versa), and this clears the blank screen. It doesn’t work on all systems though.

1 Like

Sorry I missed that, thankx for the reply!

I’ve merged the posts into the existing support topic.

Just reawakening this old thread to say that I’ve sorted the blank screen issue on my desktop PC. It has both Intel Graphics and a Radeon graphics card installed.

The trick was to create a profile for Roon within the AMD Radeon Settings application, and in that profile switch ON the OpenGL Triple Buffering setting. Now minimising Roon no longer produces a blank screen when the window is reopened.

As an aside, I’ve rewritten the section on configuring Radeon graphics card settings here - it was referring to the AMD Catalyst Control Center application, and that has long since been replaced by a completely redesigned AMD Radeon Settings application.

2 Likes

That’s awesome @Geoff_Coupe – thanks for letting everyone know, and for updating the documentation as well.

Just as a note, I discussed this issue in a little more detail here:

https://community.roonlabs.com/t/roon-becomes-unresponsive-ghosted-out-completely/13683/10?u=mike

I know I am re-opening this thread again and I know there is much correspondence and suggestions regarding this issue. I get the white/blank screen and have tried all suggestions to fix it. My Dell XPS 8700 system only has a Radeon R9 200 card with no integrated graphics. I have tried Geoff_Coupe’s suggestions for configuring the Radeon card settings but to no avail.The latest incarnation of the Radeon settings offers many features that can be turned on or off in addition to the OpenGL buffering. I think I read about one other user with a Radeon-only graphics card who experienced the problem and I believe he had (like me) a Dell XPS system. Is there anyone else out there with a Radeon graphics card and no integrated graphics who has (or does not have) the Roon blank screen problem and what kind of computer are you running it in?

It certainly is a very annoying problem and thanks for anybody’s additional input.

1 Like

I have a Dell XPS 8900 and a Radeon R9370 and no integrated graphics and still have the same problem. I added a profile for Roon with OpenGL Triple Buffering but still have the same problem.

Problem is gone after upgrading Radeon software to 17.10.1711

2 Likes

To resolve the blank screen after minimizing issue, I’m considering upgrading my older Lenovo IdeaCenter Q-190 PC with integrated Intel HD Graphics (version number unknown) to a Lenovo ThinkCenter M700 Tiny with integrated Intel HD 530 Graphics, and a 256GB SSD.

I absolutely love the small/tiny form factor (7” x 7.2” x 1.4”) of this PC.

Can Roon confirm this new Lenovo PC with integrated Intel HD 530 Graphics will properly display/redraw Roon content after the Roon window is minimized or should I look elsewhere for a new Roon core computer?

Confoundingly, some other models of the Lenovo ThinkCenter line of PC’s list only integrated graphics (no mfg. or model number). How do I insure I don’t purchase a new PC that exhibits the problem I’m trying to solve.

Are you looking to run your Core on this machine or just a Remote? If you’re looking to run the Core, you should confirm the CPU meets our recommended minimums.

As far as I know, we haven’t heard any complaints about the HD 530.

That said, I should mention again that this is a driver issue, not a hardware issue or Roon issue (if it was a Roon issue, we would fix it ;)) You can tell it’s a driver issue since we’ve seen common culprits (like the HD 4000) work on other configurations, and on Mac.

So, just to be clear, since this is a driver issue I can’t guarantee that Intel’s drivers work now, or will always work in the future. I also should mention that this issue affects a small percentage of configurations, and many people have had success updating to newer drivers.

I don’t know a lot about the Lenovo you’re looking at, but I wouldn’t let the mere presence of the Intel dissuade you from purchasing it if it’s going to meet your needs otherwise – I would just make sure they have a decent return policy in case you end up unhappy for any reason.

1 Like

I am here experimenting with Roon features and communication with the community forum but I can not minmize Roon and come back to it and maximize it again. I get a blank requiring me to close and re-open the Roon desktop app.
I think I read awhile back it was a Windows issue but it seems Roon could fix it.
My system: Roon Rock with Windows 10 PC control all wired network

Hey Frank – you can read the thread above for more information about this issue. I went into some further detail about the problem here:

https://community.roonlabs.com/t/roon-becomes-unresponsive-ghosted-out-completely/13683/10?u=mike

The best path forward here is to make sure you’re using the latest drivers for your graphics card. Let us know if we can provide additional help here – we’ll do what we can, but unfortunately this is a graphics driver issue, meaning it’s not something we can fix directly.

1 Like

Disappointing to read that although this issue has been around for the last 2+ years the devs haven’t seemingly released a fix yet. I’ve just started a trial and am having the blank screen issue after minimizing on a Win 8.1 Sony SVT13 laptop with integrated Intel HD 4000 graphics.

Updating to the latest Intel graphics drivers has made no difference.

It’s a driver issue, and as such not in the hands of the Roon Labs devs to fix. It’s down to Intel to come up with a driver fix. Having said that, I’ve seen this issue come and go a couple of times on my main PC, as different versions of the Intel driver appear. Currently it’s OK.

One workaround that will probably work for you is to install the 32bit version of Roon on your laptop.

I’d dispute the claim that it’s purely a driver issue - Roon is the only program that displays this behaviour. 32 bit version behaves in the same way. Seems like Roonlabs are are passing the buck…

That’s your opinion, of course, and you’re entitled to it. I have a different view.

It is a driver issue rendering OpenGL. Roon uses OpenGL3 for rendering its screens. You’ll probably not have many apps using OpenGL on your system, but there are other examples (mainly games, but also some Outlook builds).

That does not make it right, of course – but as @Geoff_Coupe said, it’s outside Roon’s realm of influence. Running up to date software and drivers appears to cure most cases.

Well, all drivers up to date and still the problem persists. Assuming there is a bug in OpenGL I’d have thought Roonlabs would have come up with a workaround by now. If Roon was open source and free to use, I could live with this issue/bug - however, it not - it’s expensive. No patch, no subscription.

Hi,
Have you checked on the Intel site, I’ve found that normal Windows updates tend to lag a little.