Roon Bridge Easy Installer fails on Ubuntu Linux RPi4 - "cannot open html: No such file" [Solved]

After the wipeout of my previous SD card when trying to update for Roon 2.0 compatibility, I am now finding the installer fails on a brand new sd card with a fresh installation of Ubuntu 22.04.1 LTS (GNU/Linux 5.15.0-1014-raspi aarch64).

Here’s what I get when following the instructions to use the Easy Installer script to the letter:

ubuntu@ubuntu:~$ curl -O
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   194  100   194    0     0    860      0 --:--:-- --:--:-- --:--:--   858
ubuntu@ubuntu:~$ dir -l
total 4
-rw-rw-r-- 1 ubuntu ubuntu 194 Sep 22 10:13
ubuntu@ubuntu:~$ chmod +x
ubuntu@ubuntu:~$ dir -l
total 4
-rwxrwxr-x 1 ubuntu ubuntu 194 Sep 22 10:13
ubuntu@ubuntu:~$ sudo ./
./ 1: cannot open html: No such file
./ 2: Syntax error: redirection unexpected

Have I missed something? What should I do? Thanks in advance

Hi, @John_Warden, thank you for the report. I think there there is a problem with the url in your snippet.

I tried your command: curl -O

And got the following file (html with 301 response code) downloaded instead of the installer script:

<head><title>301 Moved Permanently</title></head>
<body bgcolor="white">
<center><h1>301 Moved Permanently</h1></center>
<hr><center>nginx/1.10.3 (Ubuntu)</center>

Nevertheless, in case I use https:

  • curl -O

It works as expected for me and downloads the installer script.

Could you, please, try that and let me know if the issue is resolved?



1 Like

Perfect! The installer is now running fine. I’d saved the instructions from my previous install in a text file so I could rebuilt easily … and I didn’t spot that the URL had changed slightly (https,

Thanks. In fact the install has finished while typing this and the core has identified the Roon Bridge already. Great

Glad to hear that your problem is resolved :slight_smile:




This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.