Roon Bridge for ARM: a beginner’s guide to Raspberry Pi and Cubox-i

Thanks for the guide Rene @RBM. You made the installation really easy.

Set up my Pi3 with my IQaudIO DAC and am running it using wifi. It’s working great with no dropouts, including my 24/192 music.

Very cool. Now I can group music through my whole house.

Cheers, Greg


Why is your mini on Wifi? Do you have the option to use a wired connection?

Hmm, have just got a case for my Pi3 and installed everything using this excellent guide.
This Pi is WLAN enabled and that seems to work just fine. It is visible in Roon as an endpoint and i have it configured as it ought to be. Disabled on board audio and connected a 32bit-384khz/DSD64-DSD128 DAC via USB. (It has got an XMOS Interface)
This DAC is directly connected to a power amplifier and then to my 2:nd set of speakers. In other words, the volume control is used on this one, unlike my wired Pi2. Everything works fine up to about 24/96 but higher res files have some intermittent cracks and pops occasionally. But, on this Pi3 i can’t get DSD playback to work? All i get i load of static noise
and hiss. The music is barely audible in the background…
Did have the same issue earlier when trying moOde player, and was advised to add this:
to the beginning of line in /boot/cmdline.txt

That worked just fine on the Pi2 but on the Pi3 it doesn’t seem to help… :confused:
Any tips?

Do you send out DSP native or via DOP? Not knowing which exact DAC you employ – you may need to switch to DOP (Settings > Audio > Playback > DSD Playback Strategy).

If your Pi is starting to distort over 96Khz PCM, that may also be a culprit: DSD64 is equivalent to 192Khz PCM, while DSD128 equals 384Khz PCM.

This may be too much for your Pi’s USB ports, that share one system bus with networking (wired and Wifi). Also, the Pi’s wireless is not the greatest, which will be especially manifest at higher bitrates.

1 Like

It is an SMSL M8 DAC Rene, it doesnt handle native DSD so the setting is DoP. Just to check, i took the DAC and attached it to my Pi2, which also has a PiFi Digi+ SPDIF board, and after a few seconds i had it streaming DSD64 (DoP) without a glitch. (The Pi2 is wired though?!?!)

That does make me wonder what happens when you disable Wifi on the Pi3 and hook it up wired for now – you really do need a strong and stable signal for DSD. The pops at anything over PCM96 are suspect.

Have tried that too Rene. Same result though, no DSD playback, just pretty loud static and hiss.
Occasional pops and clicks on HiRez PCM material (over 96khz) :frowning:
As seen in the pic the troublesome Pi3 is running Linux 4.4.11 where the well functioning Pi2 is running 4.4.9, i will try and rescue an older Jessie Lite from my other hard drive and see if that does any difference.

Have you tried disabling Bluetooth on the Pi3? I remember that there was an issue with bluetooth and hifiberry add-on cards. I am not sure if it is already resolved. Add the following line to the config.txt:


I just searched for the article and found it again.

It has been fixed, but it never hurts to disable bluetooth… :wink:

Only because until recently the mini was moving around a lot. Hardwired now and haven’t had a single problem.

1 Like

I have successfully gotten RoonBridge working on a Pi2 with Hihiberry DAC+ hat (thanks Rene!) using a Synology DS1515+ as the roon core (thanks Christopher!).

However, whenever the roon server has restarted, such as after updating the nas or shutting down roon server to properly backup my database, Roon will not find the RPi automatically. This is solved by rebooting the RPi after Roon server is running. Is this expected behavior? Is there a way to force roon to check again for network devices, or is RoonBridge configured to only be visible on initial startup?


RoonServer should find its Bridges automatically after a restart of either Server or Bridge. I run RoonServer on a Linux-based NUC – I stop RoonServer automatically each night, backup the Roon database and start it up again. None of my ARM-based RoonBridges is ever missing when I wake up. :slight_smile:

Perhaps @crieke can add something here from a NAS perspective?

I have not noticed this behavior in my setup. I’ll setup a pi and and try to reproduce this here. But I suspect the cause of this on the bridge device.

Blame it on the Pi… :wink:

Are both the Pi and the Synology wired? Anything special about your network? Is the Pi still accessible through SSH when the NAS can’t find it? What happens when you restart Roon Bridge instead of the Pi? (SSH in and issue ‘sudo systemctl restart roonbridge.service’).

Questions, questions…

My suggestion is also to try it again with an ethernet connected pi (if it was connected over wifi before).
Maybe it has something to do with the sleep mode of the wireless module of the pi. This can could some trouble.
I just prepared a sd card and will try it myself…

2 posts were split to a new topic: Roon Server becoming sluggish over time

Thanks for all of the suggestions.

I was running the Pi wireless, but just plugged into a wired connection, and see the same behavior. I can still ssh into the Pi (normally over Wifi, but now over ethernet too). I also confirm that “sudo systemctl restart roonbridge.service” causes the Pi to show up as a network audio device in roon after restarting RoonServer, similar to rebooting the Pi. As long as RoonServer remains running, the Pi never disconnects from roon as an available audio output (though, I’ve only had roon installed for about a week now, so caveats about a small sample size are in order.)

Roon Remote on my MacBook Pro has no problem automatically finding RoonServer when it is rebooted. Only RoonBridge on the Pi gets lost.

I should also note that in order to stop RoonServer, I am not using the command line, but use the PackageCenter in DSM to stop Christopher’s RoonServer package, and starting it again.

This doesn’t cause RoonServer to reinstall, but seems to only stop the RoonAppliance, RoonServer, and RAATServer processes.

I just tried turning off wifi sleep on the Pi:

pi@DownstairsRoon:~ $ iw wlan0 get power_save
Power save: off

…but no change in the reported behavior.

I may try completely reinstalling the Pi from scratch this weekend.

I tried to reproduce this with my synology and a pi3.
It worked like it should here. Even after a reboot of the Synology.
Pi3 was connected over ethernet.

When using a pi as end point and “use device controls” is selected what is actually controlling the volume when I adjust in Roon? Current Pi is connected to an external usb dac. My current preamp doesn’t have a remote so it is nice to have some volume control. If I select fixed volume I have to check the box for max volume to get Roon to output actual full volume.