Roon Bridge Linux not visible

Been using Roon for about a year, have the core separate from a few bridges. One of the bridges was on linux debian jessie and worked well.

I recently wiped the machine and installed debian strectch. Used the sh script to install the Roon bridge and I can see it’s running, but it never appears as a zone in the Roon GUI (tried android client and windows client).


Bridge System info

Debian GNU/Linux 9 \n \l
Linux trotter 4.9.0-6-amd64 #1 SMP Debian 4.9.82-1+deb9u3 (2018-03-02) x86_64 GNU/Linux

I see the process running

root       447     1  0 Mar31 ?        00:00:00 /bin/sh /opt/RoonBridge/
root       453   447  0 Mar31 ?        00:00:01 RoonBridge --debug --gc=sgen --server RoonBridge.exe
root       498   453  0 Mar31 ?        00:00:09 RoonBridgeHelper --debug --gc=sgen --server RoonBridgeHelper.exe
root       505   453  0 Mar31 ?        00:00:00 /opt/RoonBridge/Bridge/processreaper 498
dave      8326  8289  0 01:07 pts/0    00:00:00 grep --color=auto --exclude-dir=.bzr --exclude-dir=CVS --exclude-dir=.git --exclude-dir=.hg --exclude-dir=.svn Roon

Have network connectivity to the Roon server

PING jj.localdomain ( 56(84) bytes of data.
64 bytes from jj.localdomain ( icmp_seq=1 ttl=64 time=0.211 ms

Last few Bridge log entries from /var/roon/RoonBridge/Logs/RoonBridge_log.txt

04/01 18:18:32 Trace: Successful POST response from
04/01 18:18:32 Trace: [push] connecting to
04/01 18:18:32 Trace: [push] connected
04/01 19:42:47 Debug: [base/updater] Checking for updates:
04/01 19:42:47 Debug: [appupdater] Update not needed
04/02 00:54:19 Trace: [rnet/RnetJsonServer] [client] GOT {"request":"updates_subscribe"}
04/02 00:54:19 Trace: [rnet/RnetJsonServer] [client] SENT NONFINAL {"status":"Success","updates":{"is_supported":true,"status":"UpToDate","progress":null,"current_version":{"machine_value":100000141,"branch":"stable","display_value":"1.0 (build 141) stable"},"available_version":null,"update_mode":"AutoCompatible"}}

Thanks in advance

All looking good. Is there any audio endpoint connected to the bridge (sound card, USB DAC) and is it turned on? Roon will not show the bridge without it.

What does aplay -l say?

1 Like

Yes, I have the analog out going to my AV receiver:

**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Generic [HD-Audio Generic], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Thanks for your help

Hi @David_Badia ---- Thank you for the report and sharing your feedback with us. The insight is very appreciated and sorry to hear of the troubles.

Moving forward, I would like to enable diagnostics on your account so our techs can have a closer look into this behavior you are experiencing. What this action will do is the next time that Roon is active on your core machine a diagnostics report containing a set of your Roon logs will automatically be generated/uploaded to our servers. I will keep an eye out for the upload and will touch base again once it has come in so you know we have it.

Additionally, may I kindly ask you to please…

  1. Expand on your setup description using this link as a guide. This will give our tech team a better sense as to what your setup “looks like”.

  2. Describe your network configuration/topology being sure to provide insight into any networking hardware you are currently implementing. I want to have a clear understanding as to how your devices are communicating and all the tools involved with making those connection possible.


Sounds good. Here is the detailed info

Setup description (as shown in my windows laptop Roon client: Settings -> About)

  • This PC: Roon Version 1.4 (build 310) stable (64bit)

  • Core: Roon Version 1.4. (build 310) stable (64bit)

  • Roon Bridge (trotter): (
    Version 1.0 (build 141) stable

Interesting that trotter (the bridge that is giving me trouble) shows here
It says “Latest version” but obviously that isn’t…

I also have a SOtM sMS-200 bridge which works well but didn’t show up in the windows client about list

Network Topology
Is pretty simple. All roon core and bridge devices (core, SOtM, trotter) are cat6 wired into a single 24 port managed switch.

The problem bridge server (trotter) also runs a mythtv client. I am confident it has solid network connectivity as the mythtv client/frontend on trotter streams video from the roon core server (also runs mythbackend) without issue.

WIndows laptop with Roon client is on wifi

Hope this helps

Thanks for the follow up and taking the time to provide the requested feedback @David_Badia! Both are very appreciated!

I wanted to touch base because I check our servers this morning and it looks like the mentioned diagnostics have nit been received yet. I have re-enable this feature on your account to try in an attempt refresh the transfer, however, I want to make sure I get a set of your Roon logs over to our techs in a timely manor.

In light of the above, may I kindly ask you to send us over a set of your “Roon” logs from the PC hosting your core, using the instructions found here.


Hi @David_Badia ---- Thank you for the PM! Confirming that it has been received and the logs have been downloaded.

I am going to be updating your ticket and then passing over to our tech team for review. Once your the team has complete their evaluation of the provided logs I will be sure to share their thoughts/findings with you asap. Your patience is very appreciated!


Sounds good, thanks!

1 Like

Hi @David_Badia ----- Thank you again for the continued feedback and more importantly, thank you for your patience while our team has been reviewing the supplied logs.

Being as the RoonBridge device is appearing in the “about” section of the application this means that Roon can see it, which suggests that there is something potentially occurring on the network where the RAATServer process is potentially being blocked or perhaps there is an issue with install (i.e the RAATSever process is not functioning as expected).

In light of the theories mentioned above, can you please verify for me that there are no active firewalls anywhere in your setup (core machine and RoonBridge). Additionally the tech team has asked if you would kindly conduct the following troubleshooting exercise:

  • Launch and then restart the RoonBridge serval times, confirming that the zone never appears in the “audio tab” each time.

  • Please take note the times when you perform the reboots/verification checks in the application.

  • After you have performed the above and the times have been recorded, please send us another set of:

    • “Roon” logs from your core machine.
    • “RoonBridge” logs from the bridge device.


Hi @David_Badia ---- Touching base with you to verify that I have received your PM and downloaded the provided materials. Thank you!

I noticed that when I opened up the package that there was only a single “Roon Server Log” and six “Roon Bridge” logs. I am certain that the team is going to need a full set of logs from the core machine + the bridge device, so at your earliest convenience may I kindly ask you to please re-supply.


Thank you for the follow up PM/Upload @David_Badia , confirming that the new materials have been received and attached to your ticket, which is being passed back to the tech team for further review.

As before, once your ticket is updated and passed back I will be sure to share the team’s thoughts/findings with you in a timely manor. Your continued patience is very appreciated!


Thanks @eric Would like to ensure I have the proper connectivity between the bridge and core servers. Which port would I need to telnet to on the core server?