Roon can't see internet after installing new BT Smart Hub router

Core Machine (Operating system/System info/Roon build number)

Intel NUC with Roon ROCK Version 1.7 (build 667) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

BT Smart Hub accessed over ethernet/powerline.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Various devices, all play back OK with existing music files. Roon Remote works fine on smartphone.

Description Of Issue

Since installing a BT Smart Hub I am unable to add new music to Roon as it cannot get access to the internet to obtain metadata – see attached image. I have tried all sorts of different network settings without success, including using a fixed or dynamic IP address, etc.

I have Roon Client installed on an Intel NUC configured for dual boot (Windows/Linux). I boot into Windows 10 for Roon management (adding music, editing metadata, etc.). Used to work with the old TP-LINK router until it apparently died but I am unable to judge whether the error lies in the router, the network settings, or some other PC hardware. I can access the internet fine via Firefox (doing it now).

Whenever I have changed routers these sorts of access issues have been firewall related. It can be that:

  1. Windows has created a public rather than a private network. It should be private but with certain public exceptions to allow roon core to communicate with external servers and remotes.

  2. Key roon servers are no longer allowed through the firewall. Every system is going to be slightly different but this old thread should give clues to what needs to be configured:

Have you tried directly connecting the NUC to the BT Hub, to narrow down/eliminate any intermediate connection issues?

I got the BT hub a couple of months ago (having been tormented by TalkTalk) and it’s been very good


Thanks very much for the suggestions, some of which I had tried. In the end I have managed to solve this via the “random walk” method. Although I had tried resetting various network values without success, and rebooting the server in between, this time I set the DNS server to and saved (everything stopped) then set back to what I think should be the correct value for BT ( and magically everything started again. Looks like these things get rather firmly cached and have to be reset by force majeure…

Hi Andrew. I thought I would just check something with you if you don’t mind, even though everything appears to be working at the moment, because my understanding of networking is rather weak. Also, I am not certain that I don’t have a problem with the BT router/phone line, as BT seems to struggle to see the hub.

My ROCK server currently has the following settings.
IP Address Setup: Static IP
IP Address:
Gateway: (set by BT)
DNS Server:

The DNS server value before I reset them manually may have been, which according to is a primary BT DNS server, whereas ~.162 is a secondary server. My question is – do you know if ROCK would have picked up these values automatically after the router was replaced? I don’t recall having to set anything manually when I originally installed ROCK (and using a TP-LINK router), but that was some time ago and my memory may be faulty.

Incidentally, I did not find that Windows Defender interfered at all and it is running OK right now on Windows with Roon Client. (When booting into Linux I use ufw firewall, and that always blocked Roon Bridge so I could never use it as a client.) Thanks.

Hi Alan

I’m ok ish on networks, but only when they’re in front of me, I’m afraid

I don’t think you need a fixed address for Roon; I’m fairly sure mine is dynamic


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.