Roon client on Windows launches to a blank unresponsive window

Roon Core Machine

Roon Core is:
Mac Mini (Late 2014) 7,1
Intel Core i5-4380U 2.8 GHz
8GB RAM / 1 TB SSD
macOS Monterey 12.6.7
Roon 2.0 (build 1299) production

Roon Client (machine having issue):
Ryzen 5600x 3.7GHz
32GB RAM / 500 GB m.2 SSD + 1TB m.2 SSD + 2TB SATA SSD in RAID
Nvidia RTX 3070 8GB (536.40 driver) connected to 2x G-Sync displays + 1 non-G-Sync display
Windows 11 Pro 23H2 build 22631.2050
Roon 2.0 (build 1300) production
Machine is also running Roon Bridge 1.8 (build 1125) stable

Networking Gear & Setup Details

Netgear Orbi RBK50 acting as router connected to Netgear Gigabit switch
Mac Mini Core connected to switch via wired Ethernet
Local music library on Synology NAS connected to switch via wired Ethernet and mounted as volume on Core
Windows Client connected to Core via TP-Link Powerline adapter / wired Gigabit Ethernet
Windows Client running Mullvad VPN client with allow local network sharing mode enabled

Connected Audio Devices

Windows client has all audio devices disabled except USB optical SPDIF adapter plugged into external DAC

Number of Tracks in Library

Local library is around 9,300 tracks, almost all FLAC

Description of Issue

Roon Client on my Windows PC works fine after first being installed but after some amount of time (could be anything from hours to one week) it will no longer launch cleanly. The Roon client launches to a white unresponsive screen (‘Not Responding’) in title bar, no Roon logo and constant spinning wheel mouse cursor. Only available course of action is to end the task via Task Manager. This has been happening for several months and over numerous Windows updates / graphics driver updates / Roon client updates.

I’ve found that a course of action that seems to bring Roon back to life (albeit temporarily) is to use the Roon uninstaller to delete settings and databases (a full uninstall of Roon is not necessary). Unfortunately I then have to manually re-apply all my custom settings (dark mode, views, etc.).

Roon logs do not appear to reveal anything particularly interesting: no error is evident in the log file.

Also to add, Task Manager shows the Roon client using around 385 MB of RAM and alternating between 0 CPU usage and spikes every second or two up to between 8 and 12% (less than one core utilisation, it’s not just solidly pegging a core)

The process also shows very minimal disk and network utilisation - 0.1 Mb/sec Network and between 0 and 0.1 MB/s Disk

Other Roon clients on the network (Windows + Mac + iOS) all work fine.

Don’t know if it will help but

Thanks a lot for the tip - just tried it and unfortunately -nodeepcolor didn’t work.

To try to eliminate any monitor/graphics issues, I also did the following:

  • Disable HDR across all my screens
  • Set all screens to same refresh rate (60Hz)
  • Disable G-Sync on all displays

I also tried shutting down Roon Bridge in case this was causing any issues, and no change.

1 Like

Are you running this on the same PC that is running Roon? And, if so, what are you trying to accomplish?

Yes, I’m running the Roon client and the Roon Bridge on the same machine - that particular setup has never caused me any issue on other machines as well as this one in the past. The reason for it is that I can have Roon Bridge set to start up with Windows, then I can boot the machine and have a Roon end point up and running without the much heavier client running on startup. If I want to use the Roon client, it runs fine with Roon Bridge in the background.

I have tried disabling Roon Bridge to see if it has any effect on this particular bug and it’s reproducible with or without Roon Bridge installed.

Hi @Gabriele_Rizzetto ,

Thanks for the report. Can you please check to see if removing the Roon saved_window_pos file allows Roon to open again without the reinstall? Please see:

Also, can you please provide some information regarding your screen setup/resolution and screen model/manufacturer type?

Hi, thanks for the suggestion - that seems to have worked. I’ll create a batch file shortcut to launch Roon and delete this file before launching.

I have a triple monitor setup but I have had this issue in the past on my old dual monitor setup (which used only monitors 1 and 3 below in a landscape + vertically stacked configuration).

Monitor arrangement is:
monitors

1 - Dell AW2721D @ 2560x1440 240Hz (G-Sync enabled, HDR enabled)
2 - Dell AW2723DF @ 2560x1440 240Hz (G-Sync enabled, HDR enabled)
3 - Dell U2515H @ 1440x2560 (vertical) 60Hz (no G-Sync)

All three are connected via DisplayPort to the RTX 3070 GPU.

I am also now launching Roon with the -nodeepcolor flag as suggested above - although this didn’t fix this issue, it did improve laggy UI I was experiencing.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.