Roon constantly spinning: "scanning now" on new Roon 1.8 update (build 806) [Resolved - m3u file causing issues]

Nucleus +

Nucleus +

Networking Gear & Setup Details

Ethernet hardwired

Connected Audio Devices

Auralic Altair G1
Mac Mini M1 - OS Big Sur 11.4
Google Chromecast

Library Size

227,000 tracks stored on Synology NAS DS918+ ethernet connected to same network

Description of Issue

The library scanning process started with new update and has now been running for approximately 24 hours despite all of my library available in Roon. When spinning icon in upper right corner is opened it says:
Adding music to library :Complete
Scanning now

I have tried restarting server 2 times but still have same result.

Experiencing this on W10 client with a ROCK. Just spinning and spinning.
It’s also not pulling any artwork to my new music.

Hey @Wayne_Carter,

Thanks so much for getting in touch as soon as you’ve had enough time to see the scanning does not complete.

I was hoping we could obtain two screenshots from you:

  1. Of the screen after clicking on the spinning icon in the upper right corner
  2. Of your Settings → Library (so we can view your Audio Analysis settings)

Thanks in advance :pray:

Hi Rebeka - Herę are the screenshots as requested.

@beka - it has been doing this now for another 24 hours. Should I be doing something to stop it? I can’t imagine this is good for my Nucleus+…

Hey @Wayne_Carter,

Thanks for your replies :pray:

It seems like I failed to mention, for the second screenshot to click on view next to Import Settings. Right at the bottom, there are Audio Analysis Settings.

Since our technical team works Monday - Friday, it will be until then to get their input. I’m looping them in today, anyway.

In the meantime, you can lower the speed for the Background Audio Analysis:

Here is the additional screen shot.

I have taken to disabling my library access when not using Roon to stop the perpetual scanning.

@beka Hi - has there been any progress on this? I am currently disabling my NAS library whenever I am not using Roon to stop my Nucleus+ from constantly scanning the library. I did not have this problem before the most recent update. What is happening?

1 Like

Hello @Wayne_Carter,

Thank you for bearing with me as I liaise with our technical team and get all the information we need from you. It is taking us longer than I had hoped…

Our technical team would like to enable some diagnostics on your account so they can take a closer look at what you’re experiencing. Before it is relevant for them to do this, could you please do the following and make a note of the time you do each:

Reboot your Core machine.
Start up Roon and let the spinner go for ~5 minutes.
Reboot your Core machine once more.
Start up Roon and let the spinner go for another ~5 minutes.

Once you’ve done this let me know the timestamps and I’ll enable diagnostics on your account. When the diagnostics report is uploaded I’ll send it over to our team for analysis.

Hi there. Note - these times are in Atlantic Time, I am in Nova Scotia Canada, not sure if that matters.
#1 Reboot - 6:58 pm
Roon restarted on Mac Mini M1 6:58pm
Library became available in dashboard 7:02 pm
Continued scan until 7:07 pm

#2 Reboot - 7:08 pm
Roon restarted on Mac Mini M1 7:08pm
Library became available in dashboard 7:12 pm
Continued scan until 7:17 pm

I then shut down Roon on Mac Mini M1 again but left Nucleus+ Core running

Hello @Wayne_Carter,

Thanks for making the time to go through this so quickly :zap:

Please, expect a reply by tomorrow. I’ve already passed these timestamps on to our technical team, so they can take a look and follow up with you.

We’ll be in touch on this thread :nerd_face:

Thanks very much! Should I leave the Core running?

1 Like

Yes please, if possible :pray:

(that will ensure connection to our servers and the diagnostic report)

Hi @Wayne_Carter

I just wanted to let you know that we ran diagnostics and passed the report to our QA team. Once we have feedback from them we’ll follow up ASAP. Thanks!

1 Like

Hi Dylan - any updates? I am currently only enabling my NAS library if I am planning on using ROON - not a good situation. Very puzzled as this was not happening before the last update. Is it common to experience so many problems with a Nucleus+? I have had mine for about 19 months and it seems it works for a while beautifully then something else happens to it… Obviously it was quite expensive and I am getting very disillusioned…

@dylan - any updates? This issue continues…

Sorry for the delay, @Wayne_Carter

I do have an update from the QA team for you — In their investigation, it looks like the scanning process is getting tripped up by a file in the Tears for Fears folder. Can you try moving the entire folder out of your watched folder and let us know if things work okay after that?

@dylan - Hi, removed that folder but still the same result. I am puzzled as to why this folder would just begin to cause this as it has been in my library since 2017 without any changes.

@dylan Hey Dylan - any further update? Still having this problem… I am seeing other posts about the same problem but some are talking about DNS and others about certain characters in file names in libraries. I am currently disabling my library whenever I am not using Roon to not tax the Nucleus+ unnecessarily but this can’t be the “new normal”???