Roon Control installs successfully but other than the first popup with a message nothing starts

Core Machine (Operating system/System info/Roon build number)
Roon Nucleus.
Windows 10 home, i7-6700, 16 GB RAM.
NAS drive EX 2 Ultra is the music source and cabled to a router.
Roon Control installed on 2 iPads.
Tidal account linked to Roon Core.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Shaw cable router
NAS and Nucleus cabled to the router
WiFi used for iPad Roon app.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Meridian 818 amplifier also cabled to the router.

Description Of Issue
A couple weeks ago when starting Roon on the PC, it no longer loads, just the initial black background Roon and message box displays briefly but the app doesn’t load. However, the iPads continued to work so ignored the issue as I only very occasionally used the PC based app.

Yesterday when opening the Roon app on my iPad it notified me that there were updates available and I selected to have them installed. After that my iPads could no longer find the Roon Core. The NAS drive with my music collection is still accessible from my PC. I can still play music through my Meridian 818 from other network sources (a Meridian Sooloos Control:15) so the only problem appears to be Roon related.

I tried uninstalling Roon on my PC and downloading and installing the current windows version which the installer says was successful but same problem - the black Roon window shows briefly and then nothing.

Help, where do I start to diagnose the problem!
Thanks, Alan S

Thanks for the reply. Nvidia drivers are up to date and no new ones installed. However I disabled the Nvidia GTX 1070 card in Device Manager and now the Roon app loads and can’t find my Core which is installed in the Nucleus. Every other device on the network is accessible and working as expected except the Nucleus. Since the Core disappeared immediately after I was prompted and accepted the install of updates on multiple devices that appeared on my iPad it seems that the update has caused my problems? Comments, suggestions?


Followup: I have restarted the Nucleus and then tried different cables and ports to connect it to my D-Link DGS-10B switch which I believe eliminates the network as the cause.

Hi @Alan_Stewart1,

Thanks for reaching out, I can certainly assist with these issues.

Can you please provide a screenshot of your Nucleus Web UI? Are you able to properly access that page?

If you are not able to access the WebUI, can you connect an HDMI cable from the Nucleus to a monitor and share a screenshot of what you see on the diagnostics screen? It should look similar to this for reference:

Well this doesn’t look good!
FYI: not sure if this matters but I did have to disconnect the Nucleus from my network and plug it in closer to my PC as I don’t have an HDMI cable long enough to reach my PC where it normally lives.

Hi @Alan_Stewart1,

Thanks for sharing that screenshot.

It appears that unfortunately, you have been impacted by a rare issue in our latest OS.

This error is recoverable but it will require you to use a USB flash drive (empty/blank one) to perform a procedure, all the details can be found in the post below:

More in-depth steps also provided a bit further down the thread:

Apologies for this inconvenience, do let us know if any of the steps are not clear or you run into further issues and we can certainly clarify.

Thanks for the info. I have flashed a USB stick however these instructions assume I have a keyboard and monitor attached to the Nucleus - assuming the Nucleus is the NUC in that post?

  1. Since I have to connect to the Nucleus to complete the steps do I simply plug in a keyboard into the second USB port and use the monitor hooked up to the Nucleus via HDMI to do them?


A followup question if I may - how do you tell when the Nucleus is on or off? The lighted power switch does not change in any way after pressing it, always being lit once the power cord is plugged into the wall.


Hi @Alan_Stewart1,

Once the Nucleus is plugged in, you should only have to press the power button once. It should illuminate a light glow when on, but easiest way to check if it’s on would be on the HDMI diagnostics screen.

Yes, this is correct, you will have to use a keyboard + monitor for the procedure. The instructions reference NUC (Intel Next Unit Computing), but the instructions are identical since both NUC and Nucleus run RoonOS.

Please be sure to choose the Recovery option, not the Install option when booting off the drive. If you run into any issue, just let me know and I’d be happy to clarify!

Roon is back online and updates to tablets were successful. Thanks for your help and support!


Hi @Alan_Stewart1,

That’s fantastic news, do let us know if you run into any other issues and we can certainly assist if so!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.