Roon Controller on iPad Pro constantly losing connection

(Matt Clark) #1

Core Machine (Operating system/System info/Roon build number)

iMac / macOS Mojave 10.14.4 / Roon v1.6 (build 401) stable (64 bit)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Virgin Hub 3 / Wifi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

IQAudio Digi+ over wifi

Description Of Issue

I have a continuous issue with Roon Controller running on an iPad Pro losing connection to the Roon Core on my iMac.

It happened just now, so I checked Roon controller on my iPhone X and it was working fine, and checked Roon controller on my MacBook Air and it was also running fine

It is only ever the Roon controller on the iPad pro that has the issue, and it happens every few days. I find if I uninstall the app from the iPad, then reinstall it and reconnect it works fine, but only for a few days

I’ll attach a few screengrabs of network config on iMac, MBA, iPad Pro and iPhone X

Any help greatly appreciated as the iPad Pro is supposed to be our main controller so this is pretty irritating!


iPad Pro connection error screen


iMac (core) Network config


Roon buid info


iPad Pro Network config


MBA Network config


iPhone X Network config

(Mr Fix It ) #2

Maybe your dhcp lease is expiring? I would normally run my core as fixed IP address. Are you running the latest iPad os and roon version?

(Matt Clark) #3

The iPad Pro is brand new and up to date (iOS 12.2). Roon is showing as the latest version.

I don’t know what dhcp lease or fixed IP address mean. I’m pretty much a Plug and Play kinda guy!

However my Core is set up, my iPhone and Macbook are having no problems, it’s only the iPad Pro. Over and over again.

(Mr Fix It ) #4

Have you removed roon and reinstalled it?

(Matt Clark) #5

I have removed Roon controller app from the iPad and reinstalled it. Repeatedly.

It solves the problem instantly, but temporarily. It reconnects to the Core straight away, but within a few days, it happens again

(Mr Fix It ) #6

Well let’s see what support would like to do…they should be along in due course :nerd_face:

(Matt Clark) #7

Cool, thanks for the initial offer of help :+1:

(Noris) #9

Hi @Matt_Clark,

You mentioned that this issue is resolved by re-installing the Roon app, but does force quitting the Roon app and starting it up again also resolve the issue? You can force-quit an app by double pressing the home button and then “swiping” the app away.

The iPad networking screenshot your posted looks ok to me. I would also check for any other things that can possibly cause this – do you have enough free space available on the iPad? Is the iPad located further away from the router than the other two working Roon remotes?

(Matt Clark) #10

Hi @noris

Thanks for coming back to me. I can’t test the force-quit thing right now; having left the iPad alone for 4 hours I’ve just opened the Roon controller app and it connected first time, having refused to do it for 2 hours; typical!

So this is an intermittent but annoying issue. I’ll wait until it fails again and try the force-quit thing and report back

In terms of your other questions, the iPad has 256GB of storage of which 166GB is free, so space isn’t an issue. And it (and my IQAudio audio device) is in the same room as the router, literally 8 feet away from it, so distance isn’t an issue. I brought the other two remotes (MBA and iPhone X) into that room to test and they were fine.

1 Like
#11

Hi, is this issue resolved? I have myself the same issue with periodic failures of my iPad to “see” the Core. Very annoying. Some times it manages to do so after a few seconds, some other times I need to kill and restart the Roon app. Have seen several similar topics but no concrete resolution. Trying to avoid starting a new thread … and I have already filled and filed the form with my network set up

Thanks in advance for any support

1 Like
(Dan Brown) #12

My iPad Air 2 does the same. Sometimes I can be running the app fine, then minimise it to the background, then a few minutes later when I go back and maximise the app, it just shows

Or

I have to force quit the app and load it up again to get it to ‘see’ the core.

Even when it works, sometimes the delays in connecting and refreshing screen content after minimising bugged me to the point of buying an Amazon Fire HD 8 when Roon released the software for it.

I now just use an ‘always on’ Fire HD in a dock and rarely use the iPad for control of Roon.

(Matt Clark) #13

@Dan_Brown hi there, sorry for slow reply. The advice from @noris worked for me, though I’m not sure how robust / long term the fix is as I haven’t used Roon that much lately. Rather than deleting and reinstalling the Roon app every time, I followed the advice to force quit the app and then reopen it. Not sure what ipad you have, but I have a new iPad pro (without the home button) and the instructions are here. This worked immediately, and though my use of Roon over the past 5/6 weeks has been sporadic, every time I have tried to control it with the iPad pro it has worked perfectly. The issue seemed to arise more during a period of heavy usage, which I haven’t done for a while. Give this a try though, and let us all know how you get on!

(Dan Brown) #14

Hi Matt. Yep the advice…

Is what I’ve been doing.

It’s just really annoying so I’ve started using an ‘always on’ Fire HD tablet for controlling Roon.

(Matt Clark) #15

Interesting. When I was uninstalling and reinstalling the app every time, it was a constant exercise. But once I force quit and reopened it once, it’s been fine ever since. Go figure!

(Noris) #16

Hi @Dan_Brown/@Matt_Clark,

Glad to hear that force-quitting the app and reopening it has allowed you to reconnect. We are investigating this behavior and we will try to reproduce on our end, I will be sure let you know if we require any further info for the investigation.

(Dan Brown) #17

Thanks @noris

(Noris) #18

Hi @Dan_Brown/@DrPo,

We are still investigating this behavior and some more information regarding the issue would be of help.

Can you please let me know your Core model/manufacturer/operating system and network setup info, including router’s model/manufacturer and the model/manufacturer for any other networking gear?

@DrPo - Is force-quitting the app and starting it up again working successfully to resolve the issue when you are in this state?

(Dan Brown) #19

Hi @noris. My core is Mac Mini 2012 quad-core i7. OSX High Sierra. 16GB ram.
Router is Virgin SuperHub 3. Cat-5 between Core and Router.

My problem rarely requires a force-quit.

It’s just when I minimise the controller to use… say… Safari… when I go back to Roon control… it can be very sluggish to re-establish a connection with the core.

Also… after the iPad screen sleeps and I use fingerprint to wake it, similar occurs.

#20

Hi Noris, just saw this.

Core runs on Antipodes EX.

Network set up (simplified relative to my earlier post by eliminating the AQVOX switch):

  • Speedport plus as modem/DCHP server (no WiFi) in study
  • wired to Ubiquiti Networks “AMPLIFI” router (this generates the SSID).
  • AMPLIFI mesh point in living room
  • wired to the EX.

Typical dropout behavior:

  • IDevice (statistically it’s more often -though not exclusively so- the iPad rather than the iPhone) refreshes connection to Core, most of the time instantaneously (yet still screen goes back to a previous list which is clearly an issue…); occasionally fails to do so and the “no Core” screen appears. Sometimes it finds the Core but gets stuck in Amber status attempting to “initialize” the connection. Sometimes it just stays in the “no Core found” screen.

Options to restore:

  • kill and restart the app: most of the times this does NOT work by itself
  • go to the Core IP address and restart Roon Core. This ALMOST ALWAYS works but is really disruptive as one has to wait for a minute or so and the music is interrupted
  • another “trick” I am using lately is to cycle off/on the WiFi connection on the iDevice. This ALMOST ALWAYS works without interrupting the music that is being played.

I have tried to make some sense out of the logs. All I can see is that there are many occurrences where connection is lost but somehow it is recovered on 2nd attempt. Could be these are the cases where I lose the screen but not the connection. Can share if you want.

Hope you can make some sense out if the above.

Thx, Greg

(Noris) #21

Hi @Dan_Brown/@DrPo,

Thank you for sharing those additional setup details, I have added the information you have provided to our internal investigation ticket.