ROON Core External access (For ROON Arc)

Hi ROON User,

How do I set up my ROON Core for external access with ROON Arc does anybody know? After iOS and iPadOS update it does not make a connection anymore…

Thank you very much.

With kind regards,


Have a read of this article to start with:

Please be aware that there seems to be a service issue with Roon’s cloud infrastructure for ARC for some users at the moment - this may also be affecting you.

Thank you Geoff and Thank you Jeff. But I’m still having this Core connection problem with ROON Arc… :frowning_face:

Is there an error message if you go to the Settings > Roon ARC page in Roon? If so, please copy and paste it into your reply. Thanks.

1 Like

Hi Geoff, yes there is. :wink:

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“2a02:a466:7ba8:1:4de3:cce:64d1:22d0”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<?xml version=\"1.0\"?>\n<s:Envelope xmlns:s="\” s:encodingStyle="\“>\n<s:Body>\n<s:Fault>\ns:Client\nUPnPError\n\n<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\n606\nUnknown Error Code\n\n\n</s:Fault>\n</s:Body>\n</s:Envelope>”}

I believe I got this same message also the previous time I had a problem with connecting ROON Arc to my ROON Core.

With kind regards,


And Geoff, I have no idea what this means… .

I’ve moved your post into the #support:port-forwarding-help category of the forum where it will be seen and responded to by a member of the Support team.

Thanks a lot.

Geoff_Coupe, hopefully the Support Team can really help with this. :pray:

I’ve been having no Roon Arc access for three full days now

Hmm, the Support team don’t work weekends, I’m afraid.

BTW, have you tried rebooting your router?

And some further details about your setup would be helpful:

Who is your internet service provider?

Please list the make and model of your modem and router?

Do you have any additional network hardware, like additional routers or managed switches?

Does your network have any VPNs, mesh network, proxy servers, or enterprise-grade security?

What machine are you using as a Roon Core, and how is it connected to the internet?


1 Like

Hi Geoff_Coupe,

Thanks for your help.
I’ve changed my Roon Core (Apple Macbook Pro, 2013) internet connection from a WiFi to an wired Ethernet connection. And also I’ve prioritized it within my Fritz!Box 7590’s Setting. Soon I will find out if this works for improved Roon experience. I tell you about it later, okay?

I have not tried rebooting my router. I will try later today.

I don’t have any VPNs and I don’t have the enterprise-grade security.
I only have one more Fritz! Repeater in my home network but that is only for my (Smart) Tv now.

Thank you once again.

With kind regards,

Sjors - The netherlands


Hello Geoff,

I have made a reboot to my router, but unfortunately nothing has changed here. And sadly and badly my Roon Arc is still Not working…

Hi Geoff_Coupe,

I made a change in my Router’s Internet Settings.
I’ve chosen to check Permit Access, I’ve added my Roon Core device Apple Macbook Pro and from then on Roon Arc has been working fine, with no issues at all so far.

With kind regards,

Sjors :netherlands:

Hi Geoff_Coupe,
Still I’ve been experiencing trouble with my Roon RRac, again. It doesn’t make a connection. What is it with Roon Arc? Is there something wrong with this?

1 Like

Hi @Sjors_Ehv,

I also experience problems here (netherlands). Yesterday everything was fine here.

Hope @support will give an update.



Yes, as @Maarten_Duits says, there seems to be a problem with the service this morning - I’m getting “poor connection” messages as well.

1 Like

Same issue in Greece, had happened a few days ago and then this morning…probably a problem with their cloud

Hi Geoff_Coupe, I think it’s working again, am I right?

Hi Rom_ulus, here all is fine for now, maybe in Greece as well I hope? :pray:t3: