Roon Core is inaccessible

Roon Core Machine

Roon Core resides on a late 2014 Mac mini running Monterey 12.3.1
Processor = 2.6 GHZ Dual Core, Intel Core, 8 GB RAM

Networking Gear & Setup Details

Router = ASUS ZenWiFi AX
Connectvity = Core to router to NAD M.50 music server is all ethernet.

Connected Audio Devices

NAD M.50 music server (ethernet connection)

NAD M.50 music server

Number of Tracks in Library

approx. 12,500 tracks

Description of Issue

My Roon runs on a Mac mini that’s about 2 years old. Recently Roon became inaccessible. I only see the pulsating icon on screen, which eventually times out. I have tried logging out/in, ascertaining that the Core is powered up and connected to the network, as well as various other suggestions from the Roon support site.

Have you tried rebooting your ASUS WIFi network, then rebooting all of your audio devices including your Mac/Roon Core, the Mac Roon client, and the NAD M.50?

I haven’t tried rebooting the network. I’ll reboot everything you listed and get back to you. Thanks for your response.

I rebooted network, Core Mac mini, a Mac client laptop and the NAD. Still no communication with the Core.

Are firewall settings on the Mac Roon client set to allow Roon Server and RAAT Server as exceptions? I don’t have to do anything on my MacBook Pro, but your configuration may require these exceptions.

Are you able to confirm the Mac client is on the same subnet as the Core? Do the Core and the client have the same 192.168.Y.XXX or 10.0.Y.XXX address, where the 192.168.Y or 10.0.Y numbers are the same for all attached devices? Last question: Do you have a mobile phone you can try connecting to the Core via WiFi?

My firewall has been deactivated while I’m having trouble with Roon.
The ip addresses for all attached devices have different values beyond 192.168.30 . . .
On my iPhone, I tried the full address for the Mini Mac Roon host, but that didn’t connect me to anything.

All of your devices at least seem to be on the same subnet (although not sure about your iPhone yet). Is the firewall off on both your Core and Mac client? I think so from what you wrote, but want to make sure.

Yes, that’s right. Firewall off on both devices. Not sure about the iPhone.

I’m happy Roon is addressing the problem relating to crashing Mac devices as mentioned on a separate thread. However, the solution Conor suggests there, which entails restarting Roon Core twice is not helpful in my case. I can’t communicate with Core in any.manner; whether via the Core Mac mini host or my iPhone or iPad.

I’m tagging @support to notify them of your issue.

Great to see you again @David_Waring!

I’m sorry to hear you’re running into issues with gaining access to your Roon account. While you mentioned you tried various other suggestions within our support site, I’m wondering if you’ve tried creating a new Roon database? If not, follow the steps below:

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

While it may resolve the issue entirely, it will primarily create stable conditions for further troubleshooting steps.

If possible, I would also try uninstalling and reinstalling the Roon Remote app on your device. In the meantime, we’ll take a look at your account logs to investigate further.

A good thing to note here, the double restart you tried will only have an effect if we’ve made a backend change on your account, which if we confirm that your issue is tied to the same issue previously mentioned, we can proceed with.

Certainly let me know if any of the above helps, and if your issue persists :+1:


Thanks for getting in touch Benjamin.
I’ll try creating a new database and get back to you.

1 Like

I followed your bulleted instructions and have reestablished contact with the Core. Unfortunately my library is now inaccessible to Roon. As are my tags, playlists,
etc. I’m hoping this is not a permanent state of affairs as I backed up my Roon database before I proceeded with creating the new database.
My music Library, which resides on my NAD M.50, is still there and the music can be played using its native BluOSs app, but the only music I can play using Roon, are streamed radio stations,.

Hey @David_Waring,

I’m glad to hear you were able to connect to your Core! The final step here would be to restore your database from the backup you created.

You can do this by heading into your Settings > Backup > Find Backups and selecting your initial database folder.

Let me know how it goes, I’ll be monitoring this thread for your reply.

Well Benjamin, looks like I’m’ back to square one. I can’t communicate with the Core. I followed the steps above, atl least I tried to restore the database, but Roon wouldn’t accept the database I had created (copied). So I tried a recent backup since I had scheduled automatic backups at some point. It appears this worked and took abofut 3 minutes. However, when I tried to open Roon after a restart, l was greeted by the pulsating Roon icon. After about a half hour of that, I quit out of Roon and r tried to restart it. No dice.
For now, I’ll try creating a new database again in the hope that I can re-establish contact with the Core. Do you see any red flags in the procedure I detailed above?

II tried creating a new database just now, but didn’t re-establish Core contact.

Hey @David_Waring,

Thanks for the update on your issue. If possible, are you able to restore from a backup that pre-dates the issue you’re experiencing? That should clear things up for you moving forward.

Let me know if you’re able to do this :+1:

Yesterday, when I had access to the Core, I noted I had several backups pre-dating my current problem. But now, I don’t have access to the Core, so I don’t have access to.the Roon GUI, so I’m unable to use Settings, Backups, etc. Am I missing something painfully obvious, or is it possible to get to Backups some other way than via menu choices in Roon’s good old GUI? I didn’t have much luck using RoonOS Web. But the backups are there, waiting for me to figure out how to get to them.

I again am able to communicate with the Core and have restored a recent backup. It was nice to see my tags and other metadata I have created are still available. However, the only way I can control Roon is via the Mac mini where the main install was made. I can’t do it by iPhone, iPad or MacBook Pro, despite installing new versions of Roon Remote on each. Also, I can’t confirm that remote connections are accepted since the Settings/Set up route doesn’t offer the appropriate menu choice, as far as I can tell.

Hey @David_Waring,

I’m glad to hear you were able to restore from a recent backup! Regarding using your Roon Remotes, can you provide more specific details on what is happening and what you’re seeing when you open up the Roon app on any remote device? Is your device able to find your core?

If you’re able to share screenshots or a screen recording, that would be helpful! Have you tried restarting your remote devices and then doing a fresh install?

1 Like