Roon Core is inaccessible

Hi Ben,
I followed the procedure above but my various remote devices still can’t connect with the Core. Unfortunately, neither can my Mac mini, which has been the only Core install location until today. Here’s a screen shot of message I hadn’t received before. I don’t know if it will be of much use to you.

Hey @David_Waring,

Thanks for the screenshot. Is this screenshot coming from your Mac mini? If so, you can click unauthorize and reauthorize your core without hurting anything.

After doing this, I’d make sure to update all remotes and core to the latest Roon build 970 and see if you’re able to connect. If you’re still not able to, then we may need to look into doing a full uninstall and reinstall of Roon across the board.

2 posts were split to a new topic: Core Stuck on Initializing

Status report:
For a brief time, I was able to connect to the Core via both install Mac mini and remote devices. But I couldn’t play any files in my Library. Then the Roon Core reverted to it’s former state of inaccessibility. I tried authorizing/deauthorizing a new Core but ended up with two virtually identical Cores on my Mac-mini/. How do I get rid of one of these Cores? Having two seems to confuse Roon as it tries to establish contact with first one and then the other cores over and over. The only difference indicated between the two cores is the character string ffff in the one not in this screen shot:

I’m also unable to quit out of Roon via install or remote devices.

Hey @David_Waring,

Are you able to force quit? Were you able to successfully unauthorize the previous core?

Something else to check: make sure the Private Relay is turned off in your iCloud settings.

On your Mac, choose Apple menu  > System Preferences, then click Apple ID. Select iCloud > Private Relay.

On your iPhone, iPad, or iPod touch, go to Settings > [your name] > iCloud > Private Relay.

Your iCloud settings might take a while to load. In order to disable it, simply untick the box and click “Turn Off Private Relay” when the prompt appears.

If Private Relay isn’t being used please try uninstalling Roon on that remote and core, restart, then reinstall. Make sure that your ~/Library/Roon folder gets deleted as well, since removing the app alone won’t fully remove Roon. To find the library folder on your Mac, head to the “Go” menu in Finder while holding down the “option key” and selecting library.

Thanks, David :pray:

1 Like

At present, Roon Core is accessible from my Mac-mini (install) and all three remote devices, iPad, iPhone and MacBook Pro. I have no idea how this improvement came about, but the system seems relatively stable at the moment. The only problem remaining is that any music I choose to play is inaudible, although the visual cues indicate the music is being streamed. I have spent considerable time exploring he Settings and Audio menu choices – sans success.
Do you think this is something that could be resolved without a hard reboot of core, router and network.? I’m not sure how to do a hard reboot.

I’ve moved this last post of yours into your existing Support thread - helps to keep everything in the same place…

1 Like

Hey @David_Waring,

I’m glad to hear we’ve made small bits of progress! Which remote are you trying to play music from without audible playback?

Would you be able to take a screenshot of your signal path after pressing play? Here is where you can locate your signal path:

Also, if you are able to share a screenshot of your Settings → Audio, it would be good to see what zones you have enabled. Here is what this looks like:

Let me know, Daniel!

Hi Ben,
Here are a couple of screen shots, as requested, of signal path and audio settings respectively:

Screen Shot 2022-06-17 at 12.00.54 AM

Hey @David_Waring,

Thank you for the screenshots! We’re getting close to success here, I can feel it! :crossed_fingers:

First, can you enable ‘System Output’ just to check if you’re able to play music from your Mac’s internal speakers?

One other question, are you able to select the M50 (from your zone named Marcel) from the zone picker highlighted in the screenshot below?

Let me know if you’re able to select a zone, and if you’re able to adjust volumes from that zone as well. If you arent seeing Marcel available, try disabling and re-enabling it from the audio settings page.

1 Like

I’ve enabled System Output and can play music on the Mac mini’s internal speakers. which is obviously less than ideal. I only use the Marcel zone, normally. At present, I can not select Marcel or any other zone.

. . . . three hours later.

Everthing works the way it should!! Roon Core is back to normal and is accessible from any of my devices. What made the difference>. Beats me, but I rebooted the M50.2 earlier today and music actually comes out of the hi-fi now.

Thanks for all your help and persistance Ben! If there are any relapses, I’ll let you
know. Fingers crossed :grin:

1 Like

Well, declaring victory was a little premature on my part. Core is inaccessible again and rebooting the M50.2 doesn’t work anymore.
Later still . . . Every thing is working again.
But to carry on re your last question: at the moment, I can select other zones in Settings>Audio and the zone zone picker. Am also able to to control volume in the chosen zone. I usually have every zone set to fixed, however, as I only ever play Roon through the hi-fi system.
These sporadic outages/recoveries have me a little spooked, so I’m reluctant to retire the topic just yet.

A post was merged into an existing topic: Core Stuck on Initializing

Hey @David_Waring,

Thank you for the update! I’m glad to hear the system has come back around, if only for a short period.

These sporadic outages sound like they could be network related. If possible, could you give your network and router a hard reboot, and reconnect once your setup has fully restarted?

From there, if you do run into another dropout, could you please send over a specific timestamp or two of when this happens? From there, I can have our team take a deeper look into what is happening at the time of the dropout.

Thanks, David!

1 Like

Hi Ben,
I hard rebooted both network and router and Roon seems to be working as it should. Over 24 hours have passed without a recurrence of the disappearing Core, so I’m feeling a little more optimistic. If (when?) the problem returns, I will let you know. Thanks again. -David


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Roon Core Machine

Mac Mini

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

On May 28 I initiated a support inquiry on this forum. As of today, July 6, my Roon Core is still inaccessible despite sporadic and brief periods of Roon functioning as it should, I made the mistake of declaring the problem solved after one daylong interlude where everything was fine. Three days later, the topic was shut down by Roon and sure enough, the problem had resurfaced.

@Ben Cap is the rep who had assisted me and he recently stated that the difficulty had been identified and there would be an update which would neutralize the problem, My fingers are crossed, but the amount of time I’ve spent trying to restore Roon to a functioning state I find unconscionable. In short, Roon is a great product when it works but often it doesn’t. At which point, you’ll wish you had a degree in network administration, since your only recourse is to this forum and other far flung locations on the sprawling Roon web presence,

I have my doubts about a business model that places so much of the tech support onus on the shoulders of the consumer. Is Roon too sophisticated for its own good?

This is an automatic feature once the topic is marked a solved.

I’ve re-opened that topic and merged you post into it so all the history is together.
Tagging @benjamin so he is aware.

Hey @David_Waring,

Thanks for reaching back out, and my apologies for any confusion here! As @Carl mentioned, the system will auto-close threads once a solution has been found. I’m sorry to hear you’ve run into this issue again!

Unfortunately, we don’t have specific identification on the issue you’re having (perhaps you were thinking of a similar issue where many users had their cores stuck on initializing?)

A few things to note, if possible, please update all your Roon devices to the most recent build (988) and see if that helps.

We’ll need to enable diagnostics on your account and grab a set of logs from your Mac Mini to better identify what might be going on.

Please use the directions found here and send over a set of logs to our File Uploader? Please include a timestamp of when you are attempting to establish connection, or when you lose connection to your core. This will help the team pinpoint things more specifically.

1 Like