Roon Core is inaccessible

Hi Ben,
I hard rebooted both network and router and Roon seems to be working as it should. Over 24 hours have passed without a recurrence of the disappearing Core, so I’m feeling a little more optimistic. If (when?) the problem returns, I will let you know. Thanks again. -David

2 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Roon Core Machine

Mac Mini
Monterey
Intel

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

On May 28 I initiated a support inquiry on this forum. As of today, July 6, my Roon Core is still inaccessible despite sporadic and brief periods of Roon functioning as it should, I made the mistake of declaring the problem solved after one daylong interlude where everything was fine. Three days later, the topic was shut down by Roon and sure enough, the problem had resurfaced.

@Ben Cap is the rep who had assisted me and he recently stated that the difficulty had been identified and there would be an update which would neutralize the problem, My fingers are crossed, but the amount of time I’ve spent trying to restore Roon to a functioning state I find unconscionable. In short, Roon is a great product when it works but often it doesn’t. At which point, you’ll wish you had a degree in network administration, since your only recourse is to this forum and other far flung locations on the sprawling Roon web presence,

I have my doubts about a business model that places so much of the tech support onus on the shoulders of the consumer. Is Roon too sophisticated for its own good?

This is an automatic feature once the topic is marked a solved.

I’ve re-opened that topic and merged you post into it so all the history is together.
Tagging @benjamin so he is aware.

Hey @David_Waring,

Thanks for reaching back out, and my apologies for any confusion here! As @Carl mentioned, the system will auto-close threads once a solution has been found. I’m sorry to hear you’ve run into this issue again!

Unfortunately, we don’t have specific identification on the issue you’re having (perhaps you were thinking of a similar issue where many users had their cores stuck on initializing?)

A few things to note, if possible, please update all your Roon devices to the most recent build (988) and see if that helps.

We’ll need to enable diagnostics on your account and grab a set of logs from your Mac Mini to better identify what might be going on.

Please use the directions found here and send over a set of logs to our File Uploader? Please include a timestamp of when you are attempting to establish connection, or when you lose connection to your core. This will help the team pinpoint things more specifically.

1 Like

Thank you, @Carl.

1 Like

OK @Ben, I’ll see if I can get the logs to you, but I can’t use Roon in any capacity at this point, even on the install lMac Mini. Roon is listed there among its applications, but I get the pulsing Roon logo when I try to connect…

Hi Ben,
I’ve sent the log files. via Roon Uploader as requested; also a time stamped screenshot.

Hey @David_Waring,

Thanks for sending them over. After review, it appears that your Mac Mini is functioning as expected, even with it being able to play music yesterday (Chris Potter on a Sunday sounds like an excellent combination!)

Are you still having issues, David? If so, are they occurring on another device, not your Mac Mini?

Let me know :+1:

HI Bern, Yeah the problem persists with brief periods when I can use either one of my remote devices or the Install Mini to play music. I have no clue what brings about these remissions, or what causes the problem to recur. Today, I was able to use Roon Core to play an album for about 5 minutes, for instance. I’m trying to be zen about this, because my NAD M.50 enables me to play all my files using BluOs without recourse to Roon. but the Roon UI is so far superior to BluOs that this workaround I\s less than satisfactory. Do you suppose Roon and BluOS are conflicting with each other? The M.50 is supposedly Roon Ready.

Hi @ben
How do I proceed now? I haven’t had any response to my recent post (see above)

Hey @David_Waring,

Our team had a chance to review your log set again, and was able to find repeating logs that are pointing towards network difficulties. Here is a snipbit:

07/10 10:19:48 Warn: [rnet/RnetJsonClient] failed to connect Connection refused

It is difficult to pinpoint specifically what might be going on, but signs are pointing to your mesh network. If possible, you can examine your network in more detail using the Fing app. It’s also worth double checking that you’ve disabled any firewalls around Roon.

If you haven’t already, you can also completely unplug your mesh network, and reintegrate back into your setup to see if that clears it up.

For issues with your iPhone dropping connection, try turning off “enable Lock Screen controls” in the set-up tab of settings. We’ve seen this help some users in the past.

I apologize for not being able to provide more details here David. Our team would like to investigate a fresh set of logs, if you could send over another set that would help us continue to look into things for you.

  • Ben

HI Ben,
I’ve uploaded a recent Logs file and time Stamp as requested. I’ll provide the other info as well this weekend.
It turns out “enable Lock Screen controls” was already disabled. -David

Hey @David_Waring,

Thanks for that. After reviewing your information, we’d like some additional clarity in regards to your network. We are seeing two IP addresses on the same network, which isn’t an issue for macOS as one is typically wifi and the other ethernet.

Are you running two wired network interfaces on the same LAN? Or, do you have the typical wired/wireless configuration on your Mac?

If you are running the more typical wired/wireless configuration, please try:

  • Turn off the wifi interface
  • Quit and restart roon on the mac
  • Kill and restart roon remote on the phone
  • Attempt to connect again. You may still get the remote connection screen and if that’s the case then choose “select a different core” and see what happens.

I have a wired component to my network, but only one as far as I know. Accordingly, I went ahead and followed the procedure you listed above. At the moment, everything is working as it should, but as I’ve mentioned, that’s usually a temporary state of affairs. I hope this outcome suggests something significant, or at least interesting.
Concerning your earlier suggestion, I tried to download Fing but that requires an M1 processor and I have only the older Intel in my Powerbook.
Also, I found out “enable Lock Screen controls”was turned off.

2 Likes

@David_Waring that’s great to hear! I’ll be on standby while you continue to test :+1:

Sad to say, things have deteriorated to the extent that my Deezer app isn’t working with my M50.2 and recent database backups list a total of 3 albums in my Library.

Hey @David_Waring,

Thanks for letting me know. While Deezer has no relation to anything related to Roon, it does provide further evidence of your network being the culprit for your issue.

In regards to your database backup, are you able to share a screenshot of this issue?

You mention you have an ASUS ZenWiFi AX (XT8) for a router, are you able to provide the specific version/model number? We’ll need to access the web GUI for your router.

To log into the web GUI:

  1. On your web browser, enter http://router.asus.com
  2. On the login page, key in the default user name (admin) and password (admin)
  3. You can now use the web GUI to configure various settings of your ASUS router.

We’ll be looking specifically into the multicast settings. To find them, head to Wireless on the left-hand side, then click the Professional tab. It should look like this:

From there, head to the Multicast rate (Mbps) and disable it.

Let me know if continue to run into issues after this :+1:

1 Like

Here’s a current status report: All the BluOs functionality of my M50.2 is working, including Deezer and album graphics, which are normally also available in Roon, but aren’t at present This is due to my severely truncated Roon Library. None of the backups I have tried yield more than seven listings for albums in Roon. Curiously, the graphics and most of my Roon Library are accessible via my iPad and iPhone remote devices.

Here’s a current status report: All the BluOs functionality of my M50.2 is working, including Deezer and album graphics, which are normally also available in Roon, but aren’t at present This is due to my severely truncated Roon Library. None of the backups I have tried yield more than seven listings for albums in Roon. Curiously, the graphics and most of my Roon Library are accessible viva my iPad and iPhone remote devices.

I believe you have the model of my Asus router correct: ASUS ZenWiFi AX (XT8)

I’m having troubler with ASUS site. I’ll send you the rest of the info you requested next.