RoonServer Stuck Initializing on new Mac Installation, Logs Showing Critical Exception [Fixed with build 987]

Roon Core Machine

MacBookPro
MacOS Monterey
3.5 GHz Dual-Core Intel Core i7
16Gb RAM
Running RoonServer 1.8 (970)

Networking Gear & Setup Details

MBP connected to TP-Link switch via Ethernet
Media storage connected locally via USB3
Roon Clients (various platforms) connected to network via Google Wifi

Connected Audio Devices

Many different endpoints, most connected to TP-Link switch via ethernet

Number of Tracks in Library

~60k

Description of Issue

I’m building a new Roon server – a MacBookPro dual-core i7 with 16Gb RAM – to move Core off of my Synology. I’ve transferred all music from Synology to a locally attached external drive, connected via USBC, and have a fresh backup from the Synology ready to restore to this new Roon Server instance.

I’ve installed RoonServer on the MBP, started it up, but all of the clients are stuck saying the Core is “Initializing” and the Core never comes up. I’ve tested it with multiple clients and all say the Core is Initializing. And all clients are causing the following errors in RoonServer_log.txt when I restart any client:

> 06/21 07:06:31 Trace: [remoting/brokerserver] [initconn 192.168.1.11:63461=>192.168.1.207:9332] Connected
06/21 07:06:31 Trace: [remoting/brokerserver] [initconn 192.168.1.11:63461=>192.168.1.207:9332] Initialized Fresh Session
06/21 07:06:31 Trace: [remoting/brokerserver] killing old client from d0744363-13c4-481f-802e-8fb1fe666a4d because we have a new one
06/21 07:06:31 Info: [remoting/serverconnectionv2] Client connected: 192.168.1.11:63461
06/21 07:06:31 Trace: [remoting/remotingserverv2] SENT NONFINAL DistributedBroker.ConnectResponse={ BrokerId=f0eb7cf8-1106-4467-9a88-6c09a96f222e BrokerName='RoonMac' }
06/21 07:06:31 Trace: [remoting/remotingserverv2] SENT NONFINAL DistributedBroker.UpdatesChangedResponse={ IsSupported=True WasJustUpdated=False Status='UpToDate' HasChangeLog=False CurrentVersion={ MachineValue=100800970 DisplayValue='1.8 (build 970) stable' Branch='stable' } }
06/21 07:06:31 Critical: scx: System.TypeInitializationException: The type initializer for 'Sooloos.Broker.Music.LibraryUtils' threw an exception. ---> System.NullReferenceException: Object reference not set to an instance of an object
  at Sooloos.Broker.TinySooid.Get (System.Sooid s) [0x00005] in <7cecef3f1d4c4639b87a9cf0466771ff>:0 
  at Sooloos.Broker.Music.LibraryUtils..cctor () [0x0001d] in <7cecef3f1d4c4639b87a9cf0466771ff>:0 
   --- End of inner exception stack trace ---
  at Sooloos.Broker.Music.LibraryApi+<>c.<get_LoggedInStreamingServices>b__126_0 (Sooloos.Broker.Music.LibraryApi self) [0x00000] in <7cecef3f1d4c4639b87a9cf0466771ff>:0 
  at Sooloos.Concurrency.SharedObject`2[T,THREAD].Read[U] (System.Func`2[T,TResult] getval) [0x00068] in <65207027110e40f3b7383d771d6e3c1b>:0 
  at Sooloos.Broker.Music.LibraryApi.get_LoggedInStreamingServices () [0x00000] in <7cecef3f1d4c4639b87a9cf0466771ff>:0 
  at Sooloos_Broker_Api_Library_Adapter.Serialize (System.Object obj, System.IO.Stream stream) [0x00325] in <bebd2ca6b826450fba9734c0f755d191>:0 
  at Sooloos.Broker.Remoting.RemotingServerV2._PutObject (System.Object o, System.IO.Stream stream, System.Boolean inline) [0x0010b] in <709d129b856b4e878e1fc221d8306693>:0 
  at Sooloos.Broker.Remoting.RemotingServerV2.Sooloos.Broker.Remoting.IRemotingContext.PutObject (System.Object o, System.IO.Stream stream, System.Boolean inline) [0x00000] in <709d129b856b4e878e1fc221d8306693>:0 
  at Sooloos_Broker_Api_Broker_Adapter.Serialize (System.Object obj, System.IO.Stream stream) [0x0028b] in <bebd2ca6b826450fba9734c0f755d191>:0 
  at Sooloos.Broker.Remoting.RemotingServerV2._PutObject (System.Object o, System.IO.Stream stream, System.Boolean inline) [0x0010b] in <709d129b856b4e878e1fc221d8306693>:0 
  at Sooloos.Broker.Remoting.RemotingServerV2+<>c__DisplayClass29_0.<OnGetService>b__0 (Base.Result`1[T] result) [0x0002b] in <709d129b856b4e878e1fc221d8306693>:0 
  at Sooloos.Broker.Distributed.ServerConnectionV2.OnGetService (System.Guid guid, Base.ResultCallback`1[T] cb_result) [0x0001e] in <7cecef3f1d4c4639b87a9cf0466771ff>:0 
  at Sooloos.Broker.Remoting.RemotingServerV2.OnGetService (System.Int32 rid, System.Byte[] body) [0x0001f] in <709d129b856b4e878e1fc221d8306693>:0 
  at Sooloos.Broker.Remoting.RemotingServerV2+<>c__DisplayClass23_0.<OnRequestReceived>b__0 () [0x00011] in <709d129b856b4e878e1fc221d8306693>:0 
  at Sooloos.SynchronizationContextThread+<>c__DisplayClass45_0.<Post>b__0 (System.Object _) [0x00000] in <bff8c9cf380348e1aa89b7af87e839b1>:0 
  at Sooloos.SynchronizationContextThread._Dispatch (Sooloos.SynchronizationContextThread+SendOrPostWrapper& ret) [0x00012] in <bff8c9cf380348e1aa89b7af87e839b1>:0 
06/21 07:06:41 Debug: [easyhttp] [13] POST to https://device-map.roonlabs.net/1/register returned after 109 ms, status code: 200
06/21 07:06:41 Trace: [devicemap] device map updated
06/21 07:06:42 Info: [stats] 33665mb Virtual, 157mb Physical, 49mb Managed

Thoughts or suggestions? This is a fresh, clean MacOS install with nothing else running. I’ve tested that DNS from the MBP works fine and as expected using both internal and external DNS servers, and everything else appears to be normal.

I’ve included a screen cap from the latest Mac client.

2 Likes

Do the logs from the client have anything to add?

Are all the clients Macs and are they all running Monterey? Have you tried a client running another version of macOS?

Can you run your server on another version of macOS?

Have you tried an iOS client?

  • Client logs are throwing this exception:

06/21 09:12:27 Trace: [push2] exception thrown. restarting connection (Unable to connect to the remote server)

I’ve verified that the Mac firewall is allowing all incoming connections for the “RoonAppliance” service. I’ve also tested completely disabling the Mac firewall and restarting RoonServer, same result and same exception thrown in the client logs.

  • No, I tested multiple clients. The screenshot I attached from from a client running on Big Sur. I also tested with iOS with the same result.

  • I can test another version of MacOS but it’s not trivial to downgrade. The Core requirements say anything above 10.14 is supported so it would be great to hear if Mojave is officially supported for Core before I flash the system and try Big Sur.

@support This might be a stretch but I have noticed most if not all reported initializing issues are users with core i7 Macs.

1 Like

Hey @rcrawley,

Thanks for taking the time to write in! Our team is taking a deeper look into this.

I see you mention that you’re moving your Core to a new setup. Prior to doing this, did you log out of your older Core prior to logging into the new setup?

I will be monitoring this thread for your reply :pray:

Hi @Benjamin. Yes, I shutdown the core running on the Synology before I installed RoonServer on the MBP, so the only core that’s up and running is the one one the MBP. I haven’t re-enabled the Synology core at all since working on this issue.

Hope that helps and let me know if you need anything else. Thanks!

1 Like

Hey @rcrawley,

Thanks for the information. While our team digs in a bit deeper, I want to triple-check: when you brought up the new core and logged in, did you get the option to transfer your account/license to the new core?

Roon Core Machine

Mac Mini, OS Monterey 12.4, M1 CPU, 16 GB RAM (Core Machine), 256 GB SSD, RoonServer 1.8 (build 970), Connected to ethernet hub (no wifi used) - see below.

Networking Gear & Setup Details

Combined wifi and wired network, Linksys two-node Velop mesh network for wifi, Velop configured as router connected to cable modem and to an 8-port ethernet hub.
Mac Mini core connected to ethernet hub (no wifi used) and the iMac running Roon app used to remote into the Mac Mini core is also only using ethernet (via an ethernet-over-powerline adapter to the hub). The two machines are on different floors in our home.

Connected Audio Devices

At this point only wifi streaming to KEF LSX speakers and to Yamaha receiver but have not been able to do so using the new Mac Mini core as I’ve been unable to port the existing core to it.

Number of Tracks in Library

820

Description of Issue

I set up a new mac mini as a roon core (just installed the roon server software) and can screen share from the iMac to it. When trying to transfer the core function to the mac mini, I screen share into the mac mini from the iMac, I see that the Roon server is running on the mini, I start Roon on the iMac and it attempts to connect to the new core, but it stays stuck at initializing (with a red dot).

I’ve reinstalled the Roon app on the iMac and the mac mini and I turned off the firewalls on both machines. I’m at a loss as to what to try next. Any advice is welcomed.

Update: I tried using wifi with the mac mini and remote computer (took both off ethernet) and it still hung-up in initialization. Also, allowed to run overnight but never left initialization stage.

Update 2: To eliminate any communication issues, I installed the roon app on the mac mini. When I ran it, both my current core appeared as Ready (green dot) and the core on the mac mini itself still showed as initializing (red dot) and never ended that state.

Resolution: In attempting to resolve this stuck in initialization problem, I don’t recall how I actually got to this point, but the problem was that I had not logged out of the original core before trying to setup a second core. Roon on the mac mini indicated I had to use the current core or log out of it to use a new core (can’t have two cores running at once, obviously). Once I logged out, I was able to connect to the new core on the mac mini, which showed in the Ready state. Not sure what I did that caused Roon to require that logout decision, but that’s what fixed it.

Roon Core Machine

Mac Mini, OS Monterey 12.4, M1 CPU, 16 GB RAM (Core Machine), 256 GB SSD, RoonServer 1.8 (build 970), Connected to ethernet hub.

Networking Gear & Setup Details

Combined wifi and wired network, Linksys two-node Velop mesh network for wifi, Velop configured as router connected to cable modem and to an 8-port ethernet hub.
Mac Mini core connected to ethernet hub (no wifi used).

Connected Audio Devices

KEF LSX speakers, Yamaha receiver, ipods, iPhones and iPads.

Number of Tracks in Library

900 tracks

Description of Issue

I setup a new mac mini as a headless dedicated core by installing Roon Server, but when accessing it from a remote Mac running Roon the core was always in a state of initializing. To try something different, I installed Roon on the mac mini and then the remote Mac could access the mac mini core (as could Roon on the mac mini). If I stop running Roon on the mac mini, then the remote Mac sees the core initializing, which never stops. I’m confused as I thought only Roon Server was required on a standalone core.

Any explanation as to why Roon is necessary or suggestions to resolve how I can avoid running the full Roon software on the mac mini would be appreciated.

Hey @Philip_Panagos

Thank you for getting in touch, and welcome to Community! We’re happy to have you but sorry to see that it was an issue that prompted your first post.

I’m glad that things are working for you now! Please feel free to reach out if you ever have any other questions or issues. Happy listening :headphones:

Hey @Philip_Panagos,

In checking your system diagnostics it’s difficult to parse exactly what took place on your machine. But, it appears that Roon Server and Roon all-in-one were installed on your Mac Mini at some point. In addition, Roon Server looks like it was also installed on a NAS at some point.

I would recommend that you decide which install you prefer on that machine, Roon Server or Roon all-in-one, then uninstall the unwanted version.

For Mac to uninstall Roon completely hold down the Option key (⌥) to unhide the Library folder in the Go pull-down menu. You’ll then need to navigate to ~/Library/Roon or ~/Library/Roon Server (depending on which way you choose) and trash that folder. Removing the app alone won’t remove the cache and config data.

1 Like

Thanks for the response, Jamie. Unfortunately, if I just run Roon Server then all the remote computers and devices just see it initializing. In another thread, Support stated that Roon Server wasn’t running correctly on the mac mini’s (other’s had this problem too). So a fix for Roon Server is what is needed and what I prefer to run on my dedicated mac mini Roon Server. Hopefully that will be soon.

Early in my free trial that I started about 3 weeks ago, I did install on my NAS but never used it. I then used Roon on my MacBook Pro as my Server until my mac mini arrived last Friday. So now I intend to use the mac mini running only Roon Server if and when it is fixed so I can do so. If there are traces of my NAS server and/or my MacBook server lingering, how do I ensure they are fully eliminated ?

1 Like

@jamie this is the problem….it’s a roon server bug no issues with Roon all in one installs.

See the many other threads with this issue including mine on 3 different macs all with clean installs, and one that was running roon just fine on build 952 before updating last week

@support and it’s still a problem!!!

2 Likes

Core Machine (Operating system/System info/Roon build number)

MacMini (2018)
3.2 Ghz Intel Core i7
32Go RAM
12.4

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Unifi switch
Unifi Gateway
Everything is linked via Ethernet cat6b

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Linn Streamers (5 different models)

Description Of Issue

Hi,

I had an error with a corrupt database, so I loaded a backup.
it got stuck to initializing, so I decided to reinstall from scratch, roon & roonserver, (in order to build a new database), but when I tried to turn it on again, the server got stuck to initializing …
You can find the logs here :

Thanks!

1 Like

Any help ?

anyone ? any idea ?

Roon Core Machine

M1 Mac mini, 16Gb RAM, 1TB SSD, latest Roon & RoonServer downloads from site. Latest MacOS.

Networking Gear & Setup Details

Connected via ethernet, static IP handled via DHCP reservation to Unifi Dream Machine Pro, which serves as the hub for everything else. Wifi is not connected. The rest of the network contains two Unify switches and two WLAN APs.

Connected Audio Devices

No directly connected audio devices to this machine.

Number of Tracks in Library

Ca. 50000.

Description of Issue

Trying to move a ROON installation from a QNAP NAS to a dedicated machine, but RoonServer is – like for some others, it seems – stuck on “initializing…” on my Mac.

Opening up the all-in-one Roon app and setting the core works, but this is not a sustainable solution in the long run (too easy to quit, needs to be launched at startup etc.) as the only thing that’s needed is the server component.

This is curious in the sense that the QNAP NAS installation of Roon was working just fine in the same network surroundings, without any alterations/port forwards/firewall rules.

Have double checked the Mac mini’s setup, and the firewall in it is off & everything seems fine.

Need help establishing how to get RoonServer past the “Initializing…” part on this machine so I can properly set it up and restore my library. Currently I cannot use Roon at all.

Edit: Also, I’ve two Roon licenses instead of one: don’t know if this plays a role.
Edit: Clarifications to networking and a few other items.

Can you describe the process you followed in moving from the QNAP to the Mac? Did you first build a new server on the Mac? Are you trying to restore a backup of the QNAP server from to the Mac?

Thanks for the swift reply. I only installed RoonServer, and starting that results in the menu item saying the server is running. Players just report it being infinitely “Initializing…” as seen from the screen cap here:

So, I’ve not restored the backup from QNAP installation as I cannot even get to that step. I am able to do it (restoring the QNAP backup) running the entire Roon package on the Mac Mini, which works fine and gives me access to the library etc – so works in total.

So this seems to be only RoonServer problem. However as a solution that’s unfeasible in the long run for reasons found in the original post.

I see you’re running macOS 10.16 (Big Sur) but is it fully updated? Hasn’t Apple updated Big Sur to macOS 11.6.7?

Have you checked the Roon logs for errors that might be responsible for the continuous initializing?