Roon Core Machine NUC 8i3 BEH down after Bios Update

Roon Core Machine

Intel NUC 8i3 BEH mit Transcend 128 GB PCIeTM Gen3 and 8 GB Ram

Networking Gear & Setup Details

Switch Netgear GS 608 conect to NUC on Ethernet, no VPN using

Connected Audio Devices

Audio Devices: iPhone, iPad,…WiFi or Ethernet

Number of Tracks in Library

Tracks >8,000

Description of Issue

The NUC 8i3 BEH has been updated several times with the latest BIOS from Intel. All installed without problems (last… A few days ago I flashed the current bios BE using a USB stick. The stick was FAT formatted with the mentioned file. The NUC did not find the file with F7. Then format the stick to NTFS and try again… the new bios will be recognized and the update has been successfully confirmed. After rebooting the NUC, no more Rock OS was found. Then I tried to save the OS with a restore… without success. Next attempt to reinstall the Rock OS was successful and confirmed up to the point of removing the USB media and rebooting. The reboot meant that no boot partition was found either. Check the bios settings with F2 according to the installation instructions. Adjusted according to the specifications, then installed everything again… No boot partition found. I attributed the error to a defective Transcend 128 GB PCIeTM Gen3. This was newly ordered and installed… unfortunately the same error message that no boot partition was found. My other suspected error is a defect in the bootloader of the NUC. How can I check this function or is the NUC defective and to be replaced?
Thank you all in advance for the feedback and help.
Kind regards

Not a NUC user myself, but can’t you try and reflash the prior bios version to verify your hardware is still okay?

1 Like

As above, not a NUC user, but legacy booting is or has been phased out. Dell announced this in 2020 for their machines. I’m not sure which NUC version has stopped supporting Legacy booting…

There was a similar topic the other day:

It might be worth downgrading your BIOS.

I use an Intel NUC8i5BEH and it should be very similar to yours.
When installing BIOS 090, I noticed that many settings in the BIOS were reset to the default value. This did not happen when installing previous BIOS versions.
It’s possible that this happened to you too, so you need to restore the settings you had before installing BIOS 090, including those related to the boot sequence.

Hello Support Team of Roon, thank you all for the fast Feedback,

the Core NUC 8i3 BEH is back online after a few hours of searching for the causes…


The current BIOS update BE had no compatibility with Rock and the SSD M2.


With F7 it was not possible to flash back to the previous BIOS version

Resetting the BIOS could only be done with the “Power on” button and pressing 3 seconds (until it flashes orange). Then the function of resetting the BIOS version is offered in the menu.


After resetting the SW, the disconnection from the mains and the replugging of the security jumper to 12 / 23 is indicated. (The security jumper is shown with a photo on the INTEL NUC website). Here the change of position to 1+2 led to no success!

Position 2+3 and the reboot after assembling the NUC then had the hoped-for success. The SSD M2 was recognized as a boot disk, Rock could be reinstalled, the core could be connected to all PCs, iPhone, iPads and the 1TB SSD with the music was also recognized directly.

After 12 hours on the Internet, all Core Flac files with the metadata were updated again (only the radio stations need to be resaved or reinstalled from the backup)

A note of the problems with the Boot SSD M2 in connection with the mentioned BIOS version for the NUC 8i3 BEH & ROCK is certainly helpful.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.