Roon core unstable after an update. HARD DOWN

I was reading into this that i may be able update a driver and fix the issue …

No, ROCK already uses the best available open driver, the one mentioned in the link.

However, I agree generally with @ipeverywhere (and Roon’s ROCK documentation) that using a reimplementation (i.e., in the Linux driver) of a proprietary, not fully documented, highly complex file system is asking for trouble in general.

Hey @Ben_Katz,

After digging into this with the team again, we have two options for next steps:

  1. Split up your library 50/50 into two folders, and only sync one folder with your core. Check to see if any crashes occur, then check the other half. You can start to figure out if corrupt files are the culprit here.

  2. As another temporary workaround, and to get around any possible NTFS issue, can you attach the drive to a Windows machine and share it out to the Core via a network share? Then Windows can deal with the filesystem and Roon will just use SMB to read/write data. That may tell you if it’s an issue with the contents of a file vs. something with the hardware.

Let me know how the above goes :+1:

Ive attached the offending drive to the comuter with the remote. Ive tried to share it a few times but have had no luck. I opened the properties and did the advanced share. I copied the network path but it doesnt seem to work…

Could it be an issue with this core machine?

Have you attempted reinstalling?

Screenshots of the Add network share dialogs in Roon would be useful to help diagnose this. If you can get this working, that would allow you to test out @benjamin 's suggestion to isolate the cause of your original issue.

Ok. I have run a few more tests and made few observations. I split the folders in 2 equal sizes and loaded one. It loaded and was fine. It did not matter wether it was plugged directly into the NUC or the usb hub.

If i added ANY additional sub folders ot crashes the core. It doesnt matter which folder.

I also noticed that even when my core is up and playing music it is hot or miss whether i can access the core via \Rock.

Additionally i got to a place where the Core would not recognize the drive. I took it to another computer and it showed errors. I fixed the errors and plugged it back in with only connecting the 1 folder it played fine. When i added any other subfolder it failed and the drive showed errors on the other computer. When i gixed the errors it worked fine. It seems as if ROON is corrupting the disk

Ok. I bought a new HD. I formatted it as exFAT. I copied the drive to it. Plugged it directly into the NUC. It got well past halfway scanning the drive. Up until that point it would stutter every once in awhile but would retain the search and keep going. It crashed the core at 5:47PM. (3 mins ago) please look at the logs and tell me what was happening around that time. I have now eliminated all of the conjecture save the ROON update and the possibility that at the very moment that ROON updated that large update some file got corrupted. Please help me

I posted this at the bottom so look there fir detail but on a clean drive connected directly to the NUC which has the core it crashed at 5:47PM this evening @benjamin

Okay. So another update. I noticed that roon recognized the tracks it had sorted through when it crashed. I restarted the syncing and it crashed once more but i got to the end. Roon choked the whole way through but i now have a fully restored library.

So…it wasnt corrupt files. It wasnt the drive or the hub. All of that is still in place. There is something that has changed in Roon when scanning files… and something had changed in a recent update to make it better…

I will wait 24 hours to be sure but i will report back to close the ticket in a bit


Well, I truly hope that solved everything for you Ben! Quite a saga, get why you were very understandably ticked initially. Fingers x’ed.

Thanks Johnny

Ok. All seems to be stable.

Hoo hoo!

Happy new year, hope it’s still stable in a few days!

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.