Roon core unstable after an update. HARD DOWN

Yes. I get that. I was bringing it upnfor the coincidence of a HW failure the very second i update the software. Im keenly aware of that as i have worked in software for a long time

1 Like

They did, in RoonOS build 254 (which applied to ROCK), the one released on Nov 9.

Which uncovered the many issues with people’s dirty NTFS external drives

1 Like

oh, good catch. Linux and NTFS have always been a poor combination.

@Ben_Katz If this is an NTFS drive do you have some place to move the data, reformat the drive as something not NTFS, and move the data back? If it is an NTFS error error with Linux that should remove the fault. If it truly is a drive issue then moving the data around should show errors on another machine.

1 Like

The NTFS question came up several times in this thread above, and in one post by Roon support it was specifically mentioned to attach the disk to Windows and run a disk check. However, I don’t think the specific command was ever mentioned, as far as I can see, and I can’t remember the outcome (without rereading the whole thread).

@Ben_Katz did you ever try this?

  • Attach the USB Disk to Windows. Note the drive letter that it receives in the File Explorer
  • Search for CMD in the Windows Start menu
  • When Command Prompt appears, click Run as Administrator
  • When the command window opens, type the command (without quotes, and assuming that the drive letter is Z - change as needed): “chkdsk Z: /f /r”
  • Press Enter key after entering the command and wait.
  • When it is done, close the command window
  • Remove the drive safely as described here: Safely remove hardware in Windows - Microsoft Support

Does it work now on the ROCK?

There were quite many issues caused by previous unsafe removal of USB drives with NTFS file systems (e.g. unplugging from Windows without safe removal or unplugging from ROCK without shutting down), now that RoonOS since build 254 is strict about it (which is a very good thing as it avoids corruption)

Understanding of the issue has improved over time, Roon are working on a better solution:

NTFS was never recommended for external storage on ROCK because of issues like this. exFAT is recommended if Windows compatibility is needed:

1 Like

The drive that is at issue works on my other computer. It works on my friends ROON that has not been updated and chhdsk reports no errors. Is it still possible its the drive and not the drivers?

The friend’s Roon that wasn’t updated means little, part of the dirty-removal problem was precisely that the Linux kernel in the previous RoonOS didn’t refuse drives that it should have refused because of file system inconsistencies.

But if Windows chkdsk reports no errors, then I guess you ruled this one out as well :frowning:

I don’t remember that whole thread anymore, so sorry if I say something stupid, but if I had a drive that doesn’t work in all machines for unknown reasons, but still works in one machine, I would use this machine to copy the data off it ASAP and buy a new drive

Thank you for your help!

Sorry, I have wasted your time today. I just read through the thread and realized we went through this chkdsk thing already previously :frowning: I hope that Roon support can figure it out!

Not at all! Nobody reads the whole thread and i appreciate the help. @Suedkiez

1 Like

Well, I was here all the time, I could have remembered or searched for it :slight_smile:

Is there any Roon help coming? @danny . Interesting note. I started a 1 core audio analysis and after a short time the core crashed.

Hey @Ben_Katz,

Is this still the case? If so, we’ll need to continue to focus on the drive in question. It’s often that Roon will discover recent corruption after an update, as that’s part of the update process. It isn’t that the update caused corruption, it more so identifies hidden or low lying corruption and alerts us of it.

As @Suedkiez mentioned earlier:

I would recommend moving your data and reformatting the drive to exFAT and see if your issue persists.

So its expected behavoir for a drive to show no errors in chkdsk, work on another machine and another ROON instance but still be the drive? If you reply yes, i will reformat the drive. @benjamin

Poor @Ben_Katz, yes he did when we asked the first time,

Later I asked him again and now you :slight_smile:

chkdsk is a windows things. Note that Microsoft has never released NTFS into the public domain (unless I was just not paying attention). Linux’s ability to read NTFS filesystems have always been a bit of a hack. Writing has been even a bigger hack. There is lots of history here.

There are 2 variables you’re not accounting for.

  1. Linux vs. Windows use completely different versions of the base library to read / write NTFS file systems. I’ve got a painful history here so I am biased towards a “good luck” when attaching NTFS file systems to Linux.

  2. You are moving the drive but are you moving the USB hub? USB isn’t entirely reliable regarding data transfers. Saturating the USB can cause read errors. As I stated previously I’ve seen USB controllers fail in odd ways. I don’t recall if you tried plugging the drive directly into the motherboard of the NuC? That’d be a good datapoint to get.

As a temp workaround, and to get around any possible NTFS issue, can you attach the drive to a Windows machine and share it out to the Core? Then Windows can deal with the filesystem and Roon will just use SMB to read / write data. That may tell you if it’s an issue with the contents of a file vs. something with the hardware.

1 Like

Also, since I was curious on the state of NTFS in Linux…

There are now 3 different sources of code supporting NTFS in Linux. I have no idea which one Roon is using.

There was an old and rotting kernel driver that nobody sane was using. Distributions used ntfs-3g, but this was a FUSE module and thus in userland and not in the kernel. As the new driver seems to have come with a kernel update, it can really only be the NTFS3 driver that was somewhat surprisingly donated to Linux in 2021 by Paragon:

How does that affect my issue

I think we’re just trying to convince you that connecting a NTFS formatted drive to Linux isn’t reliable and can cause issues.

Sorry, I just answered @ipeverywhere’s question, probably best not to discuss this in this thread