Roon crashes corrupt database

Roon Core Machine

Intel i3-9100, 32 gb RAM proxmox installed. On Debian 10 VM roon core (VM with 8 gb ram)

Networking Gear & Setup Details

unifi switches, and unifi AP

Connected Audio Devices

Hifiberry connected with wire

Library Size

Description of Issue

When I start Roon server I see that it already takes 1.7 gb ram, which increases in a day to about 6.7 gb ram. Eventually the Roon app will not start anymore with a “There is an issue with your database please contact support” If I reinstall the core and restore a backup the same issue occur. I now try to restore backups from a month ago but same issue, maybe somewhere a corrupt database? Also when I try to restart the roonserver.service I see “Failed to add a watch for /run/systemd/ask-password: inotify watch limit reached”

If you get “There is an issue with your database……” message after a Restore, then that Restore was taken when the database already had ‘latent corruption’.

Conceivably, all your Backups might be corrupted. In that case, there’s nothing you can do but start afresh. Hope you haven’t done a lot of curation.

See why this might occur in this post.

Don’t do anything drastic until you here from @support.

Thx for your reply. This does not sound good. I could start with a clean database and import my music on nas. But then i would miss all my albums added through tidal and playlists. Now roon has been running for a day already. Maybe i coul write down all tidal albums .🥲

All your Tidal favorites must be safe.
Log into Tidal app and check.
They will be pick up by Roon easily.

1 Like

more information here

1 Like

Well, that is a probably a resource issue, the answer is to increase your inotify watch limit.

See this post

1 Like

Hi @Tom_den_Heijer, would you kindly use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service)? Thanks!

1 Like

I have sent the logs. Also, as a test, I started the roon core without restoring my database. Immediately lower memory usage. If I add my Tidal account the total ram usage increases to 2Gb. But after a night playing this stays at 2Gb (with the database restored it increased to around 6 Gb ram). So the leak seems to come from the database which -besides Tidal- includes my music on a NAS

Thanks, @Tom_den_Heijer, I’ll take a look at the logs.

How many tracks total do you have in your library when you include the NAS? For larger libraries, it’s definitely going to use more resources.

I have now only using Tidal 4700 tracks. On my NAS I have around 3000 tracks. So in total around 8000.

Thanks, @Tom_den_Heijer. That’s not too large, so I don’t think that should be the problem. I’ll take a look at the logs and will follow up soon!

Did you have the chance to look at the logs? The last months I only enabled TIDAL and that worked fine with memory usage around 2Gb. Today I decided to add my NAS music again and immediately the memory usage increased to 7 Gb Ram. A restart decreased the memory again to 1.7 Gb but I do not know for how long…:slight_smile:

edit: after 3 hours playing, memory is already at 7.5 gb ram…maybe a restart every three hours is necessary… ;-(

Hey @Tom_den_Heijer,

Thank you so much for following up on Dylan’s post. We are very sorry for the delayed reply on our part… :pensive:

Dylan has brought me up to speed on your case and the great news is that our team has been actively working on bringing improvements in this area. We discuss it in depth here:

If you feel comfortable joining the beta I think it would be of great help :nerd_face:

Thanks, I saw this improvement and it may help me. I signed up for the beta

1 Like

Hey @Tom_den_Heijer,

That’s awesome! Thank you for trying that.

Now, the time has come for the official release of build 846. We’d love to see if it goes just as well as the beta.

Hello Rebeka,
The last two weeks I have again issues with a corrupt database. Sometimes I see this after Roon has made a backup of the database at night and then in the morning it will not start due to “issue with database” Just now I tried to play a song of an album I just added to my library and again “issue with database”. Restarting the Roon core, helped fortunately. Do you want me to send the logs of the latest crash

Yes, please @Tom_den_Heijer. We’re particularly interested in taking a look, especially if you’re running Roon on the latest build. Could you please let us know once you had a chance to upload the logs?

The drive is here.

This morning I got an “issue with database”, logs are uploaded. Some weeks ago I went from a debian VM install to ROCK. I restored a database backup and everything works after that. Until the next crash…

Thanks @Tom_den_Heijer. We got the logs :nerd_face:

We’ll follow up as soon as our team has a chance to check them out :pray:

Hey @Tom_den_Heijer,

Thanks for your patience :pray:

After taking a close look at the logs, we’ve seen clear traces of database corruption. We’re so sorry this is the case!

Starting with Build 880, we’ve been a lot more strict with integrity checking, meaning that even partially corrupted databases won’t work.

We’re truly sorry this is the case…starting fresh is the best next step :pensive: