Roon Crashes Immediately on Startup (MB PRO M2, Ventura OS) [Solved]

Running off a Roon Nucleus

Nighhawk Router, Laptop on WiFi, Nucleus hardwired in. Nord VPN.

Connected Audio Devices

Have BluOs endpoints thru the house

Number of Tracks in Library

300,000+ tracks

Description of Issue

Recently got a new MB Pro M2 and migrated my old laptop to new. Roon was working fine, running off the Nucleus and I restarted my computer and now it won’t open. I see the Roon home screen for a split second and it closes. No crash report whatsoever.

Has anyone else experienced this issue? I saw something from last November - not sure it was the same situation.

Thanks in advance everyone.

@Maxwell_Gosling, how did you perform the migration? Did you restore from a Time Machine backup or migrate files over manually?

so i did a manual migration and its been working now for about a week without issue. i did a restart today because it felt like my computer was laggy - nothing related to roon. once i went to re-open it after the restart is when the issue presented itself.

As the MBPro is a Roon Remote, have you tried downloading and reinstalling a fresh copy from Roon?

Have not done anything at this point - you’re saying just D/L a fresh copy and overwrite the app?

Yes, just reinstall over the old version on the MBPro.

Downloaded, installed. Same result.

I am tagging @support, they may need to look at your logs from the Core or MBPro.

@support I am having the same issue. I run my Roon primarily from desktop iMac, with Nucleus+ connecting my main stereo system/amp/streamer in the living room. Last night I turned on Roon and it asked me to install the update. I did, and it immediately crashed. I power cycled the Nucleus several times to no avail. ROON will not load on my Mac, it just instantly crashes. HELP.

1 Like

Same problem here! Crashing immediately on my Mac Mini M1. Tried reinstalling app - no luck.

Please help me too!!

Hey there @Maxwell_Gosling. Everyone,

Thank you for reporting this issue. I’m a Mac user too and would like to help you get to the bottom of this.

I would normally see about getting diagnostics from you remotely but with a client that won’t run, that won’t be possible. Will you please get me some logs? Follow the instructions below and I will take a look at this in the morning. Please keep in mind, we need the logs from the Mac and not the Nucleus so you’ll be looking for the Roon folder on the Mac.

Use the directions found here and send over a set of logs to our File Uploader

Alternatively, as long as you have backups, it should be possible to restore Roon with no data loss. I will also list the instructions for a fresh install of Roon to give you something else to work with and a more immediate solution. The logs will still be in that location and still useful so please do still upload them.

  • Find the folder that says “Roon” Mac software location
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

Let me know and thanks,

1 Like

@Wes , thanks for the reply. Just uploaded some of the more recent logs from the Mac library. Going to wait on you before taking further action.

apple security updates this week killed Roon on iOS and MacOS. bang, bang. Roon screen flashes, disappears. I reported to support today 2.17.23 asking for help.

1 Like

@support My experience with this issue suggests that the problem is with Roon and not Apple (or compatibility between them). Roon was working absolutely fine for me until ROON asked me to install the new update. The moment I installed the Roon update was the moment Roon instantly crashed. So it may be that the Roon update is no longer compatible with Mac iOS but the cause and effect from where I sit puts the problem with the Roon update.

1 Like

I am having the same issue, both on Mac Pro and iPhone. It showed up first on the phone, which probably auto updated. Laptop asked for an update, and now Roon will not launch on either device. My core is a Nucleus.

Exactly my experience. I thought an update to roon devices was going to help. Then the Mac roon crashed. Oops.
Fortunately the core still runs fine (oddly enough) and I can run that via screen sharing command and control.

We wait.

hey everyone,

i followed the alt suggestion here, renaming the roon folder to roon old and reinstalling and it seems to have solved this issue for me. hope this is works for the rest of you in a similar situation.

1 Like

And I spoke to soon! Once I tried to play music, the app quit and crashed and won’t re-open. Back to square one. Please help!

1 Like

Hi everyone,

I need some help isolating this.

Will each of you experiencing this issue please chime in with your MacOS version and what processor platform you’re using (M1, M2, Intel)? I know that some of you have already supplied this but we need specifics for each case to pursue a root cause.

Thank you in advance,

1 Like

M2, Ventura 13.2 (22D49)

1 Like