Roon crashes on MacOS 10.14 Mojave beta

Roon.app/Contents/Resources/VERSION:

100500339
1.5 (build 339) stable
stable

System:

2018 MacBook Pro 15" w/ TouchBar
2.9 GHz Intel Core i9
32 GB 2400 MHz DDR4
1TB SSD
macOS Mojave 10.14 beta 8

Audio:

Laptop -> USB-C to mini-B -> JDS Labs O2/ODAC -> Headphones
No local music library
Streaming Tidal Hi-Fi

Steps to reproduce:

  1. Start Roon by double-clicking /Applications/Roon.app or by running /Applications/Roon.app/Contents/MacOS/Roon from the terminal

Expected results:

Roon starts

Actual results: Roon crashes with:

$ /Applications/Roon.app/Contents/MacOS/Roon
00:00:00.000 Debug: Attempting to load library: /System/Library/Frameworks/Foundation.framework/Foundation
00:00:00.009 Info:  Library[/System/Library/Frameworks/Foundation.framework/Foundation] Loaded success => True
00:00:00.009 Debug: Attempting to load library: /System/Library/Frameworks/AppKit.framework/AppKit
00:00:00.111 Info:  Library[/System/Library/Frameworks/AppKit.framework/AppKit] Loaded success => True
00:00:02.911 Debug: Attempting to load framework: /System/Library/Frameworks/Cocoa.framework
00:00:02.923 Info:  Framework[/System/Library/Frameworks/Cocoa.framework] Loaded success => True
00:00:02.923 Debug: Attempting to load framework: /System/Library/Frameworks/OpenGL.framework
00:00:02.925 Info:  Framework[/System/Library/Frameworks/OpenGL.framework] Loaded success => True
00:00:02.925 Debug: Attempting to load library: libHIDRemoteNative.dylib
00:00:02.926 Info:  Library[libHIDRemoteNative.dylib] Loaded success => True
00:00:02.927 Debug: Attempting to load library: libSPMediaKeyTapNative.dylib
00:00:02.928 Info:  Library[libSPMediaKeyTapNative.dylib] Loaded success => True
Assertion failed: (_eventPort != NULL), function -[SPMediaKeyTap startWatchingMediaKeys], file SPMediaKeyTap.m, line 78.
Stacktrace:

  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) ObjCBindings.Messaging.void_objc_msgSend (intptr,intptr) [0x0000a] in <d839154cc8894716a4db0f23fa6bf27a>:0
  at ObjCBindings.SPMediaKeyTap.StartWatchingMediaKeys () [0x00016] in <d839154cc8894716a4db0f23fa6bf27a>:0
  at Broo.Engine.OpenGlWindow.<InitHIDRemoteAndSPMediaKeyTap>b__158_0 () [0x00054] in <5c27af822fd84971867f5ce4da4dbcb3>:0
  at Sooloos.Application/<>c__DisplayClass1_1.<Main>b__10 () [0x00006] in <13701f8b949a4115b1b0592a29173403>:0
  at Broo.Engine.DeviceTarget.ProcessSafeQueue () [0x00005] in <5c27af822fd84971867f5ce4da4dbcb3>:0
  at Broo.Engine.DeviceTarget.GuiMainLoop () [0x000d2] in <5c27af822fd84971867f5ce4da4dbcb3>:0
  at Broo.Engine.Engine.GuiMainLoop () [0x00006] in <5c27af822fd84971867f5ce4da4dbcb3>:0
  at Sooloos.Application.Main (string[]) [0x003f7] in <13701f8b949a4115b1b0592a29173403>:0
  at (wrapper runtime-invoke) <Module>.runtime_invoke_void_object (object,intptr,intptr,intptr) [0x00051] in <13701f8b949a4115b1b0592a29173403>:0

Native stacktrace:

	0   Roon                                0x000000010154abf8 mono_handle_native_crash + 264
	1   libsystem_platform.dylib            0x00007fff72543c9d _sigtramp + 29
	2   libSPMediaKeyTapNative.dylib        0x000000010c4a46d0 singleton + 1880
	3   libsystem_c.dylib                   0x00007fff724041c9 abort + 127
	4   libsystem_c.dylib                   0x00007fff723cc868 basename_r + 0
	5   libSPMediaKeyTapNative.dylib        0x000000010c4a09a3 -[SPMediaKeyTap startWatchingMediaKeys] + 211
	6   libxammac.dylib                     0x0000000108e68fe9 xamarin_dyn_objc_msgSend + 217
	7   ???                                 0x0000000114fa3905 0x0 + 4646910213
	8   ???                                 0x0000000111cdfd13 0x0 + 4593679635
	9   ???                                 0x0000000101de9229 0x0 + 4326330921
	10  Roon                                0x000000010149f297 mono_jit_runtime_invoke + 1383
	11  Roon                                0x0000000101697ab4 do_runtime_invoke + 84
	12  Roon                                0x000000010169b079 do_exec_main_checked + 137
	13  Roon                                0x000000010150cb0f mono_jit_exec + 287
	14  Roon                                0x000000010150fa8d mono_main + 11069
	15  Roon                                0x000000010148ec4d main + 253
	16  Roon                                0x000000010148eb44 start + 52
	17  ???                                 0x0000000000000005 0x0 + 5

=================================================================
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

[1]    6273 abort      /Applications/Roon.app/Contents/MacOS/Roon

Attempted without without change in results:

  1. Rebooted several times
  2. Removed ~/Library/Roon
  3. Removed ~/Library/Saved Application State/com.roon.Roon.savedState
  4. Removed ${tmpdir}/com.roon.Roon

Attempted with success:

  1. Delete Roon.app
  2. Delete ~/Library/Roon
  3. Delete ~/Library/Saved Application State/com.roon.Roon.savedState
  4. Delete ${tmpdir}/com.roon.Roon
  5. Remove Roon.app from System Preferences -> Security & Privacy -> Privacy -> Accessibility
  6. Reboot
  7. Start Roon, authorize firewall connections, authorize Accessibility Settings

However, quitting Roon after the first setup will always lead to the crash on subsequent launches.

Attempted with success:

  1. Remove Roon.app from System Preferences -> Security & Privacy -> Privacy -> Accessibility
  2. Add Roon.app from System Preferences -> Security & Privacy -> Privacy -> Accessibility

The above is required before every launch of Roon

Logs from a successful (multi-day) run of Roon (Roon_log.08.txt), a failed start (Roon_log.txt) and the macOS crashdump are at https://gist.github.com/tomchuk/25762a8a933be71c456bd083f13633c6.

If there is anything I can do to help diagnose this further, please let me know.

Thanks,
Tom

Edit: Just noticed 45568, sorry for the dupe.

And with last Beta (18A377a) I need to use the workaround again.

@support We’re getting very close to release of Mojave. Do you need anything from us?

Roon application crashes when I try to start it after updating to the latest macOS Mojave 10.14 Beta 18A377a running on MacBook Pro (Retina, 13-inch, Early 2013). 3 GHz Intel Core i7,8 GB 1600 MHz DDR3.

I had the same problem after updating to 18A377a. Like qdtjni, redoing the Accessibility workaround fixed it for me.

Works for me too.

Works for me to after redoing the Accessibility.

Admittedly this is likely to be an issue with Mac OS, not Roon, but I thought it worth flagging.
In the latest Mojave public beta (18A384a) if I try to open Roon I get a splash screen for a few seconds, and then it crashes. This has been happening intermittently on previous beta releases, but on this current release it’s now impossible to open Roon. (I’ve tried uninstalling and re-installing - same problem).

As mentioned, it’s just as likely to be a Mac OS beta issue, but thought it worth posting in case anyone else is having a problem (and has a solution!), or if @support want a crash log.

Setup:

  • The MacBook with the issue is a 2014 2.5GHz i715" Retina, 16GB 1500MHz DDR3 RAM. Hooked up to a Schiit Fulla 2 DAC - but same issue without the DAC (and same issue even if I’m off my network, or turn networking off)
  • Core is running on a MacBook Pro 2010 2.66GHz Intel Core2 Duo w/ 4GB RAM, wired ethernet and library on 2TB WD SSD
  • All other endpoints are working fine

Hi Nic,

I moved your post to this thread. Have a read to see a workaround to get Roon up and running.

Edit, here’s John’s workaround:

Cheers, Greg

2 Likes

Every time I start the most recent Roon control app on my 13 MacBookPro 2017 it gets to the splash screen and then immediately crashes…I have a crash report and will attach…I use my 13inch MacBookPro 2017 as a control. Its currently running the most recent beta macOS Mojave version 10.14 Beta (18A384a) and started when i upgraded to this beta version and was working flawlessly prior to this, with no other changes to the system. I understand the culprit, unfortunately, i cant change the OS on the macbookpro and this report is mainly a FYI considering the full mojave release is only weeks away.

My core is on a 15 macbook pro (retina, 2.7ghz intel core i7, 16gb memory, 1TB SSD, macosx 10.13.6 high sierra) running Roon server (headless configuration) version 1.5 (build 339) stable (64bit) w my library stored on 6TB LaCie USB 3.0. Connected directly to my router.

Main home main zone is LINN Akurate DS (connected directly to the same router)… DSP engine on (headroom and sample rate conversion only)

Additional zones include homepods and Chord Poly

Other controls are ipad, and two iphone Xs

Current Library size: 2908 albums and 42400 tracks (when not using synology NAS storage and only physical USB drive like my current setup)
and increases to 5000 albums and roughly 80-90000 tracks.

Error log:[http://gofile.me/3ZYhj/MSjECgRc0](http://Error log link)

http://gofile.me/3ZYhj/MSjECgRc0

Hey John,

I moved your post to this thread, as to keep all relevant information in one place.

See @john’s post (2nd in this thread) for a workaround running Roon on Mojave beta:

Fix worked for me - I didn’t have to remove it, it was already there in the privacy list but it wasn’t checked. I checked it and it worked. I had to fix my sound issues first though, after installing the public beta today my sound stopped working and was causing the whole computer to drag and go slow.

Looks like it’s working fine with the last Beta release (i.e. 11th).

It would seem it doesn’t work. Probably people know this already, but I didn’t see it posted anywhere.

https://pastebin.com/sfjqzr6r since the log is too big and I can’t upload text files.

Well, I just found this: Roon crashes on MacOS 10.14 Mojave beta

Guess I should have searched better. :smiley:

as we are almost at GM release for 10.14 I would expect that Roon would be on top of the issues if any and have it pretty much sorted.

I am sure they are.

You can remove it from System Preferences/Security & Privacy/Accessibility and then re-add it. That fixed it for me. It is now running perfectly happily on the latest beta.

Topics now merged.

1 Like

5 posts were merged into an existing topic: Is Roon Compatible with MacOS 10.14 (Mohave)?