Roon crashes on my mac mini [Resolved]

I have latly, have a problem with the roon client application on my mac mini is chrashing after it has been open for a couple minutes. This just suddenly have start happening. Roon is the only application that is chrashing like this.

I have looked in the system logs and it is generating a roon chrash file. I am pasting this in below as I dont understand what it say and what is the cause of the chrash.

I have tried toi uninstall roon and installed it again, I have also done upgrade of my OS to a new version. Non helped.

roon server is running on a win server computer, so only using the mac as a client

chrash file:
Process: Roon [41136]
Path: /Applications/
Identifier: Roon
Version: ???
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Roon [41136]
User ID: 501

Date/Time: 2017-11-16 04:10:57.019 +0100
OS Version: Mac OS X 10.13.1 (17B48)
Report Version: 12
Anonymous UUID: 31C540AE-2338-8F73-4E43-C332483DAAB4

Time Awake Since Boot: 180000 seconds

System Integrity Protection: enabled

Crashed Thread: 13 Worker (4)

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000

VM Regions Near 0:
__TEXT 000000010ce48000-000000010d1ef000 [ 3740K] r-x/rwx SM=COW /Applications/

Application Specific Information:
abort() called

Thread 0:: tid_307 Dispatch queue:
0 libsystem_kernel.dylib 0x00007fff5c888e76 mach_msg_trap + 10
1 libsystem_kernel.dylib 0x00007fff5c888390 mach_msg + 60
2 0x00007fff350c4dd5 __CFRunLoopServiceMachPort + 341
3 0x00007fff350c4127 __CFRunLoopRun + 1783
4 0x00007fff350c3797 CFRunLoopRunSpecific + 487
5 0x00007fff343d8866 RunCurrentEventLoopInMode + 286
6 0x00007fff343d85d6 ReceiveNextEventCommon + 613
7 0x00007fff343d8354 _BlockUntilNextEventMatchingListInModeWithFilter + 64
8 0x00007fff326d5a23 _DPSNextEvent + 2085
9 0x00007fff32e6ae6c -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 3044
10 ??? 0x0000000115482a50 0 + 4652018256

let me know if more of the file is needed and I can send it. it was not allowed to past in the whole file

Hi @Jens_Petter_Johansen — Thank you for the report and sharing your feedback with us. Both are appreciated!

Moving forward, to help aide in our evaluation of this behavior you are experiencing, may I very kindly ask you to please provide me with the following information:

  • An expanded description of your current setup using this link as a guide. Things to “include”:

    • The model and specs of the Core computer (i.e “Win server computer”)

    • The Model and specs of the MacMini.

    • Please provide insight into the endpoint being used with the MacMini. In other words, what is the MacMini feeding (i.e DAC, etc)?

  • Please verify that both the core machine and the MacMini client have both been updated to the most recent build.

  • When the application crashes on the MacMini, RoonServer remains active on the Windows machine, correct?

  • By the sound of your report this appears to be a relatively “new” behavior that has developed. Besides the updated to the most recent OS version on the MacMini have there been any other changes to your setup?

  • You mentioned that the application is crashing after a “couple of minutes” of being active. During this time frame, what are you doing in the application? Are there any other applications or processes occurring on the MacMini at the time of the crash?


Core computer: MOJO Dejavu server running Win2012-R2 (celeron of some sort 8GB RAM)
Client MAC min (Late2012)i OSX 10.13.1 (2.5 16GB)

No endpoint beeing used by MAC Mini,

Both are updated to recent build
The server is not chrashing, it i still working fine by using my IPAD as client, it is only the client on the MAC mini that is chrashing
No changes to systemsetup

music is store both on NAS and on SSD on my core computer

When I start the client on my mac mini, the application is just closing down without me doing anything. Somethmes after 30 seconds, sometime more. Sometimes I am able to start a song, sometimes not. I am not doing any changes. If I do anything it is only playing music


Hi @Jens_Petter_Johansen — Thank you for touching base with me and taking the time to answer my questions. Appreciated.

Moving forward, I would like to get our techs some more information about this issue you are experiencing on the MacMini. With this in mind, can you please reproduce the issue you are experiencing (on the MacMini) and note the time when it occurs. Once I have this information, I will enable diagnostics on your account, which will hopefully help us gain a better understanding of this behavior.


Today, CET (central europearane time)

Started app at 1103
Started one song: dead can dance : the carneval is over
App chrashed at 1104

Started app at 1106
Started one song: dead can dance: the snake and the moon
App chrashed at : 1109


Thanks for the follow up @Jens_Petter_Johansen, very appreciated!

As mentioned, I have went ahead and enabled diagnostics on your account and the next time your MacMini comes online a report will be automatically generated/uploaded to our servers so our techs can try to get a better sense as to what could be causing the issues on your MacMini client.

Once the team has completed their analysis of the information found in the diagnostics report I will be sure to share their findings with you in a timely manor.


hello again,
It has been Development here, in a negative way. The app is now not starting up anymore, it is chrashing
during startpunkt of the app.

I have to add that part of my troubleshooting have been removing the app+files, and installed
it again. Did that some time ago, but it did nothing. It is also worth saying that I am not experiensing
any problems with any other app on this Mac .

Have you been able to analyze yet?


Hi @Jens_Petter_Johansen ----- Thank you for touching base with me, I appreciate the update.

Moving forward, I got some feedback from our tech team regarding this behavior you are experiencing with the MacMini. As per the team’s request, I would like to have you try the following to see if we can trigger a change in behavior on the mini. Please see below.

  • Before you do anything, please make a backup of your current Roon database. Always good to make sure you have a fallback :sunglasses:

  • Once you’ve created your backup, close all active instances of the Roon application.

  • On the device hosting your Roon core please access your Roon Database.

  • Once you have found and accessed your database (i.e your “Roon” folder), please delete the “Transport” folder.

Path: Roon Folder - > Database - > Core - > “guid” (example below) - > Transport

19 AM

  • Once the “transport” folder has been deleted, please launch the application on your devices and confirm if the MacMini client continues to crash.


That did nothing Else than mess up my roon setup. The backup did aperently not backup everything Even though i gotno error message…

Problem still exist

Hi @Jens_Petter_Johansen ----- Thank you for touching base with me and I am very sorry to hear of the continued troubles.

To help me better understand the current state of things can you please provide me with the following (see below) and we will do our best to get things back up and running for you.

  • You mentioned that the proposed test “messed up” your Roon setup and that the problem still exists. Please explain exactly what the issue is after having performed the test. Having this insight will allow us to more accurately asses the current situation.

  • In regard to the back up “not backing up everything”, what do you mean by this? My assumption is that you tried to restore from the back up and something was not “right” with the process or the backup itself. Having some further insight into this observation as well, would be very appreciated.


When I was to restore the backup I took before the removal of the folder you told me to something just have happening to the backup AS it did not rektorer my latest setup. I had to find a many month old backup.

I got no error message on the backup I took that it had failed or not backed up… so the action I did messed up my setup AS I had ro rektorer an very old backup

The initial error still exist, the action to remove the folder did nothing

Hi @Jens_Petter_Johansen – sorry you’re still having issues here. Can you try something for me?

  • On the Mac, go to your Library folder and rename your Roon database to Roon_old (instructions on finding your database are here)
  • Follow the instructions under the “Installation Errors on OSX” section here
  • Relaunch Roon

You will need to select your Core and some settings on your Mac may be lost – I can’t guarantee this will work but it will help us rule out some common issues.

Answers to Eric’s recent questions above will also help. Thanks for your patience here @Jens_Petter_Johansen – I’m sure we can get this working for you.

Hmmm… that seems to maybe have done the trick.

I did as you said, it has been stable up for hours now.

Look Ok so far

hello. just wanted to confirm that the roon app now have been stable since I did the last proposed change. so this case can be closed… thanks very much for all support and help…

1 Like