Roon crashes when adding songs to library [Ticket In]

Description Of Issue
Roon still crashes every time when the first new song from an album is added to my library. This problem has existed since June 2021 when I reported it. @support asked for logs which were sent last year, but were super busy so didn’t revert. I am now trying again, hoping you have more capacity.

Any help will be appreciated as having to restart Roon numerous times per day is rather annoying.

Core Machine (Operating system/System info/Roon build number)
Windows 10, Intel® Core™ i7-9700 CPU @ 3.00GHz, Roon Build 884
Dell XPS8930

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Vodafone Hub / Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Audioengine HD3 speakers with Dell Tower with 2TB drive, via USB

Number of Tracks in Library
10,000

Description of Issue
Every time I add the first new song from an album (Qobuz) Roon crashes and has to be restarted. However, when loading the second, third and further song from the same album, Roon does not crash. Only when adding the first song from a new album.

Hi @johan thanks so much for your continued patience and for reaching back out to us about this. I’m sorry to hear that this issue has been ongoing for such a long time - we’d love to take a look into this for you, once again!

Can you please try to reproduce this issue, make note of the date and time of when this crash occurs, and use the directions found here and send over a set of logs to our File Uploader?

Would you also be able to share the name of the track that is imported just before the crash occurs?

Thanks so much!

Thanks @ashley, I have uploaded the Log Zip as requested.

There were at least 30 albums that crashed beween Friday and yesterday - the logs should show them. Since my posting, I’ve also tried to add via iPad - there too, the first new song via my iPad also resulted in Roon crashing.

FYI - I received a software update notification today and since installing it, I’ve not had an album crash, albeit I’ve only tried adding two new songs from different albums. Just thought I’d share that, hopefully the issues has been resolved. Crossing fingers! But please look into the Logs in any event, as the has been a 6-month old issue.

Cheers.

Thanks for providing those to us, @johan, it’s much appreciated. Please be sure to let us know if the issue continues even with the newest update - hopefully that’s not the case, fingers crossed! :crossed_fingers:t3:

I’ve looped in our technical support team in the meantime :pray:t3:

Thanks, Johan!

@ashley - Roon crashed again when I tried to add Andante (highlighted) to my library.

Hi @johan ,

It doesn’t look like your PC is communicating with our diagnostics servers at this time, can you please reboot it and let us know? Also, can you please confirm you’re using the latest graphics drivers on your PC? Thanks!

Hi @noris I can confirm that I am using a Nvidia GeForce RTX 2060 gaming driver and have just downloaded the very latest update. I have also just rebooted as per your request. Thanks!

Hi @noris, Roon has crashed quite a lot today, most recently when adding this song.

Hi @noris - Roon crashed a lot today with below one example. Crashing on both PC and iPad. Classical music and non-classical music.

2 posts were split to a new topic: Roon crashing when adding Qobuz albums

I am getting this as well. Prior to the 903 release my core had auto updated to windows 11 and I started experiencing the odd crash, especially whilst playing/editing at the same time. The volume of crashes was annoying but tolerable. Since the 903 release the number and regularity of crashes has gone way beyond annoying and is now completely intolerable.

Hi @johan ,

Thank you for those details! I’m looking over the traces contained in your logs, and they look very similar to an existing ticket we have, so I have added your report to this ticket. I can’t specify when the ticket will be fully resolved, but we are aware and tracking this behavior, thank you!

Thanks @noris. FYI, I’ve again gone through all my setting and there’s nothing that appears odd or not in line with recommended settings on the Roon forum. The fact that is is sporadic and happens on both the PC and iPad Pro (albeit using the same core on the PC), makes me think it might relate to software rather than a firewall or setting on my side. But happy to try different settings once you get to this. But it is super annoying as I do add a lot of music to my library on a daily basis.

1 Like

Hi @noris - do you have any updates on this ticket?

@johan - We made some improvements regarding this in our next release, let’s circle back and see if it helped you after the next release is out :slight_smile:

Thanks @noris.

Hi @johan ,

Are you still seeing this issue following our latest Roon release?