Roon Crashes When I switch to "iMac" Audio Zone and Does Not Show Headphones

Roon Core Machine

Mac OS Big Sur 11.6.2
iMac (Retina 5K, 27-inch, 2020)
3.6 GHz 10-Core Intel Core i9
32 GB 2667 MHz DDR4

Networking Gear & Setup Details

Orbi Router
8tb SS drive in an RS9 dedicated server
Connected with ethernet CAT 6 cable to router, iMac.

Connected Audio Devices

Headphones – Woo Audio Fireflies

Number of Tracks in Library

37,274 tracks

Description of Issue

Everything was working fine until I edited a track that was playing on the RS9 Music Server. Then the music stopped. I closed Roon and restarted, and it immediately crashed repeatedly. I then restarted the iMac, and Roon still crashed immediately. I restarted the RS9 and the iMac and still crashed immediately. I then uninstalled Roon on the iMac, and reinstalled a fresh copy from Roonlabs. This time it opened fine and connected to the Core, but did not show the headphones as an available audio zone. Then I tried switching to the iMac Audio Zone and Roon immediately crashes. The only audio zone on my iMac that I could select is “unnamed.” Then the Headphones zone suddenly appeared and now works, but when I switch to iMac it still crashes as soon as I switch. So currently, on the iMac, I can use the Headphones audio zone (attached by USB to the iMac) and the “unnamed” audio zone on the iMac, but not the “iMac” audio zone.

Hi @Philip_Stillman,

We’re sorry to hear that you experienced crashing on your Mac. We just released a new Roon update, Build 903. You can find more information on the new version in the link below. Can you please install the new update and tell us if it helps? Thanks!

I have updated to Build 903. When I try to switch to the iMac as the output, Roon immediately crashes. In addition, my headphones still do not show up as an output in the “audio Zone”. I have tried to switch USB inputs on the iMac, rebooted the iMac with the Woo Audio Fireflies turned on and turned off, nothing seems to get the headphones to show. Please help, and ideally in less than SEVENTEEN DAYS.

Hi @Philip_Stillman,

Thank you for getting back in touch with these additional details. We’re pulling logs to take a closer look. When you uninstalled and reinstalled Roon on your MAC remote did you remove all Roon files and empty the trash on the Mac?

Additionally, can you check to ensure that you allowed the necessary Roon Server exceptions in your Mac firewall settings?

When I uninstalled Roon and re-installed its I removed all files and emptied the trash, before reinstalling. I have checked the firewall settings on the iMac and there is an exception for “Roon” listed. It does not show whether that is or not. I then turned off the firewall, turned off the music server, and then restarted the music server, and then opened Roon. It could use the “headphones” as an audio zone, but as soon as I clicked on iMac as a zone, Roon still immediately shuts down. I then turned the Firewall back on, and the app still crashes when I try to switch to “iMac” as the audio zone. FYI, I have no problem accessing the music server from Finder on the iMac. Now what?

Hi @Philip_Stillman ,

Can you please note the exact local time + date you experience the next crash and let us know the time it occurs here? Thanks!

any time that I open roon and try to switch to iMac as the source. I will do it again in an hour or so

today, Feb 24 at 2:48 pm EST

Hi @Philip_Stillman ,

Are you still seeing this issue at the present time, even in the latest Roon build? Is the behavior the same even after a reboot of your Core? If it is, we can try to reset your RAAT zones and CoreAudio on the Mac to see if it helps, can you please:

  1. Reboot mac
  2. Exit out of Roon if running
  3. Navigate to your Roon Database Location and rename RAATServer folder to RAATServer_old
  4. Navigate to ~/Library/Roon/Database/Registry/Core/ and
    delete files starting with raat and endpoint
  5. Open Terminal and paste in command: sudo killall coreaudiod
  6. Reboot Mac again and verify if behavior persists

Thanks for the info. However, for reasons unknown, I can now switch between the iMac and Headphones so whatever was the problem has been resolved.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.