Roon crashes when scanning library


Roon crashing after 1-3 minutes of running, while it scanning library.

I found and read the log files but I didn’t find out what the problem was.

How should I proceed now?


1 Like


In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

1 Like

Hi @anon35074520,

Please provide more details regarding your setup as per @Carl’s link. Can you please also use these instructions to send ma a copy of your Roon logs for review?

Hello Noris,

I just sent an e-mail reply to your e-mail with logs and a screen photo with the moment when the program cracks.

Thank you!

Hello Carl and many thanx for helping!

I used Roon for a while and it worked perfectly, I tested it using both a BlueSound Node 2i network player and a Cambridge CXA80 amplifier, via a USB cable. It worked perfectly with both, I listened to music both on TIDAL and from my collection of flacs and MP3s on a NAS, but at one point the program started to close on its own every 2-3 minutes. I noticed that the crash occurs at the same time as the program scans. I sent Noris a print screen (photo) with the moment the program cracks. Reading other posts here, I find that there are probably corrupt files on the NAS and it crashes when it reaches it. I also emailed the archived LOG directory.

I am waiting for a solution from you.

Thanks a lot!

Unfortunately, the e-mail return.

Here dropbox link:

Rather than use traditional email, it is better to send @noris a Private Message via the forum with the links to your logs and photo. Click on his avatar, then click the Message button to create a PM to him.

Thanks a lot, Geoff I tried but couldn’t find the Message button. I put the link here on the forum.

For future reference:

I’m sorry, I don’t see this button, I would have seen how big it is … :slight_smile:)

Fortunately, I solved the problem. I deleted a folder with MP3s that appeared in the log (Z:\MP3 ARHIVA CODRIN\Codrinu_006\ANUBIS GATE - 2003. Purification (LOCOMOTIVE)) and now scans continuously, without crashing.

Thank you all for your help and time!

1 Like

That’s probably because your new to the forum, I seem to remember that private messages are an earned privilege

How did you identify that particular folder or file as the issue? What error message appears in the log? Or was it the last thing in the log before the crash?

Hi Toni, I saw that the same folder appears towards the end of writing from the log files I opened. It does not appear exactly at the end of the log file, but near to the end.
See the unzipped logs using the link above.

1 Like

Hi @anon35074520,

Thanks for letting us know that you were able to identify the .MP3 file causing the issues here!

I’ve just bumped your account level so you can send messages, can you please send me the .MP3 causing the issue as a private message and I’ll forward to our QA team for review?

Hopefully we’ll be able to reproduce the issue in the lab and file a ticket for the devs to improve the behavior when scanning this file, thanks!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.