Roon Crashing in Win10

Core Machine (Operating system/System info/Roon build number)

Computer Information:
Manufacturer: MSI
Model: MS-7998
CPU Vendor: GenuineIntel
CPU Brand: Intel® Core™ i7-6700K CPU @ 4.00GHz
Windows 10 (64 bit)
Driver: NVIDIA GeForce GTX 1080
RAM: 16343 Mb

Roon version 1.7 build 610 64bit (stable)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear Orbi Mesh Network Wifi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

When using Roon (not necessarily with music playing), screen will go entirely black, music stops (if playing), roon itself then crashes. I have a support package but not sure how best to provide it.

Hello @Ben_Privett,

Do you by any chance have Dropbox / Google Drive or something similar to send the crash package?

You can send the crash package to me, but if you need another service to perform the transfer, just let me know.

Does the crash happen after opening a tab in particular in Roon?

@noris hopefully you’ve received my support package via DM.

There is no consistency for when it crashes, it crashed 3 times trying to get the version, when all I did was open Roon, click settings, click version…

After a little research it appears Roon can’t handle g-sync being enabled? Can you confirm if that’s the case and when a resolution is expected?

Hi @Ben_Privett,

Which version of the NVIDIA driver are you using?
Is it the latest one available?

If you try to disable the ASIO driver for this zone, does the issue still occur?

I am on the latest version, 456.55 released 9/28.

ASIO doesn’t seem to do anything, but disabling gsync fixes the issue… I’d really prefer not to disable gsync though.

Hi @Ben_Privett,

Thanks for re-confirming that this issue is related to Gsync and not the ASIO driver. Can you please open Windows Start menu and type in “System Information” and share a screenshot of System Summary & Components -> Display? I’d like to get that information over to QA, thanks!

1 Like

we have seen this before perhaps…a search on gsync revealed a number of issues

1 Like

Agreed, I came across a few posts on it and confirmed that is the root cause of my issue. I tried the workaround in that post and was unsuccessful, unfortunately.

was about to edit and see if the workaround in that post worked…ok well back to square one on that.

Given that Roon is heavily dependant on Open GL 3.0 perhaps something is broken in gsync for OGL

1 Like

Appreciate the help!

Thanks for those system details @Ben_Privett, let me get this info over to the team and I’ll let you know once I have further feedback from them, thanks!

Hi @Ben_Privett,

I spoke to the team regarding your case and we plan on looking into this further. I can’t quite comment on when there will be any changes here, but we’ll do some testing on our end and see what can be done.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.