Roon crashing on Windows Core


Any real solution for this problem? I can start roon desktop after deleting the following directory: “C:\Users<user>\AppData\Local\Roon\Database”. This problem drives me nuts, because I’ve to reset roon dekstop everytime I start the program. I can’t roolback because I’ve runned “Disk Clean-Up”. What update can uninstall? Can it be the the “.Net Core SDK 2.1.801” update? I think the workaround with a fresh Windows 10 install is not a good workaround. It takes time to install all apps you need and tweak and tune Windows. Anyone with a better workaround or a fix?

Hi @Tommy_Olsen,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

So just to confirm, if you delete the database things will work temporarily, but then the issue occurs again? How long does it take for the issue to return?

Can you confirm how many albums total you have in your library? Where is your media stored?

Here is a little description of my setup. I’m running the core server on a virtual machine hosted on ESX 6.7U2. The OS on the core machine is Ubuntu server 18.04.2 x64. Have allocated 4 vCPU, 8 GB of ram, 60 GB on local SSD harddrive for database. Music files are stored on a QNAP TS-1635AX (CIFS connection over network). In my homenetwork I’ve distributes my serverers and storage over 3 location due to heat and security resons. These locations are tied together with 3 mikrotik switches with 10GBb ethernet. Clients and server are on 1Gb ethernet. Ethernet to storaged and ESX servers are usually 2x1Gb trunked togheter. I’ve a 500mbit internet connection. It can be to much details to explain everyting, but performance is very good on storage and network. I’ve about 380000 tracks on the core server. I’ve also a connection to Tidal.

Audio devices I use are local soundcard and squeezbox connected to my home audio system (Squeezebox Support enabled).

Roon on android devices are working flawlessly. Have only problem on Roon Desktop installed on my desktop (i9900k with 64GB ram and SSD only setup). The OS on my desktop is: Windows 10 Version 1903 (OS Build 18362.295).

After deleting the local database, I can use Roon Desktop with no problems. Everything is working perfect, and the speed is top notch even for such a big collection. But the next time I start Roon, it just hangs with no response forever. Deleting the local database fix the problem everytime. I’m thinking about make a script to delete the database everytime Roon Desktop is started, but that is a nasty workaround.

I’ve tried to uninstall and reinstall the Roon Desktop software. Uninstall and install .NET framwork feature. Tried to restore older version of the database from when everything was ok. Can’t remember excaclty the date this problem started, but it was this summer. What I’ve not tried is to reinstall my desktop or degrade it. Doing this would be the last resort since everything else is working perfect.

Here is the last part of the logfile, have edited out token and serial because of security resons:
08/19 15:11:20 Debug: [easyhttp] POST to,,roon.dsp.,roon.client.,roon.sood?roon_auth_token=xxxxxxxxxx
08/19 15:11:20 Info: [raatserver] [runner] Status: Started
08/19 15:11:34 Info: [stats] 5695mb Virtual, 297mb Physical, 24mb Managed, 1454 Handles, 110 Threads
08/19 15:11:48 Trace: [appupdater] initial check for updates
08/19 15:11:48 Debug: [base/updater] Checking for updates:
08/19 15:11:49 Debug: [appupdater] Update not needed
08/19 15:11:49 Info: [stats] 5687mb Virtual, 299mb Physical, 26mb Managed, 1444 Handles, 108 Threads
08/19 15:11:50 Info: Flushing kart data to server
08/19 15:11:50 Debug: server said:
08/19 15:12:04 Info: [stats] 5627mb Virtual, 300mb Physical, 27mb Managed, 1438 Handles, 93 Threads
08/19 15:12:19 Info: [stats] 5599mb Virtual, 300mb Physical, 27mb Managed, 1434 Handles, 86 Threads
08/19 15:12:34 Info: [stats] 5595mb Virtual, 300mb Physical, 27mb Managed, 1432 Handles, 85 Threads
08/19 15:12:49 Info: [stats] 5591mb Virtual, 300mb Physical, 28mb Managed, 1432 Handles, 84 Threads
08/19 15:13:04 Info: [stats] 5591mb Virtual, 301mb Physical, 28mb Managed, 1430 Handles, 84 Threads
The last line with “…Info: [stats] 5591mb Virtual, 301mb Physical…” repeats forever.

Hi @Tommy_Olsen,

Are there any active antivirus or firewall on the Core machine? If you disable them temporarily is there any change?

Forgot mention that I’ve tried to disable antivirus and firewall also. The result is the same.

Thanks for confirming that, @Tommy_Olsen.

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Sorry for the late reply, have been traveling. Started roon client right now. Time is 19:04 UTC.

Any update? Any workaround I could try?

After weeks with problems, the roon client suddenly started to work? Don’t know if you have done anything? At the moment I’m happy and no further debugging is needed.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.