Roon Docker Server won't start

Core Machine (Operating system/System info/Roon build number)

unRaid server/Linux based system using steefdebruijn docker server. I am using version 1.7.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Trinnov Altitude32 connected via ethernet

Description Of Issue

Roon was working fine until about a week ago. Then it would not connect with the iPad app. So I then deleted the iPad app and reinstalled. It connected and was working fine until I decided to reinstall my backup. The Roon Sever on my unRaid will no longer start.

Hi @mikela,

What happens when you try to start RoonServer? Do you see any errors?

Would you kindly use the directions found here and send us over a set of logs using a shared Dropbox link?


Where do I send the shared Dropbox link?

Hi @mikela,

You can post the link here or in a private message to me here on the Community site.

Roon Server & RAAT Logs

Hi @mikela,

Thanks for sending those over, much appreciated! I’ve sent this over to the technical team for analysis and I’ll be sure to reach out to you as soon as I have their feedback. Please note that the queue for the technical team is a little longer than typical due to the holidays, but I’ll be following up soon.

1 Like

Any progress to report?

Hi @mikela,

Apologies for the delay due to the holidays. I checked with the team on this and they’re still investigating the exact cause of the issue, but they’re hoping you can try something which should help you get Roon up and running temporarily. First, can you confirm whether or not you have Roon backups?

Yes I have backups

Hi @mikela,

Thanks for confirming. Next, I’m hoping you can please try the following to start with a fresh database and let us know if it helps:

  • Stop RoonServer on the Core machine
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart RoonServer

Ok, did this and RoonServer successfully started.

Great, thanks @mikela!

I’m still waiting for further feedback from the team on the issue, but in the meantime, you can try restoring a backup from before this occurred and let us know if that helps. If you’re still seeing the issue after the restore you can go back to using a new database while we wait for the team’s feedback.

Tried to “restore backup” and got the “cannot locate core” message again.

Thanks for giving that a try, @mikela.

I checked with the technical team on this today and they let me know they’re continuing to investigate this with our development team. For now, using a fresh database (the instructions I provided above) will allow you to use Roon until we have more information from the team on this.

I’ll be sure to reach out ASAP once I have an update.

1 Like

Hi @mikela,

Can you try the following?

  • Stop RoonServer on the Core machine
  • Change RoonServer folder to RoonServer_New
  • Navigate to the RoonServer_Old folder from before
  • Delete the .restore_old directory from /data/RoonServer_Old/.restore_old
  • Rename the folder back to RoonServer
  • Start RoonServer

Let us know if this works for you!

Hi dylan,

I never tried this as I just decided to start over. However, I am now back at this same spot. In the above instructions: When you say “Rename the folder back to RoonServer”. Which folder are you referring to? RoonServer_New or RoonServer_Old?


Hi @mikela,

Apologies for the delayed response here!


It seems that within a month or so of reinstalling Roon on my iPad and relabeling as described earlier that I get the dreaded cannot connect. I then have to repeat this process. I have a suspicion that this happens because of Roon forced updates. Is there any way to prevent this?

Hi @mikela,

You can change automatic update settings by going to Settings > About. We have more information about this in our KB.

This isn’t something that should be happening from an update, though. If you see anything like this occur again can you use the directions found here and send us over a set of logs using a shared Dropbox link?


Even though I turned off my RoonServer core, I am unable to delete the restore file. It says I need permission from my server even though I have it set to a public file and can change the file names.