Roon does not add Synology shared folder via Hostname

Core Machine (Operating system/System info/Roon build number)

Innuos Zenith music server (Roon Version 1.7 build 528)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

SOtM sNH-10G Switch on Ethernet

Description Of Issue

When I attempt to add a Synology NAS shared folder using the Hostname, I get an error message:


“There was an unexpected error: UnexpectedError”

But when I use the IP address instead of Hostname, the Synology NAS shared folder is successfully added:


NOTE - I can connect to the Synology NAS on Mac OS Finder, using the Hostname, via menu Go > Connect to Server:


System details:

Synology Model Name: DS1815+
Current DSM Version: DSM 6.2.2-24922 Update 4
Roon Core on Innuos Zenith music server
Roon Version 1.7 (build 528)

Innuos Zenith and Synology NAS are both connected to SOtM sNH-10G Switch, which is connected to an Arris Touchstone TG2472 Wireless Gateway modem.

Can anyone confirm if this issue can be fixed, or suggest something I can explore?

P.S. If anyone knows how to update Synology firmware, can you point me there? I inquired with Synology Support via Chat, but they did not provide an answer.

Thank you in advance!

You can continue using the IP-address or trying the hostname.local workaround (smb://synology.local/WAV). See also:

Thank you for the information. I just tried the hostname.local workaround, but received a different error message.

“Could not connect to share: Host not found”

I read the other topic last night, didn’t see a solution, but will read again. Curious how the Hostname worked in the past, but now no longer.

Go to Sygnology Assistant - Select your NAS and double-click to open the menu.
Select Configuration screen - select Update and Repair (?)

Here are the corresponding screens, albeit in Dutch, but I hope they are clear enough.


stick with the IP address option but in your router or Synology change to reserve that IP address for the NAS or use Fixed in synology. make sure to note the DNS settings too … fyi based on your IP address use dns’s of (assuming your router is .1) and as secondary

Thank you Dirk. I use Update and Restore on a regular basis, but I thought that was to update the DSM operating system. Does anyone know if that also updates the firmware?

My experience with other hardware, is that a firmware update is separate from the OS, and requires downloading a separate firmware update file.

Thank you Wizard. That was going to be my next step — to explore how to create a fixed IP address.

Hi Gerry
As far as I know/understand these are the only (and complete) updates one needs to execute to keep your NAs up-to-date both hardware and software related.
I have only seen 1 explicit reference to firmware updates, related to hardware expansion units. You would receive automatic warnings and downloads if applicable.

So as long as you implement the DSM updates, I believe you are fine.

Do you have any reason to believe this is not the case?


P.S. there are of course the Packages updates for the different applications

Hi Dirk,

Thanks again for the information. The only reason I inquired about a firmware update, was after reading someone’s suggestion about it in another topic on this Hostname issue. But I never read a confirmation, and so was just wanting to explore any possibility for a solution.

I will now learn how to assign a fixed IP address and just live with that until hopefully the Hostname works again like it did before.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.