Roon does not recognise Streamers (connected by ethernet) anymore

Roon Core Machine

Innuos Zen mk3

Networking Gear & Setup Details

Router: Fritzbox 4040
Switch: Silent Angel Bonn N8

Connected Audio Devices

Linn Selekt DSM in one room,
MSB Techology The Analog DAC (with streaming module) in another room
(All gear has latest firmware)

Number of Tracks in Library

14K Tracks

Description of Issue

Roon does not recognise Streamers anymore.
Settings → Audio does only show my Ipad (remote control) and gear connected by USB to the Core but not by wired ethernet anymore (problem was here before release 987).
Any helping ideas?

Hi @Dan_Rosen,

Have you tried any troubleshooting steps, such as rebooting the Zen, network devices and endpoints?

1 Like

Yes, this is usually the first thing I do when encountering problems.
As my Roon software was not up-to-date I installed version 988. it didn‘t solve the problem.

My Innuos Zen mk3 has a dedicated ethernet output port for streamers, not even there a unit is recognized anymore, so it’s not even the problem of the switch or a router on the first hand.


I assume you’ve checked in Roon’s Setting → Audio to see if they are enabled, I guess they are simply not visible.

I’m not sure what else to suggest, let’s see if Roon’s @support team can help.


Just for testing reasons I plugged in a Bluesound Node 2i (in the Fritzbox) that I didn’t use for some time; this cheap unit popped up immediately in the audio device section but my multi thousand $ audiophile gear won’t anymore…?

Did you plug the expensive stuff directly into the Fritz? Just as a test. Schlepping kit about isn’t ideal I know.

If you have a dumb cheap switch (or get one on sale or return from Amazon) it might be worth using it instead of the silent angel and see if that wakes things up.

Should tell you something, I’d think.

I agree with Ged – try switching out that audiophile switch for a regular one that costs one-tenth as much, and see if things come back.

Yes MSB and Bluesound Node are connected to the same Router.
Node popped up immediately in Roon while MSB DAC not, both are of course Roon Ready.

Hard reset to defaults on the Linn etc?
I presume the Linn app sees itetc?

Yes, playback via Linn‘s own App is possible.

Just noticed that roon is seeing airplay on the Linn.
I think proper @support need to step in…

:point_up_2: Absolutely, this is what Linn recommends, simple unmanaged switches. Easiest choice is a Netgear GS108, $39 on Amazon (US) right now.

I actually use now these discontinued dumb Cisco switches to connect my Linn Klimax DSMs with optical ethernet. But I used the Netgear switches before, zero issues.

Even when I bypass the switch and connect the streamer directly to the Server, only the USB connection plays music, the ethernet connection is not recognised (but earlier was, but then there were SW updates). And yes the LEDs above the connectors are blinking.
Like I said, the system was running fine until one day I recognized it wasn’t anymore.

Yep, hopefully soon.

Will be Monday now.

Hmmm. The Web page for that device is a bit unclear about the technicalities. By “dual-Ethernet ports” I assume they simply mean that there are two Ethernet ports; the writer simply doesn’t understand English hyphenation. But the fact that one is labeled LAN and the other STREAMER is kind of interesting. 100Base-T Ethernet ports are medium dependent; that is, each port is either MDI or MDI-X. Most modern switches and other equipment have auto MDI-X; they sense which they need to be and switch to it. But with audiophile equipment, particularly a computer that advertises “medical-grade mains filter” and “asymmetrical isolation feet”, and which labels the Ethernet ports with specific uses, who knows? It could be that you need a crossover Ethernet cable instead of a straight one.

I think if you just get a commonplace Ethernet switch and try it, that may solve the problem. Most modern switches are auto MDI-X, so you can plug in either, and have it work.

Innuos describes it as follows:
Dual-ethernet ports with isolation transformers provide an ultra-low noise network connection for your streamer, removing noise from the path and improving sound quality on all network audio.

Why changing gear that worked beforehand properly?
I blame SW updates. Either Linn‘s most recent or Roon.

Yes, but that’s mainly marketing-speak. All Ethernet ports have isolation transformers, and “dual-ethernet” doesn’t mean anything. I think they meant “dual Ethernet ports”; it’s written that way elsewhere on the page.

Well, you change it because it doesn’t work now. Sure, could be a Linn problem. Hard to see how it could be a Roon problem, but sure, maybe.

Linn has always been very clear, on their site and through dealers about recommended network setups. They are not obliged to test their firmware changes against exotic network hardware/configurations that fall outside their recommendations. TL; DR: keep it simple (and cheap).