Roon does not sync correctly with Tidal favorites

For some reason some of my most recent Tidal favorites do not appear in my roon library. I am also experiencing problems when I delete an album which is taken from Tidal favourites. In the past, this operation has always worked removing the favourite flag from Tidal and removing the album from Roon BUT NOW… the deletion fails with Roon saying that it cannot find the file. Is it a known issue?

I am using the most recent version of ROCK on a NUC.

Hi @simonratti,

Is there any change in behavior if you reboot your ROCK and networking gear? What if you try signing out and back into TIDAL via the Roon Settings -> Services tab?

Hello, I have already tried all these options, including logging out and in again. No way. My library now contains some albums that point nowhere and I do not know how to resync correctly.
Thanks for helping.
Look…this is Tidal

and this is Roon

Do you see the mismatch?

Jackie Leven is on Tidal but not on Roon
Weyes Blood is on Roon but not on Tidal and if i try to remove it from Roon …this is what i see:

And of course it remains untouched.

And if i try to play… it does not work either

Hi @simoneratti,

I assume you have also tried the “Sync Library Now” feature in Roon Settings -> Services -> Edit button next to TIDAL -> Sync Library Now?

If there is no change with that either, can you try clearing the TIDAL cache?

  • Exit out of Roon
  • Stop RoonServer from running in the ROCK Web UI
  • Find and open your Roon database
  • Navigate to Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting RoonServer and verify if the issue still occurs

I experienced a few identical issues with Tidal favorites recently. When I closed down Roon on the core (Mac mini) and controller (MacBook Pro) and rebooted the core Mac mini it all resolved.

Hello, the feature “Sync Now” always displays the following message:


It appears it is constantly syncing and it shows no button/ command to force an immediate sync.

Apart from this… I have turned off ROCK and all the devices with a remote installed on them (I probably never had all of them off together). This action finally cleaned the ROCK library from the bad links BUT it did not solve the synchronization issue as I have still favourites in tidal which are not visible on ROCK. We are getting closer to a solution but the issue is not gone yet. Of course… I have logged out and into Tidal again after restarting everything.

As you can see

The Tidal app shows Jackie Leven, Burial and Frank Zappa albums in my favourites:

But Roon is still missing them:

Hi @simoneratti,

Can you please try to reboot your core, start a manual TIDAL sync, note the exact local time you press the sync button and then send me logs by using these instructions?

If you don’t have Dropbox / Google Drive just let me know and I can provide an alternate upload method. Thanks!

Hello, I have rebooted the ROON server, I have rebooted the NUC, closed all the remotes but I still see this:

Roon is continuously syncing… how can I force a manual sync?

I have already logged out and into Tidal but still the same message. What should I do? Should I send you logs anyway?

Hi @simoneratti,

It looks like there is a sync ongoing and that’s why you are not presented with the “Sync Now” button. Yes, please do send logs regardless.

I also have a few networking questions for you:

  1. What is your network setup like, can you list the model/manufacturer of all your networking gear and how your Core is connected to the network (where in the chain)?

  2. How are your DNS servers set up? Are you using the ISP provided ones or are you using custom DNS servers (Google/Cloudflare/Quad9)?

Can you download the logs from here?

My ROCK is connected directly via ethernet to the Netgear Orbi Router which enables a local wifi mesh network through my flat, which is used by the remote devices to play. The Orbi router connects via ethernet to the ISP modem and it is manually setup to use the;; DNS addresses in the order mentioned. the Orbi local NW is different from the Internet Port NW as shown here:

Do you need anything more?

Hi @simoneratti,

Thanks for confirming the network setup and for sending those logs over. I am looking through them and I’m noticing quite a few networking issues, seems that there are network errors when trying to sync with TIDAL, our account services, and our metadata services.

Since this behavior is impacting multiple areas, I suggest we take a closer look at the router. Can you confirm you are using the latest firmware for your router? Do you have any other firewalls on the network which blocks certain types of traffic?

I have gone through the router configuration and most settings are default. There is no active firewall or filter. Is there any option in particular that you recommend to check?

@simoneratti - I would reboot the router and check for newer firmware as the first step. You may also want to try switching the DNS servers around with being the first one in case Cloudflare is experiencing any issues. If you are connecting to one of the Orbi nodes, it’s worth a try connecting to the primary unit instead as well.

Hello, I have changed the DNS to as a primary choice. The firmware is the latest. ROCK is connected directly to the Orbi router station and not a node. Very simply… roon cannot sync to Tidal. In the past it had worked smoothly. Since some time I have been noticing the failure. Something must have changed in the ROCK software. How can we root cause this issue?

And…to be more clear… I have rebooted the router…I have rebooted the modem… I have rebooted ROCK… I have rebooted all the clients…

Hi @simoneratti,

I have sent you a private message regarding next steps.

A post was split to a new topic: Can’t sync with TIDAL + Nucleus

Hello, I am in touch with Noris, hopefully he can solve it. I have tried to follow every instruction so far but nothing changed.
There must have been a sw change at some time, because I have started seeing the tidal sync issue and I have also started seeing a huge delay of the Tidal login when Rock is restarted. It takes some minutes after the login before the music on Tidal becomes available. Until a few minutes after the login all the The Tidal tracks are given unavailable and I can only play local files. After some minutes also the tracks on Tidal become accessible. Are you experiencing it as well?

1 Like

Hello @simoneratti,

No, I am not experiencing this behavior nor have I seen widespread reports of this. Since I am not able to reproduce this on my end I believe this could be a database or networking issue, we can run the following 2 tests to clarify:

Test 1 - Starting with a fresh database on ROCK:

  • Create a Backup of your current Roon database
  • Stop RoonServer from running in ROCK’s WebUI
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Roon database folder
  • Verify if the issue remains the same with a fresh database (don’t restore yet)
  • After verifying for a day or two, then restore your database from a backup

Test 2 - Trying a different PC. If you have another PC which can host the Roon Core can you check to see if the behavior is the same there?

  • Install Roon on another PC
  • On the “Choose your Core” screen, select “Use this PC”
  • If you already have connected Roon to ROCK, you can go to Roon Settings -> General -> Disconnect to go to the “Choose your Core” screen

Hi @simoneratti,

I also suspect something has changed since the 1.7 update which has caused these issues, because nothing else in my setup has been altered since before then.

I’m not experiencing the Tidal login delay you mention, but the two issues that seem identical to yours are:

  1. Unable to delete Tidal album after adding to my library - same as screenshot you posted, “File Not Found”
  2. Under Services in Settings, Tidal is constantly syncing, as you described it

I’m working on a separate thread to respond to @noris to troubleshoot my setup. hopefully will get to the bottom of it.