Roon does not work correctly with Linn Akurate DS endpoint

Core Machine (Operating system/System info/Roon build number)

Mac mini (Mid 2011) running OS X El Capitan 10.11.6 / Roon 1.7 (Build 667)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet connection via Verizon Fios-G1100 router.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Emm DAC2X connected via USB. Linn Akurate DSM running version 4.75.360 connected via wired ethernet.

Description Of Issue

The EMM connection works perfectly. The networked Linn connection used to work fine too.

The first track takes forever to load. A typical error message is “Unexpected error communicating with audio device”. Today I am also seeing the message “Roon lost control of the audio device”. After the first track completes, playback freezes, with a pulsating icon running continuously. Pressing play many times sometimes results in success. Transferring from the EMM to the Linn results in the same behavior: the first track plays OK then everything freezes.

Streaming music from Qobuz is generally worse than playing albums from the network - but even they are subject to dropouts.

Connecting the Linn directly to Qobuz works fine but obviously I miss the Roon interface in that case.

I have had this problem for some time and have tried many potential solutions included rebooting all devices.

Hi @Jim_Gatheral,

Thanks for reaching out! As a test, can you please confirm if playback to your System Output zone is working as expected? Or are you also seeing issues for that zone?

If you have any local library content, can you please let me know if the issue reproduces with that as well? If you need a few sample tracks, you can download from the 2L Test Bench (right-click on the file size -> save as).

Dear Noris,

Thank you for your reply. I should have let you know before that the same issue occurs with local library content. I don’t see any System Output zone. I have attached a screenshot of the sound output devices for the Mac Mini which runs Roon core.

Screen Shot 2020-10-27 at 1.09.43 PM

Once again, the EMM DAC connection via USB has no issues. Roon works perfectly with that.

Best regards,


Hi @Jim_Gatheral -

Chris from Innovative Audio here; thanks for looping me in.

Two suggestions:

  1. Run Linn Konfig on a computer and update the DSM to the latest Davaar version 4.79.383. There were some fixes in 4.77 specific to Akurate DSM, and some fixes in 4.79 related to crashes with Songcast streaming. [If you don’t have Konfig, you can download it from ]. Call me if you need help navigating Konfig, though it’s relatively straight-forward.

  2. Also check in Roon > Main (hamburger) menu > Settings > Setup > Subnet for Linn Streaming = something like (or whatever your home network IP address range is), and not something like This is not necessarily the solution to the problems you’re seeing, but I’ve seen quirks in Roon (not) streaming to Linn if this subnet address isn’t correct…and it’s certainly possible that your Verizon FiOS router may have applied a software update or automatically changed some configuration that “broke” the Linn streaming features.


Hi Chris, thanks for your suggestions. For point 2, the subnet is so no problem there. I had version 4.75 of the Linn software. I have just updated to the new beta version of Linn software:

Let me try and see what happens…

Hi Chris,

So far it seems that this Linn update has solved all of my (sound-related) problems.

Thank you!


Now I’m not so sure. The music last for much longer than before. But it stops after some time…

I am getting the error “Audio device refused to switch input to Roon”…

Now “too many failures, stopping playback”…

Hi @Jim_Gatheral,

Can you please let me know the exact local time + date + track of the next issue you experience? This will be useful when we need to take a look at logs.

So you are saying that only the Linn is impacted here? The EMM connection does not give you any of the symptoms you are seeing on the Linn?

Hi @noris,

Yes that’s right - the only problem is with the Linn. I will start playing Roon again and note when the next issue occurs.

Thanks and regards,


I got “Unexpected error communicating with audio device” on Friday, October 30 at 2:25pm local time, immediately I pressed play. Now Roon is playing, I will note the time of the next error.

Music froze at 2:44pm NY time. Trying to restart buy pressing play on that track gave "Unexpected error communicating with audio device”.

At this point, Roon says that music is not playing. Selected more music and now Roon is playing happily.

Brief drop out at 3:12pm.

Stopped playing again at 3:54pm then started again.

Playback stopped again (spontaneously) at 4:07pm. The little histogram that indicates activity is still going but there is no sound. I give up for today…

Hi @Jim_Gatheral,

Thanks for letting me know those timestamps! I’ve activated diagnostics mode for your account and what this action does it automatically upload a log set to our servers.

I can confirm that this log report has been received and I have passed it to our technical team for further review!

Hi @noris,

When do you think you will be able to get results from the review team?


Hi @Jim_Gatheral,

Thanks for your patience here! I spoke to the technical team regarding your logs, but unfortunately they were inconclusive. Have you by any chance reached out to Linn support regarding this issue? Linn support would be in a better position to address why this issue is occurring.

Hi @noris,

I did reach out to them initially but they sent me to their FAQs. Do you have any concrete information I could share with them? For example, is the Linn flooding the Roon server with messages, or vice versa?

Thanks in advance,