Roon doesn't see Squeezebox devices


I’m new to ROON, and just installed Roon core on my Windows 8.1 PC.

My issue is: Roon can’t detect my Squeezeboxes although I think I’ve done all the prerequisites:

  • close down LMS on my NAS
  • clear ZoneAlarm firewall for ports 9000 and 3483 (both TCP ands UDP)
  • set port forwarding accordingly on my Box/modem-router

At this point my remote library (Synology NAS / DSM 6) has been correctly scanned (350 albums) , however the only device detected by ROON seems to be my Smart TV … I’ve restarted Roon and re-retected devices, but to no avail.
Am I missing something ? Please help and advise !
Thank you

1 Like

@JL_Tancerman I would turn off the firewall completely for troubleshooting to start with. Keep your network as simple as can be.

Everything needs to be on the same subnet too, incase you have anything like VLANS or whatnot.

You should also provide some more info as noted here

flagging support for you too @support

Have you enable Squeezebox Support in Roon?

Hello @JL_Tancerman,

Can you please verify that you have enabled Squeezebox Support in Roon Settings? This option should look like this:

I would also temporarily disable your firewall as @wizardofoz mentioned. Please let me know if that helps.


I have to point the squeezebox to the IP of the Roon server. For example, my Boom requires me to set the IP of the computer running RoonServer on the Boom; then everything will connect.


and thank you (ALL of you) for your quick response to my help request.

I have read all the threads regarding “don’t see my Suqeezebox in Roon”, and indeed, I have:

  • killed my firewall altogether, and verified there was NO hidden LMS running anywhere in the background, or any other UPNP or DLNA server for that matter,
  • restarted my squeezebox and updated its firmware to 7.8.0 (EDO enabled)
  • doublechecked that the “enable SQ support” was ON in Roon settings

Also, I’ve tried to switch music libraries on my test Squeezebox Touch, but alas, the only ones displayed on the Squeez’ are the ones on my NAS (Synology 2-bay running DSM 6.2) and on my PC itself, nowhere can I manually input a local IP to direct the Squeez’ back to Roon…

Now, what’s weird is that my smart TV goes on and off from the Roon network devices list (more often off than on), which leads me to suspect a networking difficulty : I’m in France and running a French set-top box from Sagem, there are multiple POE powerline units along my LAN, my PC (Windows 8.1) is connected via one unit, my Box via another, and the Squeezebox via a third one - all these are Devolo Gigabit units with cat6 ethernet cables - No subnets or any fancy LAN structure (just a passive switch with my printers and the NAS). Everything works fine, for both music and movies as well (my smart TV has a local ethernet connection to the router). Everything is visible from everywhere… until I look at Roon, and no multimedia devices are visible from there… I’ve had previous experience with Minim, Plex, LMS, etc. on my PC, with no networking setup issues.

In the meantime, I’ve played around with the Roon music databse GUI and it’s exactly what I need ! … so I’d feel very sorry for myself if this issue couldn’t be cleared up during my Roon trial period (actually my plan is to buy a dedicated NUC-like server to run Roon and have it sit next to my NAS, too bad the Synology CPU is much too slow for Roon).

Any new suggestion for me ?
and again, thank you so much for taking the time to read my message !

Hello @JL_Tancerman,

Thank you for confirming those suggestions for me. We have often seen powerline extenders cause issues with Multicast and as such I would like to propose a test. If you temporarily connect your Core and Squeezebox directly to your Router via Ethernet, does everything show up and work as expected? If everything is working as expected then we can confirm that the powerline adapters are causing issues here.

You mentioned that the Squeezebox’s connected to your NAS show up as expected so this furthers my suspicions that the powerline adapters are the one’s causing the issues here. Please let me know the results from my proposed test above.


Hello again Noris,
and thanks for your reply and suggestion.

Indeed, I too suspect that the POE adapters interfere somehow with Roon’s broadcast for endoint devices/renderers. Here’s what I’ve seen and “tested” regarding the POE interference:
Besides the “main” Squeezebox Touch on top of my HiFi rack, I have a few more in other rooms around my POE local area network. Yesterday evening I cold started SqueezeBox #2 in my office (with LMS still down), and it was indeed detected by the Roon server and started playing music - hoorray! Why this one and not the first one ? The second Sqeez’ is connected using WiFI to the same POE adapter as the PC running Roon Core, whereas Squeez’ #1 goes thru an ethernet cable to yet another POE adapter on my home network.
However, this morning I tried connecting both Sqeezeboxes thru the same WiFi port on the POE adapter of the PC running Roon, and alas, none were detected by Roon … Moreover, I had managed to make my SmartTV (ethernet cable to router) appear on the Roon device list, I got a big ROON logo onscreen, but that connection dissapeared after a short while.
Also, while I had the Sqeezebox #2 connected to Roon yesterday evening, I tested Roon Remote on my Android phone, and couldn’t see the Squeez’ from there - all I had was the PC default audio output. What a drag !
And finally, I must say that when the Roon server took over Squeezebox #2, I lost all control over the Squeez’ - no way to access my Internet radio setup for instance, no way to run some of the plug-ins, etc… which is very disappointing in view of the fact that Roon (at this point) doesn’t have a decent Radio GUI and thematic database interface …

So my personal interim conclusion is:

  • lack of stability of functional connections to endpoints/clients in a POE environment,
  • no Internet Radio database interface
  • no coexistence with either LMS or Sqeezebox apps
  • defective (in my experience) multi-room handling from Remote

My conclusion: I’ll have to pass on Roon for the time being, although the system has enormous merit (alpha listing of composers is truly exceptional, as well as wiki-like info on artists and works - incidentally, LMS has a “referral” Squeezebox app which interfaces Qobuz and links the current track being played to other tracks on Qobuz, which is “better than nothing” in terms of musical info integration… but far from the powerful Roon service).

I’ve talked to Devolo about the POE compatibility issue, and they informed me that they have released a new line of POE LAN adapters based on yet a new technology (Home Grid Forum, versus current HomePlug standards) which might be more transparent. Inasmuch as Roon Labs have a certification platform for servers (and endpoints ?), maybe you could also start certifying POE adapters as well (ethernet and/or Wifi) ? - just food for thought…

Anyway, thank you for your kind attention,
with best regards

Hello @JL_Tancerman,

Thank you for your post and sorry to hear that you decided Roon is not right for you. We have definitely seen issues surrounding POE adapters and as such, they are listed as non-recommended devices in our Networking Best Practices Guide.

As for your question regarding the new Devolo POE adapters with Home Grid Forum G technology, we would not be opposed with working with them to test the adapters and see how they perform with Roon. Do you by any chance have a contact at Devolo who we can contact regarding this or a way to have them contact us? Just let me know if this is possible and I will forward this request to the appropriate contact from our team.


1 Like


I’m back testing ROON again, after a major change in my local networking setup.

This time I have ROON on a Windows 8.1 PC, a Squeezebox Touch (firmware 7.8) as renderer, and a Synology NAS (DSM 6), all connected on the LAN ports of a single Netgear router/modem rather than thru powerline adapters as I’d done last November. Both PC and NAS use short ethernet patch cat.6 cables, while the Squeezebox goes Wifi (98% signal strength). LMS was turned off, and Squeezezbox “enabled” in Roon - goes without saying.

HOWEVER, the issue still remains: ROON server cannot detect the Squeezebox !

What’s worse: Roon readily detects my smart TV from another room, and that TV connects to the router through a Linksys switch and a pair of powerline adapters, which were supposed to be the likely cultprits in my initial November ROON test !

Ergo, I believe something has to be done at the Sqeezebox level, but I am baffled, I have no idea what to do to have ROON detect that Squeezebox (and/or my 3 other Squeeze units…)

Anyone can help ? (Noris please ?)

Thanks for listening to me.

Maybe a stupid suggestion you already did: before connecting to the ROON server shut down all existing LMS, then switch database on your Squeezebox (Step 1 of this: Also, make sure the SQB Touch isn’t a LMS by itself. It’s the only SQB capable of doing so.
Hope this helps, it can be so frustrating…

Besides what Gabriel said, as a test, I would eliminate WiFi as the culprit by connecting the Touch via ethernet to the same switch. If it is seen then we know to focus on WiFi.

Hi @JL_Tancerman,

In addition to the above suggestions, have you pointed the Squeezebox to the Roon Core yet? You have to do this by navigating to your Squeezebox Touch -> My Music -> Switch Library -> Select your Core from that screen. Please let me know if that helps.


Hello Norris
and thank you for your suggestions, including the last one.

I changed my modem/router (due to a change in ISP contract), and all my renderers, printers, PCs, mobile phones, and smart TVs are now active on the LAN - hence my delay in responding to you.

The Roon server is on my main PC, my test Squeezebox is up and pointing to my PC instead of my NAS, both are on ethernet cables to the modem/router. I reinstalled Roon on the PC (Win 8.1) and had it scan part of my NAS music, I killed LMS on the NAS, no other LMS in sight… and yet Roon fails to discover that test Squeezebox, let alone the other audio renderers on the LAN (TVs and Squeezeboxes on Wifi and/or powerline adapters on the same single subnet). I am at a loss now. I had RoonLabs extend my free trial until March 20, yet I am clueless as to what to do here !
Thank you for your interest.


Did you go into the Squeezebox and select the new server? I have to set the server IP on my Squeezebox Boom and Classic 3 on the squeezebox device.

And, as always, make sure that any Firewalls are turned off on the PC as they can block Roon from seeing things on the network.

Hi @JL_Tancerman,

You mentioned this:

We have previously seen issues with powerline adapters interfering with Roon communication, can I please ask you to connect the audio endpoints and the Core directly to the Router via Ethernet and let me know if everything works that way? Even if as a temporary test, I would like to eliminate this part of the equation just to make sure that the powerline adapters are not causing issues here.

As @Rugby mentioned, I would also verify that Roon is added as an exception to your Windows Firwall (you can use these instructions to check) and also that Roon is not being blocked by any Antivirus applications you may have, possibly even temporarily turning off the Antivirus firewall feature will be a good test to run just to eliminate that variable as well. I look forward to hearing your results.