Roon Exclusive Mode - Need to restart PC to get sound from other apps

Core Machine (Operating system/System info/Roon build number)

Core: NUC i5 / 8GB RAM / Win10

Current device: Desktop i5 / 16 GB RAM / Win10

Latest build Roon on both

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

All on Ethernet, 500/500 fiber connection.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Current device: Pro-ject Pre Box S2 Digital - USB-connected, playing with ASIO driver

Description Of Issue

Whenever I start Roon and play music with it, I can never go back to playing from other sound/video sources on the same machine, even after closing Roon. I sometimes play random music files from MusicBee, or play video with PotPlayer or from YouTube, Netflix, HBO and so on, but I always have to restart the machine to do this. I have tried a lot of different settings, and if i switch to WASAPI and turn of exclusive mode, it works just fine, so I assume it is the exclusive mode that doesn’t release even after I close Roon.

As I use this machine as my main source both for work, everyday life and music station… it’s quite tiresome to do this several times a day. I often end up playing with exclusive mode off, but that takes away both from general SQ and MQA glitches on all of my Tidal albums. More and more lately I end up not using Roon at all on this machine… just play the files straight from Music Bee and Tidal.

Any fix for this?

This thread explains the ASIO grab of the stack though it should release if you close roon.

Thanks, but I have no problem with ASIO claiming the device when active, or Exclusive mode in WASAPI doing the same. I’ve been running Roon on 3 different machines, and they have all had the same issue with not releasing it again when closing Roon, so I was hoping other people would have had the same issue, and possibly a fix. :slight_smile:

I use a device in WASAPI in exclusive mode and it releases when i close roon. What are your devices and their drivers that aren’t?

Hi @Henrik_Richter_Schie,

Can you please let me know if your Pro-ject drivers are up to date? Does this same behavior occur for other ASIO zones as well or only on the Pro-ject?

Yes, the Pro-ject drivers are up to date, but it could be the Pro-ject. These has been a lot of issues with it, and although it runs quite smoothly now, it needed several FW and driver updates to reach full potential. This PC is the only zone I used for other purposes than running Roon exclusively so I can’t really try to replicate it on my other zones, but I’ve had the same issue on another machine but with the same Pro-ject DAC.

Hi @Henrik_Richter_Schie,

Thanks for letting me know that additional information. Does restarting the DAC also allow communication to be re-established or does the Core itself have to be rebooted? If you connect the DAC directly to the NUC Core, is the behavior the same?

Thanks, I’ll try that, though now I have switched to WASAPI and did a reset of settings to default, and that actually helped, in a way. I can now close Roon and start playing from other sources without reboot, but that caused a new issue. When reopening Roon after using it an closing it, I get the “failed to initilize audio device” error and have to restart the DAC to be able to get it to play again. LOL. Switching to ASIO works though, but ASIO still has the same problem of not releasing exclusive mode after closing. I see now that this might be an issue with the DAC, but if you have any obvious tips, I’m all ears. Thanks in advance!