Roon Extension: Rotel Volume/Source Control

Hi Didier,

Did you go to device settings and select the extension as volume control (and source control)?


Hi Boris - many thanks for this, I have the volume control working successfully with the Rotel A14 Mk2. There is an issue with the Source Control though, which I suspect is nothing to do with your extension. I can put the amp into standby, but then it disappears from Roon and I can’t switch it on again with Roon Remote. This is different standby behaviour from my old Audiolab amp. I suspect it has something to do with this:

There is no reference to Signal Sense in my amp’s menus (I’m in the UK), though there is a setting for Power Mode, which I have set to Quick as suggested.

I’m wondering if I used a VPN at the router level and switched to USA the Rotel would update the firmware and unlock the functionality?

Anyway, excellent extension, great being able to use device volume!

1 Like

Hi Franko,

One question… How is your Rotel connected to roon? Roon bridge? USB?


It’s attached to a nuc via USB

And the Nuc is your roon core?

I think the problem is that the USB port is also turned off when you power off your amp, that’s why the endpoint disappears in roon. If you want to power on your amp automatically when you start playing some music, you’ll need a roon endpoint that does not get powered off. In my case this is just a Raspberry Pi (with roon bridge installed) connected to my Rotel (toslink), the Pi never gets turned off so the endpoint is always visible to roon.
Would it be possible to install the roon bridge on your Nuc (assuming the Nuc is always powered on) and use the bridge as always on roon endpoint? Just an idea…

Thanks Boris. Yes, to clarify, the Nuc is the core and is directly connected to the A14mk2 via USB/Wasapi. The Nuc is running Windows 11, and is kept on 90% of the time. I don’t see why a pi would behave differently. The change in behaviour seems like it is on the amp side, as my Audiolab M-one amp/dac used to be visible in Roon when on standby.

p.s - I think I see what you are getting at re. bridge. I am going to get around to seperating the core/endpoint in my living room at some point. But at present the Nuc doubles up on general video/media centre duties as well. Thanks

Haha - sussed it. I switched to Rotel’s Asio driver instead of their Wasapi driver and the source control now works properly. I was thinking back to my Audiolab and it only came with a manufacturers Asio driver, so I gave it a go.

1 Like

Thanks for letting us know the solution, I’m glad it works now!

Hi Karl,
I wnated to know how you were able to sent the command vol_22! towards the Rotel?
I am logged on via PuTTY (ssh) on the Raspberry Pi with teh Rotel Volume/source Control installed.
But when I type node . I am not able to sent any command towards the Rotel.
So I presume I have to do it in another way, but I couldn’t figure it out.
The Rotel Volume/Source Control is working 100% correct for the volume. I can change the volume via a Roon app. That is working perfectly.
But the source-control is not working. My input is bal_xlr, but when I change to whatever other source, the Roon-player is not paused. And when I push on the Roon-player on “Play”, the source is not changed to bal_xlr. So that is the reason that I want to check what is happening when I sent commands directly to the Rotel RC1590.
Kind regards, Frank.

Hi @Frank_M
You have to connect to your Rotel directly, you can use putty like this:


You have to use the correct IP address of your Rotel of course and you may have to change the port, depends on the model you have. Which Rotel do you have? (Ok, I saw it, RC1590 should be port 9590)

After the connection is established you will see something like this:


You will see what the Rotel sends und you can enter commands like vol_22!. Have a look at the documentation for your model.

Please note:
You may have to terminate the extension to be able to connect to your Rotel.

Hope this helps,

Hi Boris,
Thank you for this info.
I can now sent the commands and the Rotel RC1590 is reacting correctly.
Nevertheless, I cannot pause Roon when I switch on the Rotel to another source. And the source is not changed to bal_xlr when I push on Play in Roon. What could be the reason?
By the way, thank you so much for such a fantastic software! I like it very much to be able to change the volume of my Rotel RC1590 from the Roon app.
Kind regards, Frank.

In ‘roon - settings - audio - device setup’ of your audio device: did you setup the ‘external source control’ correctly?


Hi Boris,
You’re a genius! I only indicated “Rotel Volume/Source” in the Volume control setting.
Now I also added “Rotel RC-1590 Rotel Volume/Source Control” in the External source controls, and now it works perfectly.
Big thanks for your help, Frank.

Hi Boris,
I downloaded the latest version of RooExtend (3.0.2), in which roon-extension-manager by TheAppigineer (Home · TheAppgineer/roon-extension-manager Wiki · GitHub) is implemented.
But, under the Category “Device Control”, your extension for Rotel “roon-extension-rotel” is not available.
Can you check with @Jan_Koudijs how your Roon-extension can be added in his image?
That would be much appreciated.
By the way, your tool is realy fantastic! Many thanks for all your hard work for this.
Kind regards, Frank.

This is the effect of ARMv8.
Docker images made for ARMv6 seem to be not available yet with ARMv8. :- :cold_sweat:

That is a pitty :sob:.
I hoped to be able to put the Rotel-extension on the same RPI.
Lucky for me, I still have an old separate RPI2 on which runs the Rotel-extension.
I can only hope that @Boris_Schaedler will upgrade his roon-extension-rotel to be used with ARMv8-processors.
Thank you for the explanation, Frank.

I guess this will come sooner or later as ARMv8 ist the current standard.

Hi @Frank_M,

The Rotel extension hasn’t been converted to the format that is used by the 1.x version of the Extension Manager, but you should be able to use it.

In the System category you will find the Extension Snapshots, if you install that one you can open the Settings of it and start the Rotel extension.

1 Like

Hi Frank,

I will add the Rotel extension to Jan’s extension manager v1.x… give me some time… :wink:



Your the man!
Thank you so much.
Kind regards, Frank.