Roon fails to decode jpg images sourced from apple music

The album in question, Dlina Volny - Dazed is identified by Roon and matched artwork at 1280x1280 pixels is shown as a lower resolution ‘Prefer Roon’ option in my screenshot. ‘Your’ 3000x3000 pixel artwork was found when I used the ‘rescan album’ option in Roon. This command finds and updates in-folder or embedded artwork and I know ‘your’ art is being used because my original folder.jpg was of a slightly lower resolution.

I’m running my Roon server on Linux (Arch) and have never run into an issue of this type so I can’t offer any further help.

Good luck with fixing your album art and don’t forget to enjoy the Belarusian cold wave. :belarus:

Bizarre, my Roon Server is running Arch also. :exploding_head:

@support, there a reason there’s no follow up here? What else do you need from me?

Could it be some weird permissions issue. We get load of issues at work with files downloaded via Mac’s that our Linux machines wont open and it’s always due to its permissions.

Unlikely, my scripted tagging workflow includes setting file and folder permissions for all folders and contents before they’re copied to the server running Roon. My desktop runs Arch too, it has no issues displaying the images.

Hi @evand ,

We tried your original 3000x3000 image on Windows and ROCK as Folder.jpg, and are not seeing any issue with the artwork showing:

2021-11-17 15_15_10-Roon

2021-11-17 15_13_54-Roon

Are you able to reproduce the behavior on your Windows 10 PC? Perhaps this issue is Linux-specific.

Just added the same album to a Windows 11 instance of Roon core and Roon appears to be picking up the correct artwork. One thing that is different here is that by the time you tried it the album would no longer have been Unidentified within Roon as I’d added it to Musicbrainz some time ago.

I’ll retry the experiment by adding the same cover to a random album unknown to Roon that also doesn’t exist in Musicbrainz and see what transpires.

@noris

Right, so I saved this file: https://is3-ssl.mzstatic.com/image/thumb/Music115/v4/5c/4d/74/5c4d7424-e26c-f2ef-106e-9e714ba72b58/source/9999x9999-100.jpg as folder.jpg in a folder containing an album Roon has not identified. Prior to doing this, there was no album art in the folder. This is how Roon Server (on Win 11) shows it:

Forcing a rescan of the album:


Yields:

image

To further prove the point I copied folder.jpg from the Beyries - To Love Somebody EP into the same folder, rescanned again and got exactly the same result - Roon does not display it.

I suspect the clue to the problem lies here where you can see Roon believes there’s no image:
image

Yet here it is, in all its glory:

and here it is again, this time in a folder containing an EP Roon has identified:
image

So, in conclusion then, from what I can see / infer:

  1. there is a bug
  2. it’s OS agnostic
  3. it has nothing to do with image file size or header
  4. it’s triggered under certain conditions when an album is Unidentified in Roon
1 Like

To add another permutation to outcomes that once again confirms for me there are bugs at play here:

In this instance the file in question is 3000x3000 - note Roon’s identified the album and as far as it’s concerned, in this instance there is no file on disk.

Yet, again, here it is, on disk:

Source:
https://is3-ssl.mzstatic.com/image/thumb/Music125/v4/71/99/43/71994384-24b3-2d0a-2f0b-35ce79bbab21/source/9999x9999-100.jpg

Same story:

Source:
https://is1-ssl.mzstatic.com/image/thumb/Music115/v4/7a/4b/d3/7a4bd3ae-ba12-e1e7-9323-2b6bb5fce2eb/source/9999x9999-100.jpg

And again (this time an unidentified album):

Source:
https://is3-ssl.mzstatic.com/image/thumb/Music115/v4/6c/73/36/6c733675-b032-9d1b-99f0-41fe1e588e2b/source/9999x9999-100.jpg

and a last datapoint. This album was unrecognised in Roon until I selected it and ran a rescan this morning. I’d added it to musicbrainz a few days back, soas expected Roon is now able to recognise it.

However, in doing so Roon has completely ignore the on disk folder.jpg.

image

https://is4-ssl.mzstatic.com/image/thumb/Music125/v4/4c/fa/c0/4cfac00f-abd6-bd50-cebc-7ec828e9bb52/source/9999x9999-100.jpg

Yet Roon says no image.

Hey @evand,

I am so sorry you haven’t heard back from us until today. I wish we would have said something so you know that we haven’t ignored the topic you created. We’ve actually been talking about this in trying to find a solution.

While Noris is out of office this week, we’ve consolidated all the information you’ve shared in a ticket for our QA team. They’re going to investigate and we’ll get back to you as soon as we, at our turn, hear back from them.

This is a great opportunity to thank you for the clear examples you’ve shared: they help our teams so much! :pray:

Hey @evand,

I am so sorry that my follow up does not provide a solution (yet), but a request…

I was wondering if you could:

  1. Remove the media directory with images that are not displayed.
  2. Restart the Roon server
  3. Reimport the directory, wait for 10 min
  4. Grab the logs immediately after and upload them here

Many thanks. I’ll keep an eye out on your post.

@beka @noris , done.

Hey @evand,

It seems that we only got a .txt file. Would you mind zipping up the entire logs folder and uploading that? Same drive.

Hi @beka @noris, I’ve followed the instructions once again and uploaded the only file in /var/roon/RoonServer/Logs

If Roon’s supposed to be generating something else, is it located elsewhere?

Hey @evand,

Thank you so much for doing all we asked on your side. I want to apologize for the delay in replying…

Normally, there should be over ten .txt files in the Roon Server Logs… thanks for the one :pray:

If there were any changes in the past two weeks, we’d love to know.

No change. Same issue, different year.

1 Like