Roon file scan never stops

Roon Core Machine

I run my core on a sonictransporter i5.

Networking Gear & Setup Details

My router is a TP-Link WiFi 6 AX6600 Gaming Router (Archer GX90).
My switch is a D-Link DGS-1210-20.

Connected Audio Devices

I have several.

Number of Tracks in Library


Description of Issue

The issue is with file scanning. For the last few weeks or so the file scanning has been constant. It’s like it’s stuck on something and just keeps scanning. Everything else is working fine.

Give your big music treasure 5 minutes break on all devices without power, internet and then reconnect everything. Please let us know if this helps you too. Many people were very happy about this simple solution.

1 Like

I’ll give it a try. Thanks.

1 Like

I tried this but unfortunately it didn’t fix the problem for me.

1 Like

A post was split to a new topic: Roon file scan does not stop

I’m not a programmer or developer, but a spry retiree with a thirst for research and computer skills (decades of Windows, some macOS, and for the last 5 years or so, more and more knowledge of Linux).

I learned out of interest how the basic structure of a log file is. Fatal and Error I have thank God not. But Warn gives hints there is still something to improve and these hints are in the network environment and in the data quality. This also explains why not everyone has a particular problem.

Do you also have erroneous files under settings, library, skipped files?
All corrupted music files are stored there and can also be copied to Excel.

Excel or another spreadsheet helps because everything is nicely organized and analyzable there. You can also make good use of the log files (read, filter, sort…).

We will work out the background with a lot of public exchange and the team surely has a priority list, where this point is not very high, but also not forgotten.

1 Like

Update on the file scanning issue. It looks like this issue has been resolved, at least for now. I had recently reset my managed switch and forgot to turn on flow control after I did that. Shortly after doing that the file scanning issue seems to have cleared up so the flow control may have been the culprit.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.