Roon First Sign-in - Sits and spins forever [Solved - WiFi+ Transfer App Conflict]

Core Machine (Operating system/System info/Roon build number)

Windows 10 20H2, i7 8700k, 32 GB RAM, M.2 Samsung 970 Evo Plus, Roon v1.8 Build 873

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Not relevant yet. Can’t even get Roon to run on Core Windows desktop

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Not relevant yet. Can’t even get Roon to run on Core Windows desktop

Description Of Issue

After installing Roon and signing in for the free “trial” - the gif sits and spins forever (as in hours, if you let it). Have rebooted, uninstalled and reinstalled, checked firewall settings… looked at roon_log.txt… to no avail. So far a colossal waste of a Saturday. JRiver looking better by the minute.

1 Like

You say network details are not relevant, but it needs to see the internet to login/register.

2 posts were split to a new topic: Roon Sits and spins forever

Yes, the PC is connected to the Internet. Downloaded and installed Roon from this PC. Registered online on this PC. Logged into the app on this PC. The Core shows up in my iOS device on the same network, but also sits and spins on the GIF. Orbi mesh network; PC is hardwired to the nearest satellite.

Also, played music over the network with JRiver from this PC all day. And tried killing JRiver on the off chance that Roon was looking for the same ports, but the log file would seem to indicate that is not the case.

It’s possible that Windows Defender hasn’t set up the firewall exceptions for Roon as it should have done on the installation of Roon.

Good idea! I tried disabling the Windows Firewall (only Private should be relevant, but disabled Public and Domain settings as well). Unfortunately, this didn’t appear to fix it. I don’t see a way to attach my roon_log file, and when I tried to copy and paste part of it here, there is some restriction about the “number of links in a post.”

By way of full disclosure, I also have Hyper-V installed, and am using an external switch through my onboard Ethernet card. This works perfectly for all other applications on the PC (including JRiver, etc.), and the local IP address for my machine uses a DHCP reservation.,

Is Roon in a VM? Either way, hyper v is probably the issue.

Search the forums on hyper v. Here is one

No, Roon is not IN a VM on the hypervisor. I was merely citing that I also have Hyper-V running on this PC with guest operating systems on it. Roon is running on the host Windows 10 desktop.

Sorry for the trouble here, @gtap!

Would you kindly use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service)?


Sorry this took me some time to get to today. Please see the link below for the log files requested. Thanks for your help!

For reference, I run JRiver media server and Roon in parallel so no port clash, Audirvana and JRiver clash they both go for port 8080

Have you installed the manufacturer video driver and overwrite Windows selected one, often helps

The other try is a “cold” reboot of everything, Network forward

Hi @gtap

Thanks for sending those logs over. I took a look and I’m seeing some traces that we’ve seen in the past occur when there was a corrupted graphics driver. Can you try uninstalling and reinstalling the graphics driver directly from the manufacturer’s site (don’t use automatic Windows driver installs for this)?

@dylan Thanks for the feedback. I actually already did this the night before last after I posted the logs, in response to the message posted by Mike above. It’s an onboard Intel graphics card, and I usually go out to the Intel site and check for updates pretty frequently. In this case, I was about 3 months behind… but updated to the latest version of the driver. I then did a cold reboot of the computer. Didn’t seem to change anything. Let me know if you would like a fresh copy of the logs…

Not really feeling the love here… 9 days into the trial, and not much assistance with getting it to work. I’m betting on cancelling on Friday night before this starts costing me money on Saturday.


Thanks for the trial extension, but there still hasn’t been any follow-up on my issue. Since everyone on this post seems convinced that Roon cannot co-exist on the same host PC as Hyper-V (which seems like a problem that should be addressed to begin with), I took the step of removing it this weekend. Also un-installed, re-downloaded, and re-installed Roon for good measure. Nothing changed. I’m posting a fresh set of logs here. This was from letting it run for almost 18 hours.

At this point, my investment of time/frustration to even be able to TRY this software is starting to get disproportionate to any potential perceived future benefit.

Hi @gtap — Apologies for the continued delay here. We’ve been looking into this, and the issue that you’re seeing seems very familiar (based on the logs) to what was being seen in this report:

Do you have anything like this WiFi+ Transfer installed on your device? The log traces are nearly identical to what we were seeing in that case and is consistent with what we previously thought: Something is blocking the connection on the machine, and until whatever is blocking it is removed, Roon won’t be able to function properly.

1 Like

@dylan - Well, what do you know! I do have Nero installed, and WiFi+ Transfer was running at startup. It’s actually one of the startup things that I sometimes kill after startup, but hadn’t done for a while. I’ve removed it from Windows startup permanently, and Roon ran immediately. So now I’m in business, and able to try the software out. Thanks for your help, and for figuring this one out. (Now crossing my fingers that I can re-enable Hyper-V as long as I make sure I don’t let it configure itself for two subnets!) Sorry I was feeling a bit impatient at times. :slight_smile:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.