Roon Hanging after Windows 2004 update

Having same issue. Updated Windows on 11/12 and have not been able to open Roon since. Updates included:
Feature update to Windows 10, version 2004
2020-10 Security Updtae for Adobe Flash (KB4580325)
Intel Corporation - Display -
Intel - SoftwareComponent - 1.38.2020.805
Intel - SoftwareComponent -
Intel - System - 2035.15.0.1807
2020-11 Cum Update for .NET (KB4580419)
I have tried hints above, renameing cache, uninstalling and reinstalling, renaming directories and reinstalling. I get past selecting PC as core and signing in and then it hangs at Room symbol.
Task manager says RAAT server, Roon, and Console Window Host are running with 0 activity

Help would be appreciated

What exactly did you uninstall and reinstall?

First time uninstalled app from Windows app and reinstalled from download. Second time I renamed Roon and RAAT server directories in app data and reinstalled from download

Have you tried uninstalling and reinstalling the driver for your graphics card?

I have rolled back the driver and tried to start unsuccessfully. Then removed it and reloaded the display driver and again same problem. Get past login, and then stuck at roon logo (half circle and audio signal). Just hangs forever

HI Mike,

I’ve moved your post and responses to their own thread, that way support will be able to see it better. @support prefers each new incident be their own thread, it prevents getting things mixed up between users.



Hi @MikeW,

We’ve seen Windows updates cause issues with graphics drivers which results in this behavior. What is the GPU for your device?

When you uninstalled / reinstalled, did you use Windows to install the driver, or did you install the driver directly from the manufacturer? Windows’ automatic driver updates can sometimes be a bit flakey, and we’ve seen direct downloads from the manufacturer help in cases where Windows installations did not, so it’s worth a try if you haven’t gone that route.

The GPU is the Intel UHD graphics 630 built into the motherboard. I don’t ahve a dedicated graphics card. I installed the new driver from a download on the Intel website. so not Windows.

Hi @MikeW,

Can you please use these instructions to send me a set of your Roon logs after reproducing the issue?

Here is dropbox link to logs

1 Like

Hi @MikeW,

Thanks for sending those logs over. I’m seeing some strange traces here that I’d like our QA team to review, so I have submitted a review request with them and will let you know once I hear back.

The error traces appear to be network-related, so we will also need to know how your network is configured. Can you please provide some more details regarding your network setup?

  1. What is the model/manufacturer of your router?
  2. How is the PC connected to the network, via WiFi or Ethernet?
  3. Does the PC only have one active network connection (as in you have only Ethernet or WiFi active and not both)?
  4. Are you using any network adapters or PCIe Network Cards?
  1. I am behind an ATT fiber connection, their ARRIS NVG599 router, then a Ubiquiti Unifi USG that handles all DHCP, etc.
  2. The PC is hardwired (no wifi) into the network.
  3. only one active connection on mother board
  4. No expansion cards (graphics on motherboard) and one M.2 SSD that I believe is nvmei
1 Like

Thanks for those details @MikeW, let me get the logs and network info to QA for review.
I will reach out once I have more information from them, thanks!

@noris I have gone ahead and installed Rock on a NUC, which I was eventually going to do anyway, and it runs fine. Roon works fine on the PC now as an endpoint.

1 Like

Hi @MikeW,

Thanks for letting us know that ROCK is working properly for you.

I did speak to QA and they mentioned that it looks as if Windows may have edited the security settings on your PC after the update.

If everything is working, no need to investigate further, but if issues start to re-occur we suggest to check the Antivirus and Windows Firewall, thanks!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.