Roon hangs at the end of a song

Roon seems to hang on a regular basis at the end of a song. The songs on which it hangs varies, the only constant is that it happens at the last second. Clicking on next song, or waiting a few minutes resolves the issue. Any thoughts?

I am using a Totaldac d1-dual, either attached to a Sonicorbiter SE or directly to the Windows 10 PC that runs RoonServer. In both cases attached via USB.

Can you please give us more details here:

  • Describe your setup, use this FAQ as a guide
  • Is this happening with TIDAL and local music or only with one of them ?
  • Can you reproduce this issue when there are no songs in the queue and Radio feature is turned off?


I do not use Tidal. This is happening with music stored on my NAS.

It’s rather hard to reproduce consistently, as it does not necessarily hang on the same song twice. The hang could happen with the first song that was played, or after 25 songs, or …

Seeing it is rather hard to reproduce consistently at all, I haven’t yet tried an empty queue and/or disabling radio. See setup description below.

Server Setup

  • RoonServer 1.2 build 147
  • Intel i7 4970 / 16GB RAM / 256SSD
  • Windows 10 64bit
  • 1Gb wired ethernet

Storage Setup

  • Music on Synology 713+ NAS
  • 1Gb wired ethernet

Client Setup 1

  • Sonicorbiter SE 2.2
  • 1Gb wired ethernet
  • Totaldac d1-dual
  • Attached via USB

Client Setup 2

  • Totaldac d1-dual
  • dac attached to server via USB

Hello @Nepherte,

How things are going on your end ? Have you tried to make the test with queue and radio ? Let me or @Eric know.


I was out of the country for a while, so apologies for the late repy.

Radio is always turned off (so yes the issue has happened with radio off). As far as I can tell, it has never happened with no songs in the queue. another song was always queued to play next.

The way the issue is usually triggered is when I ‘Play All’ tracks, be it from my library or a playlist. I also encountered the issue on my Macbook Air + System output so it doesn’t seem to be tied to my setup.

Perhaps it’s an issue with the music files? Most of my music is in .aif format. On the other hand, I tried playing a song that got stuck at the end (by clicking play previous) and it went smooth the second time.

All in all I still haven’t found a way to reproduce it consistently, apart from the fact that it’s consistent in its inconsistency…

Haven’t encountered this issue any longer. Not sure exactly when it disappeared. No need to investigate any further.