Roon hangs from minimized window - Windows 10

I was experiencing the hanging issue on Window 10 V21H2. I’ve recently upgraded to new version hoping this would solve my issue, but sadly I’m still having it and I can recreate it. When I open windows and unminimize Roon I get the following screen

Hi @Joshua_Baptiste,

Try this for me:

  1. Close Roon

  2. Navigate to: C:\Users(username)\AppData\Local\Roon\Database\Registry\Client\

Note: It may require enabling “show hidden files and folders” to see this.

There you should see the file: saved_window_pos.

  1. Rename this file to saved_window_pos.old, restart your computer, and launch Roon then try to duplicate your issue.

Let us know if this doesn’t resolve the issue for you.

Unfortunately this didn’t resolve my issue, same result

I just run Roon in a Window and never minimize it.

I’m not always minimalizing it either, so the title is a bit misleading

Can you make sure that under settings>about you are running the most recent version? I believe you are but I just want to be sure. We did release a potential fix for this issue.

Can you please hit start, then type system information for me, then make a screenshot to share here? If it doesn’t show the video card, please note that information and share here as well.

Thanks,
Wes

Here is the version I’m using:

Here is system information:

There is no video card, just Intel HD 4000 integrated chip

Thank you for the quick response, Josh.

Will you also tell me what your screen resolution is set to? Out of curiosity, if you change it, does the issue persist?

Thanks,
Wes

This is where my setup likely gets interesting. Since your license for Roon only consists of 1 server only, my Roon server is on a PC in my basement and I have a Sonor uRendu running my main rig. Typically I don’t touch the Roon server, but in order access it I remote desktop into it. This has worked OK in 1.8 because mostly I use Roon Remote on ipad to control my music. However now with Arc, when I log off of the remote desktop the Roon service locks up and ARC fails. If I’m logged into remote desktop and using ARC there isn’t any issue. The issue is always recreate able, by logging on and off remote desktop and I get the white screen of death on Roon.

Going back to your screen resolution, it’s not applicable because there is no screen and can’t be changed via remote desktop.

If the PC is just acting as a server, then you might want to use RoonServer and not Roon since RoonServer has no GUI part to hang.

Alternative 1 is to create a secondary desktop where you leave Roon Maximized. Remote into desktop, switch to secondary desktop with Roon, switch back and then logoff

Alternative 2 is to try using Teamviewer or Splashtop to remote into the core and not RDP and see if the issue persists. Each is free for home use.

Thanks I’ll give RoonServer or alternative 2 a shot. I already know Alternative 1 doesn’t’ work as I tried this.

2 Likes