Roon having trouble playing WNYC streams

(Jeffrey Moore) #1

I can check when I get home whether the station has changed the URLs in question; I’m not yet sure sure if some URLs which once worked have ceased to work while still existing. I’m also not sure whether this issue is related to changes at WNYC or changes with the advent of Roon build 234. But here’s the deal - this URL:

https://fm939.wnyc.org/wnycfm

…which plays fine in VLC, gets this response from Roon:

Granted, the above is at an unreasonably low sampling rate and bitrate, which WNYC should be ashamed to offer, but still, I have family members who would like to listen to this.

Similarly, Roon rejects this:

https://fm939.wnyc.org/wnycfm.aac

My Core is 1.3 (build 234) on Linux.

Update: I note that a WNYC URL shared by @brian back in Mar '16:

no longer seems to work.

(GaryM) #2

Try this for am
http://am820.wnyc.org/wnycam

This for fm
http://wnycfm.streamguys.com/

I’ve been using these but not home to test right now.

(Jeffrey Moore) #3

Thanks! The AM one does seem to work with Roon.

(Boy, that’s a terrible-sounding stream. WNYC should really be ashamed.)

(GaryM) #4

Yeah. I just use for news/talk so doesn’t really matter.

(GaryM) #5

https://fm939.wnyc.org/wnycfm

This is what you tried. Works for me with foobar2000. I wonder if roon is not dealing correctly with https:// streams. LMS had to fix some things in their software to work with https even though older http streams did work. Just a thought.

(Mike) #6

We actually opened a ticket about this earlier today :wink:

We’ll let you know what we find @Jeffrey_Moore – thanks for the report.

Also, I posted a working steam for WNYC here last week:

2 Likes
(Jeffrey Moore) #7

Oops - I searched for a similar report before posting this, because I try not to create duplicates. Must have missed it.

Or was it an internal ticket, no visible post? Then I wouldn’t feel so bad.

Oh, thanks! Totally missed that as well. D’oh, same URL I had a failure with, except HTTP instead of HTTPS - which substitution I should have thought of trying.