Roon hijacking iOS volume [Investigating]

Roon Core Machine

Intel nuc 7i5, 16GB running ROCK

Networking Gear & Setup Details

Ubiquity Unifi. No VPN.

Description of Issue

When using Roon the local iOS volume gets reset to 100%. This is very annoying and caught me off guard quite a few times. Roon shouldn’t touch my iOS volume levels. Ever.
Suggestion: let me disable the hardware volume buttons is Roon?
This issue is marked as fixed elsewhere, but it obviously isn’t.

Have you tried turning off ‘Enable Lock Screen controls (beta)’ in Roon Settings > Setup?

Yes, that is turned off.

I made a small video to highlight the issue:

This is a know issue and I am surprised it has yet to be fixed considering it’s far from pleasant and dangerous.

I gave up complaining about it and learnt to live with it. That said, it does not happen to me every single time and I’ve not managed to establish a 100% pattern.

@RBM In my case, disabling the beat did not help. Even after deleting the app and power cycling phone.

If I use volume with Lock Screen control it does jump to what the phone volume was though if I touch the volume did it last night and it went from 25 to 8 with a single press, never have my phone volume very high and I never use AirPlay so it’s not been an issue yet. Doesn’t do it when Roons active app though. Not seen the phones volume get set to 100 though. Is this after using a fixed volume device or any?

No, it doesn’t happen 100% all the time, but it does happen very often. This bug has been present for such a long time now… I tried everything to fix it to no avail: restarting, reinstalling, enabling/disabling lock screen controls, deleting the cache directory on the core (that was to fix Qobuz login issues, which helped, but didn’t fix the volume bug).

I don’t use bluetooth except for my AirPods, but there seems te bo no correlation with my AirPods use and this bug. I hardly use airplay, so we can rule that one out as well.

Hey @Mike_de_Munck,

Ben here with the support team, thanks for taking the time to write in! I’m sorry to hear you’re running into issues with volume control when using your iOS device as a remote.

Does this happen to both of your iOS devices? I see both iPhone-van-Mike and iPhone-van-Fatima linked to your account.

If possible, can you please reproduce the issue and follow the steps below to share your iOS logs for further investigation:

  1. First toggle “Save logs to Files on next startup” from your iOS Settings for the Roon App.
  2. Reproduce the issue.
  3. Access your Files App on the phone and upload the log file here.

I’ll be on standby for your reply :+1:

Hi @benjamin,

The issue is present on both iPhones.
The log is uploaded.
The issue is not only the maximized volume, sometimes Roon minimizes the iPhone volume as well (as was the case when the logs were made).

I am running the latest ios16 beta, but the issue was the same in ios15.x stable, I had this issue for quite some time now.

Best regards

Hey @Mike_de_Munck,

Thanks for sharing the above information. If possible, can you please remove roon from your mobile device, power down the device, and reinstall roon. That will give us a fresh slate to continue to test.

With this, we’ll want you to set up a fresh RAATSever database as well.

You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings → Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

Let me know if your issue persists after the above :+1:

@benjamin I followed all your steps, the issue still persists.

I also restarted the core for good luck, but that also didn’t help.

Regards

Hey @Mike_de_Munck,

Thanks for giving that a try. While our team investigates this further, I’d like to offer a potential workaround for the time being. This involves downloading the ‘Shortcuts’ app from the app store.

After downloading this app, follow the steps below:

  1. Locate and open the Shortcuts app.
  2. If you don’t see an Automation choice, but you do see < Shortcuts at the top of the screen, click it.
  3. Click Automation.
  4. Click Create Personal Automation.
  5. Scroll down the New Automation screen until you find App, and click it.
  6. Click Choose, next to App.
  7. Find and select Roon.
  8. Click Done at the top.
  9. Select the radio button for Is Closed.
  10. Deselect the radio button for Is Opened.
  11. Click Next at the top.
  12. Click Add Action.
  13. In the search bar, type: Volume.
  14. Select Set Volume.
  15. Adjust Set volume to to the appropriate %.
  16. Optionally turn off Ask Before Running.
  17. Click Done at top.

Please let me know if this workaround is functional for you while we continue to deep dive this issue :+1:

Thanks for the workaround. This really is a stopgap solution though. I hope this issue gets fixed soon. Please let me know if you want me to test try something.

Regards Mike

Roon 2.0 or my upgrade to a new iphone 14 pro didn’t fix this unfortunately. Is there any progress? We’re you able to reproduce? Is there anything you want me to try/test?

Regards Mike

Hey @Mike_de_Munck,

My apologies here, there is progress being made but we’re still very much investigating the potential root cause of this issue.

A few follow-up questions for you:

  1. What are the specific steps you take to reproduce this issue?
  2. Do you have airplay enabled at all when this issue occurs?
  3. Does this affect specific endpoints? Does the same issue happen when only playing to your system output?

It would be helpful to the team if we could get an updated set of logs from the affected mobile devices as well:

Thanks, Mike!

Hi there @Benjamin ,

1, set the iPhone volume to let’s say about 50%. Open up the Roon app and go back to the iOS springboard. Result: iOS volume is at 100%
2. AirPlay isnt active on the phone. (There are airplay devices in the network though.
3. All endpoints are affected.

Let me try to catch some new logs this weekend.

Regards Mike

1 Like

Logs uploaded :+1:t3: