Roon hijacking iOS volume [Ticket In]

Hey @Rob_Magnotti,

There have not been any updates from our team on a solution for this yet. In the meantime, take a look at this thread and a potential workaround while we continue to work on a solution :+1:

Thanks for the follow up @benjamin.

One point about this remains cloudy: all the things you’re speaking about (including the linked thread) are related to the Roon Enfpoint jumping to 100%. That is not the case under discussion here: it is the iPhone volume itself that jumps to 100%… and this happens whether or not the iPhone running Roon Remote is Enabled (but not used) or Disabled.

In short, it’s likely a related issue, but quite distinct from Endpoint volume jumping.

Hoping to learn if this latter bug is also on the bug repair team’s radar? Thanks!

1 Like

Exactly.

Endpoints remain unaffected by the volume jump.

1 Like

I’m having this occur as well. It only occurs when I’m using Roon. While the suggestion of using a Shortcut helps by reducing the volume back to whatever you set (5% in my case), as long as the Roon remote app is on-screen my iPhone’s volume is at 100%.

Edit: And just to be clear, I have no problem with Roon properly controlling the volume of my endpoints. This is strictly affecting the overall volume level of my iPhone.

1 Like

@benjamin, @support

Exactly the same here. Every time I switch to or start the Roon Remote App the iPhone’s volume goes to 100%. This very annoying.

1 Like

There’s a few tickets open regarding this and similar issues.

There’s a work around with the shortcuts app.

  1. select automation on the bottom
  2. select the + top right corner
  3. create a personal automation
  4. go down the list and select app
  5. select the ‘choose’ and add Roon (I also get this with Tidal, so I added it)
  6. also select closed as this is when it’ll happen
  7. hit next and add action
  8. type in volume in the search bar (vol is enough)
  9. select set volume. I have mine at 25%
  10. select next and disable ask before run
  11. then select done

This is a work around given by Roon for this with this issue. I think it’s Roon/Apple related. Not just a Roon issue

3 Likes

This issue was happening to me and the above workaround helps.

I also found when my phones volume went I 100% and then went back into Roon and adjust my endpoints volume it sometimes shot the music volume to 100%. Loud as F

1 Like

I’m using the Shortcut, and it will reduce my iPhone volume back down to 5% (which is what I set in step 9.), but not until I switch away from the Roon remote app. However, as soon as I switch back to Roon, the phone volume immediately jumps to 100%. If I manually lower it in Control Center, go back to Roon, and then look in Control Center again, the volume is back to 100%. There’s no way to make the phone volume stay lower than 100% as long as Roon is the active app.

I’m having no issues with Roon properly controlling the volume of my endpoints thank goodness. That would be a much bigger issue indeed!

You can create the shortcut to apply on opening and closing the app.

1 Like

Ah yes, I can see @benjamin has already posted this in the thread. I flicked through the thread too quickly.

1 Like

Oops, I only selected to run it on Close. Does using it on Open keep the volume permanently lowered for you while the app is open/active? I’m not able to test it myself at the moment.

No, it just sets it to the prescribed percentage, you can adjust it accordingly whilst in the app. Set it low when opening.

1 Like

Ok. Thanks for posting this. Maybe this will be good enough until we hopefully get a fix, either by Apple and/or Roon.

As I said in my earlier comment, with just running the Shortcut on Close alone, my volume shot to 100% anytime Roon was open/active, and could not be manually lowered from there as long as Roon remained open. I mean you could manually reduce the volume in Control Center to zero or whatever you wanted, but when you closed Control Center, bringing you back to the Roon app, and then reopened Control Center, the volume was right back to 100%. So unless you were paying attention you might have thought you’d taken care of manually lowering it, when in reality you had not.

Edit: I’ll change my Shortcut later today and report back on the results. Fingers crossed that it’ill work at keeping the volume phantom menace under control.

2 Likes

@Menzies it appears that adding Open to the Shortcut isn’t working for me at keeping the volume under control, after initially appearing to. I turned on notifications, and although I’m being notified the automation ran when I opened Roon, when I go to Control Center, the volume is at 100%.

Btw, the only apps open on my phone are Roon, and Safari with one tab … the Roon forums.

Edit: Just for clarity, I have an iPhone 13 on iOS 16.1, as well as the latest Roon 2.0 versions on everything. I just noticed there’s a new iOS version 16.1.1 that’s recently been released. I’m downloading it now to see if that might miraculously contain a fix. If you don’t hear otherwise from me, then assume it did not.

How odd. It works for me. iPhone SE2 on iOS 16.2



When you look at the automation, does it look like these screenshots

I’ve tried it with fixed volume and Roon controlled volume and it works for me

@Menzies, my Shortcut settings are exactly like yours except I set the volume to 5% and I enabled Notify When Run.

Did you mean 16.1? I just updated to 16.1.1 and that appears to be the latest version:

But the exciting news is I’m happy to report that, at least for the moment, updating to 16.1.1 appears to have fixed the issue, and my iPhone volume is now staying at 5% as I move back and forth between Roon and other apps!

Edit: of course we still need a permanent fix rather than a work around by the use of Shortcuts. If I disable the Shortcut automation, the volume still jumps to 100%.

Edit2: it looks like I spoke too soon. After re-enabling the automation, the volume is back to jumping to 100%. :sob:

I’m stumped. I have tried it on iPads iOS15.7.1, 16.1 and iPhone SE2 iOS16.2 beta. It all works.

I wonder if the beta release contains the fix?

Edit: what happens for you if you disable the automation?

Nope, it doesn’t work for me now. I think I’m going back to using my Samsung M52. I have no adverse effects yet but I don’t want experience any either.

Would be good if @benjamin could provide an update. I know there was an update on another thread. Just curious in the progress.

1 Like