Roon hijacking iOS volume [Ticket In]

This is not the only way Roon hijacks iOS :-(. Say you are playing music through YouTube Music or other app. When you open Roon it pauses YouTube. This is very likely a violation of iOS standards.

Kids and wife in bed, I dare not find out. Usually music can end up full volume (although hasn’t for a good while now).

1 Like

That may dependent on the current audio device selected in Roon i.e. the IOS device. I’m certainly no authority on IOS standards but if what you state is correct there numerous apps committing the same violations, eg. Naim, Qobuz, Tidal, Amazon Prime to name just a few that override playback ….

Hey @Geal_us_Dearg_a_suas, have you felt brave enough to disable the automation and see if your volume will remain under control? While it would be nice to know if iOS 16.2 Beta might actually contain a fix for this issue, I completely understand your hesitation. If it ever starts functioning correctly for me again, I’ll probably be reluctant to install any new Roon or iOS update ever again. :wink:

Cheers!

I dare not. I’ve been watching my phones and iPads erratic behaviour with the automation in place. I have been using my Samsung Android phone for now.

1 Like

Smart man. Plus I’d never want to be in the crosshairs if you disabled it and then couldn’t get it to work properly again (or blew a speaker … yikes). I’d never be able to forgive myself!

Thanks so much for taking the time to troubleshoot things with me. I really appreciate it.

1 Like

Roon’s hijacking of the iOS volume leve has been an issue for me since I began using Roon in 2020. My specific case seems to be when using a Bluesound mini powered speaker as the Roon endpoint. The “volume control” setting is “device volume”.

When controlling that endpoint from the iOS Roon Remote app, my iPhone volume gets set to 100%.

I’ll try the automation work-around suggested and provide feedback.

1 Like

The automation works for me.

Thanks so much for support providing this solution!

2 Likes

Happened again yesterday morning, while baby in bed.

FYI, enabling lock screen controls(beta) under app settings appears to stop the iPhone volume from maxing out. At least for me.

Thanks Rob… the workaround is working as advertised here so far too.

@benjamin hi there. A new build was released yesterday and still no fix for this long-standing issue. A ticket has been in for quite a while now, is there a fix on the horizon?

Regards Mike

Just wanted to say that this didn’t work for me. I started getting some weird volume changes occurring randomly. I have an all Sonos setup so that very likely has something to do with it as I also have issues trying to use Spotify:Connect with my setup outside of Roon.

The other things that I’ve reported previously when trying to use the Shortcuts automation are still not working correctly either.

Edit: for clarity sake, I should add that the Spotify:Connect - Sonos - lockscreen/volume button control issues are not new. It’s a known issue that goes back years and only affects some users, like yours truly :cry: