Roon Hung Up On Log-In

Hi Guys,
I am stuck and could use some help! Our house had a power failure last night resulting (long story) in my having to use OS X Time Machine to bring everything back to normal. The good news: it worked (after 14 hour in the “Restore” mode!).
The bad news is that, for some reason, Roon now gets hung up when I’m signing in. The Roon logo just keeps grinding
away in the middle of my screen but never moves on to the next stage. ( Roon is taking my password with no problem.)
I have had no problems with Roon for many months until this. Anyone know what I need to do?
Thanks in advance!
Petridish (Geoffrey Cole)

Hi Geoff,

We saw a similar issue, but with a new machine in this thread.

Let’s drop some flags for @kevin and @vova to assist.

Thanks andybob!

Hey Geoff,

Unfortunately, Time Machine is not supported for backing up Roon.

Because Roon’s database is constantly updated in the background, programs like Time Machine tend to save random pieces of Roon’s database, instead of saving a full snapshot of the database at a given point in time. This generally means that when you restore, you get a mix of different files from different times, resulting in corruption.

Sorry for the trouble here @petridish. Have you done any manual backups you can fall back on?

Hi Mike,
I have not been backing up my Roon library (though I certainly will be from here on in!) So… what would be my next steps for getting everything back to normal?
Thanks Mike!

Hey @petridish – sorry again for the trouble here.

Generally, there’s very little we can do about this class of corruption. Usually this type of backup process renders the database beyond repair, but if you’ve put a lot of work into your database (such as making lots of edits, or building lots of playlists), we can try to take a look at it. I’m not optimistic, but if that’s the case we’ll see what we can do.

If you’re not particularly attached to your database, you can just delete your Roon folder, install from scratch, and log in.

Just let me know how you’d like to proceed here Geoff, thanks!

Hi Mike,
I have not put alot of work into the Roon database so I guess I will install from scratch. Is there anything special I need
to know before I do the install?
Thanks Mike!

Ok, well at least nothing important was lost :smile:

I think this should be what you need:

Then just reinstall from our website and log in.

Hi Mike,
As you advised, I uninstalled Roon from my Mac and then reinstalled it. It went without a hitch-- however, when I tried to
use the Roon remote app on my iPad I got the same message many have reported here:“Waiting for Remote Library, Roon is still trying to connect…” (etc).
I have followed all the troubleshooting suggestions including checking for firewalls and making sure the IP networks and netmasks are compatible on my Mac and my iPad. Below is the additional info you needed:
The Roon Main Install on my Mac:
OSX 10.11.3 (El Capitan)
Firewall is disabled
The Roon Remote Install on my iMac:
iOS: 9.2.1
Firewall: Disabled
Mike, can you help me figure out what to do next to get the Roon Remote working?
Best Regards,

Hey @petridish – let me make sure I’m understanding the current setup, then I’m sure we can get this resolved.

OK, so you uninstalled completely as described at the link I shared above. So you’ve had to log in, set up your storage and outputs again, etc. Correct?

If I’m understanding the above there may actually be a simpler solution here – every time you install Roon fresh, a unique ID is generated for that install, and each remote is going to remember that ID and look for it on startup.

Before we troubleshoot further, I’d like to confirm your iPad isn’t looking for your old install as opposed to the new one, since the troubleshooting instructions don’t cover this case.

Can you let me know exactly what you’re seeing on the iPad? Is there a button that says “Select a different library?” That may be what you need to tap here, but let me know if you’ve already tried that, or if I’ve misunderstood anything above.

Thanks Geoff!

Hi Mike,
To your first question, I did uninstall Roon exactly as described in the link you provided. As to your second question, I am getting the button that say "Select a different library’ on the lower left of my iPad screen at startup. Good news, I hope!
(I have not tried that button yet for fear of losing access to my music!) So, before I try it myself, can you tell me what I should do next?
Thanks again, Mike, for all your help!

Since you started a new library (when you did the fresh install), you should be able to just click the button, select the library, and off you go!

Let me know if you have any trouble, but I think that should be it Geoff. Enjoy!

Thanks Mike–it’s working perfectly!

1 Like