Roon installation on headless pc

hi, i would like to install roon on a headless pc that in connected to my usb DAC. unfortuntaely, i am getting an open gl error. my hope is to install roon on the pc and then control it using the new ipad app. is this a supported configuration? i’ve gone through some of the forum threads and it sounds doable, and so not sure why i am unable to install. any advice?

another configuration i would like to try is install roon on a larger server in my basement and have it “steam” to a low powered pc connected to the dac. again, control via the ipad app. is that currently doable or do i need to wait until something called roonspeaker is out?

thank you! hammer

You should install RoonServer, it’s a separate download and it doesn’t require OpenGL. You can then set it up using tour iPad as remote.

You can’t stream to the Server as far as I kniw, so the Basement is for a later time.

where do i download roonserver? thanks!

It’s in here:

Thanks. Got it installed and the iPad app recognizes the server. However, when I attach storage, I see Roon’s adding music to library dialog box counting down the files, but nothing is being Added or Identified. Any ideas? My files are .flac and .dsf files.

In terms of setup, I have 1) roonserver installed on a headless PC connected to my USB DAC and iOS app on my iPad Air 2. The app sees the PC.

The issue is after scanning and counting down the files, none of the songs are added to my library.

Thanks, I am so close!

No clue here, at least .flac should work. Mine showed them directly.
Where is your music stored, and are file/folder permissions correct?

Yes, the files are on a mapped drive on the PC running Roon server…tried several times and still no luck!

Also tried logging out and then back in and still no luck…the software sees the files as it counts down the number of files, but issue is none of them are being added to my library.

Any thoughts?

@mike will be able to help if we can’t.

In the meantime, would you be able to take a pic of your settings/storage tab and post it ? That may provide a clue as to why this is happening.

here’s a screen shot,…there are only music files on z:\

but i’ve tried enabling and disabling the other options and it make no difference…none of the files are being added…thanks!

Could the problem be that I need to install something besides roonserver?

I didn’t have to install anything other than Roonserver. It starts up two processes, once called RoonServer and the other called RoonAppliance.

This is my Storage tab:

As you can see, I have some additional text noting a folder as “Connected” and giving a Track count.

I suspect that at least some parts of RoonServer are not seeing the music on your Z drive. Is there a music directory on that drive or are all your album folders in the root directory ?

Also, try Z:/ or Z:\

Can’t wait until I see my music…that’s a beautiful picture!

I think “connected” is only for network drives. I just switched to a network drive and now it says “connected/realtime”, but still no luck having Roon add the tracks to my library. :frowning:

All my music folders (one folder per album) are in the root folder.

I do see it counting the number of tracks, but none of the tracks are being added.

My watched music folder is actually an SSD in the Brix unit where the core is running but connected as a network folder. It might be worth giving the Z:\ drive a network name and trying to connect it that way.

Yes, when I now connect as a network folder, it says connected/ realtime and when I first connect, I can see Roon counting the files it found (some 30,000), but issue is none of them are being added to my library! So strange.

Hmm. I haven’t heard of that before; sounds like a problem above my pay grade :smiley:

@mike or one of the other devs will check in and hopefully be able to set things right.

update: I tried the same music source from a full install of roon on a different pc and the musics files are added no problem.

So it appears the problem is with my ipad/roonserver setup.

Still trying to get ipad/roonserver to add files my library. Any ideas on what to try next?

Is it by any chance the fact that you are running 2 instances of Roon as a server. If one PC is acting as a Roon main PC then the server cannot. Fairly sure you can only run one at a time looking at the same folder.

No, just one instance of server is running…I only installed the full version on another pc to make sure my music files are okay. And that pc is now off and the ipad remote never tried to connect to that pc.

Which PC is the licence attached to?

Note sure what that means. When I install roonserver, it does not ask me for my account info. However, when I run the iPad app, it does and that’s where I entered my info.